Jump to content

Most touchscreen issue’s explained and the reason some touchscreens are dying on P10AN01’s (Advent Vega, Viewsonic 10s, Point Of View Mobii, ect)

Guest richardmlea

Recommended Posts

Guest themooseofdoom

Signed up just to say thanks for this topic - I'd bought a Vega on ebay back in April last year that I knew from the description simply had a bad ROM flash problem. Got that sorted a few minutes after receiving it but it had an unresponsive stripe in a perfect line about an inch wide from top to bottom right down the middle of the screen in portrait mode/across in landscape. I was convinced it was a physical fault - I'd tried all the ROMs available at the time and got nowhere with the shuttle tools or your other fixes - even tried the iron just in case it was a detachment problem. I was just about to order a bargain basement tablet on Amazon this morning then remembered the Vega sat in the drawer and thought I'd have one last search for repair tips and found this. Oddly, it didn't show any problem with the firmware for the touch screen - when I checked the TPUtility it showed a valid version but after flashing to a different FW the dead stripe moved (ended up with the reversed strip issue). A few more tries with different FW and I ended up back on my original version numbers but everything working. Vega is now happily running VegaCream RC2 with no issues. (Apologies for the formatting, for some reason IE or the forum code isn't liking 'Enter'.

Link to comment
Share on other sites

The screen on my Vega has just become completely unresponsive, at what point in the steps in the OP would I find if I was going to get any response at all from the screen - in other words after running the tputility do I need to flash the next rom before getting any response or should I be able to get some sort of response even if not calibrated properly before that ?

Sorted :) used the viewpad rom and the screen came back to life, flashed on a new rom and calibrated a few times and now works nicely.

Edited by piran
Link to comment
Share on other sites

Guest maddog1979

I need help.. ready to fleabay this or smash it up.

My 101H touchscreen as been playing up for months. Over sensitive in places, dead in others, double touches, ghost touches etc.... I've tried all the firmwares and whilst sometimes i can get the testrom (1.10.4) to work perfectly, as soon as i flash any other rom including the original advent one it just goes back to playing up..

Any help...

Link to comment
Share on other sites

  • 1 month later...
Guest cichy80

Hi guys

Unfortunately one tablet did not go after the upgrade. I noticed that they are not soldering the pins in ITE. After resoldering ITE, FW works without a problem.

1st photo.

Yellow / Orange pins not soldering.


2nd photo.

Resoldering pins OK.


Link to comment
Share on other sites

  • 4 weeks later...
  • 4 months later...
Guest Alexzandro

Thanks Thanks Thanks, RICHARD !!!!! :) :) :)

Have to say that I also had the reply "cannot load fw, upgrade failed" ( or something like that ) with fw 99, tried again with fw 101 and it worked like a charm !!!! My device is POV MOBII, now resurrected .

Great forum , great people.

Regards again

Alessandro :D :D :D :D :D :D :D

Link to comment
Share on other sites

  • 5 months later...
Guest Weliwarmer

Hi All,


I know this is an old post but I'm stuck.


I have gone round and round trying all the firmware versions on this thread and after succeeding in getting the touch working, it's now got the lower cm reversed problem.


These are the versions I have tried, in many different orders over many many evenings of trying.




Lots of different versions of these from all the links on this thread.


Has anyone a link to download the newer firmware and config?


Or has anyone any other recommendations?


Thanks for your help,



Link to comment
Share on other sites

  • 3 years later...
Guest Ativirus

I was wondering if anyone still has the firmware file for the viewpad 10s. Mine has just developed the firmware 99 issue & I use the Tablet a lot for reading while I'm waiting at the doctors with my invalid brother.   Thanks!

Link to comment
Share on other sites

  • 6 months later...
  • 5 months later...
Guest addy_86

Hi, My advent touchscreen is not working can anyone please provide working links. i have tried USB mode but can't seem to get my mouse working


Link to comment
Share on other sites

  • 2 years later...
Guest hernankano
40 minutes ago, JHAres said:

Hi everyone...

Here you can find a copy of my old folder with the touchscreen fix related files:


Let me know is the link is working and if you got all files you need... 

Kind regards...!


files and links are working ok, you save me! my touch is working again, i attach the files if some one need it in future. GRACIAS

fw_cfg.zip Touchscreen Firmware.zip TpUtility2_20110322_0.apk

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.