Jump to content

[Q] Has anyone had any reception problems?


Guest Doogie Howser
 Share

Recommended Posts

Think that's the route I'm gonna go down, My new phone's dual sim so I can run with both, I just thought I'd have to stick a tenner on to receive data to check the 3G.

Link to comment
Share on other sites

With my OSD sometimes my signal just completely drops or sometimes says that there's no sim inserted, I don't know why this happens but it restores back to normal after I restart the phone

Link to comment
Share on other sites

With my OSD sometimes my signal just completely drops or sometimes says that there's no sim inserted, I don't know why this happens but it restores back to normal after I restart the phone

Are you in the UK?

I've seen that the Asian guys have had problems.

Link to comment
Share on other sites

Are you in the UK?

I've seen that the Asian guys have had problems.

Yeah I live in London but I am Asian :P

Edited by Raihan42
Link to comment
Share on other sites

I'm in Helmshore and reception is generally fine. I've still got the OSD, I was about to look at something else because the GPS had stopped working but there was an update last week that has fixed it!

stu

Link to comment
Share on other sites

I'm in Helmshore and reception is generally fine. I've still got the OSD, I was about to look at something else because the GPS had stopped working but there was an update last week that has fixed it!

stu

Cheers got the Orange/EE sim and 3G has been brilliant, super fast all over the Valley, Can't believe i stuck with O2 so long I thought that's how slow 3G was!

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.