Jump to content

ZTE Acqua stock ROMs


Recommended Posts

  • Replies 61
  • Created
  • Last Reply

Popular Posts

There's a new B06 version for the TMN official ROM for the Acqua. [here, version B06] No idea what's new, or if is rootable too

Guest papars

The recovery file is extracted from the official ROM update.zip or from a CWM backup?

I checked the new ROM and I see this in build.prop

ro.build.sw_internal_version=TMN_P740AV1.0.0B05

B05 ? Also this is newer that other original versions
ro.com.google.gmsversion=4.0_r7

Build dates of the current original versions:

German B04: June 7 2012

Greek B02: July 24 2012

Slovak B07: August 1 2012

TMN B03: September 10 2012

TMN B04/B05 : December 25 2012 (!)

Edited by papars
Link to post
Share on other sites
Guest Di0g0

Can you check the partition sizes on the the TMN official ROM?

The TMN ROM does not seem to fit into my Wind Acqua.

How can I check that? Also on my phone info I find the follow: TMN_P740AV1.0.0B04 (Compilation Number) .

And the recovery is extracted from the oficial update.zip

Link to post
Share on other sites
Guest papars

open a terminal window or from adb shell and type the command df.

At the top of the list you will see the size and other info about the file system.

In my acqua is like this:

Filesystem Size Used Free Blksize

/system 393M 367M 25M 4096

Link to post
Share on other sites
  • 2 weeks later...
Guest papars

ZTE R22 (Telecom New Zealand) is Acqua?

Original firmware is here: http://wwwen.zte.com...38922447658.zip

Version is B07, 12 July 2012

So far the latest official version is TMN (B04/B05 25 Dec 2012)

If is allowed I can post a link with a CWM flashable version of a slightly slimed version of TMN (removed chrome but added root)

Edited by papars
Link to post
Share on other sites
  • 1 month later...
Guest epyloxias

So, the owners with "Greek" Acqua should install the German rom in order to get wifi to work with JB, right? Should we install the German recovery too? or is KonstaT's enough for our "job"?

Link to post
Share on other sites
Guest epyloxias
So, the owners with "Greek" Acqua should install the German rom in order to get wifi to work with JB, right? Should we install the German recovery too? or is KonstaT's enough for our "job"?

Installed successfuly german recovery, but not the rom... Anyone to give me a step by step guide?

Edited by epyloxias
Link to post
Share on other sites
  • 1 month later...
Guest MJonMoDaCo

Thank you to the clever clogs who got the NZ recovery uploaded. Owe you big time, even though CM 10.1 is confirmed as working on this phone...

And I really like it, actually...

Link to post
Share on other sites
  • 1 month later...
Guest Skinz1984

After the wifi at my home didn't work with my acqua [Australian Telstra Urbane] I tried flashing one of the stock roms to see if that would help. I flashed the portugese stock recovery and rom [because it is the most recent] without any issues. After this, however, I could not flash any other recovery using fastboot. I managed to fastboot boot into the cwm recovery, and then flash the zip. So I now have CWM back on and my previous rom. It wont let me even flash the portugese recovery. It says it is sending the recovery, and then it pauses at 'writing...' when I finally disconnect the cable it states 'too many links'

I have tried different usb cables and ports, but I don't see why that would matter as it was on the same cable and port when I first flashed it. Any ideas?

Edited by Skinz1984
Link to post
Share on other sites
Guest papars

What rom you try to install? You can only install official roms through their recovery. I you have cwm installed official file flashing will not work.

Did you test Cm10.1 it works ok.

Link to post
Share on other sites
Guest Skinz1984

I kept trying to flash the stock Recoveries but to no avail. Eventually by using fastboot boot I was able to install the nz rom and that put me back on a different stock recovery and stock rom. From there I could flash the recovery again

Link to post
Share on other sites
Guest MJonMoDaCo

I kept trying to flash the stock Recoveries but to no avail. Eventually by using fastboot boot I was able to install the nz rom and that put me back on a different stock recovery and stock rom. From there I could flash the recovery again

If you have a rooted device with terminal emulator installed you can do the following:

1. Start Terminal Emulator

2. su (give superuser permissions if you haven't already)

3. dd if=/mnt/sdcard/path/to/recovery/file.IMG of=/dev/block/mmcblk0p17

and that should fix it. Perhaps these instructions should be added to the OP?

As an aside, I dug into the NZ ROM and found, to my dismay - the medion recovery (for German ROM). Suffice to say that didn't stay there for long!

Link to post
Share on other sites
Guest ricardompnunes

hello, I have a TMN A15 with a custom ROM 10.1 from Konstat, everything works fine. but I like to test the new version TMN b06.

after doing the recovery with the B03 version ZTE UPDATE TOOL does not find latest version and is available for download version B06

how can I make updade the stock ROM with CWM or ADB fastoot

sorry, the google translation.

Link to post
Share on other sites
Guest MJonMoDaCo

hello, I have a TMN A15 with a custom ROM 10.1 from Konstat, everything works fine. but I like to test the new version TMN b06.

after doing the recovery with the B03 version ZTE UPDATE TOOL does not find latest version and is available for download version B06

how can I make updade the stock ROM with CWM or ADB fastoot

sorry, the google translation.

You certainly can't flash stock rom with CWM. The instructions for flashing your stock recovery is in the post above yours! Since you're using google translate, we'll forgive you, but you'll need to make sense of the next instructions...

1) Download stock recovery (and ROM!) for your phone from the original post, and save/transfer it to your SD card's root directory.

2) Since you're on a CyanogenMod custom ROM already, open up Terminal Emulator

3) Type 'su' (without quotes) and give superuser permissions when it asks (if you haven't done so already)

4) type 'dd if=/mnt/sdcard/<name of recovery file>.img of=/dev/block/mmcblk0p17 (This flashes the recovery partition with the stock recovery)

5) type 'Reboot recovery' and it will take you to the stock recovery

6) format user data (I sure hope you backed up!!)

7) Select Zip from SDcard and install.

8) Smile.

Edited by MJonMoDaCo
Link to post
Share on other sites
Guest ricardompnunes

You certainly can't flash stock rom with CWM. The instructions for flashing your stock recovery is in the post above yours! Since you're using google translate, we'll forgive you, but you'll need to make sense of the next instructions...

1) Download stock recovery (and ROM!) for your phone from the original post, and save/transfer it to your SD card's root directory.

2) Since you're on a CyanogenMod custom ROM already, open up Terminal Emulator

3) Type 'su' (without quotes) and give superuser permissions when it asks (if you haven't done so already)

4) type 'dd if=/mnt/sdcard/<name of recovery file>.img of=/dev/block/mmcblk0p17 (This flashes the recovery partition with the stock recovery)

5) type 'Reboot recovery' and it will take you to the stock recovery

6) format user data (I sure hope you backed up!!)

7) Select Zip from SDcard and install.

8) Smile.

thanks for the help, I had already done what is in the post above mine, problem is it gives me this error messages "and: fail to VERIFY whole-file signature e: signature verification failed instalatiion aborted."

what I wanted is something that bypasses signature verification, if possible!! or something to correct the problem signature verification.edited 17set2013

Anyone know, because gives this error? "fastboot update update.zip - archive does not contain ´android-info.txt` - archive does not contain ´android-produt.txt´ - error: update package has no androi-info.txt or android-produt.txt"

excuse my english

Edited by ricardompnunes
Link to post
Share on other sites
Guest SandStorm_RS

I followed those instructiosn to install this new stock rom and worked flawlessly.

But, my terminal emulator was the one from the "rom toolbox" app I often use.

Also, my CWM was an ancient one, from the 5.x version.

Well, at this moment I'm restoring everything with the default backup and restore app. Tested the camera, the flash still sucks making a blank area, so, they didn't really fixed the flash operation mode.

All in all, I'm about to remove the backup app APK's, flash CMW again and go for a custom ROM.

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.