Jump to content

[DEV][ROM][CM10+AOKP+PA] PAC-man ROM v19.3.0 (updated 16/7/13)


Guest robt77
 Share

Recommended Posts

I cant add new Access Point Names.Everytime i go to mobile network/apn it just returns me to the last screen and now i dont have internet.Is there anyway i can add them indirectly?Do i have to do a factory reset on cm10 before instaling pac?

Everything else works just fine and overall its a great rom.Tnx for your time and effort

Link to comment
Share on other sites

To be honest I don't know anything about APNs. Before installing any different ROMs you should wipe data before flashing the ROM. I would suggest to do a full wipe and then reinstall to see if that fixes the problem.

I cant add new Access Point Names.Everytime i go to mobile network/apn it just returns me to the last screen and now i dont have internet.Is there anyway i can add them indirectly?Do i have to do a factory reset on cm10 before instaling pac?

Everything else works just fine and overall its a great rom.Tnx for your time and effort

Link to comment
Share on other sites

To be honest I don't know anything about APNs. Before installing any different ROMs you should wipe data before flashing the ROM. I would suggest to do a full wipe and then reinstall to see if that fixes the problem.

I did that.What wanted to know is if i didnt do a full wipe,will i be able to keep the old settings?

Link to comment
Share on other sites

And something extra from my 2day experience witn PacMan : Sometimes after 5 minutes or so, I get forceclosed from wifi... Ofcourse it "revives" but... Is that some kind of bug I guess?

Link to comment
Share on other sites

Thanks for your comments :D I will say it again, all credit to KonstaT he did all the work for Jelly Bean on our devices, I just compiled the ROM, am working on 4.2.2 but running into issues that I hope I will resolve

Edited by robt77
Link to comment
Share on other sites

As this is a three in one ROM I don't if the dirty flashing will work. You can try and see if it works?

I just tried dirty flashing it over my old cm10 and it worked.I still cant add new apns but the old ones are still there and that is all i really needed.No other issues but the clock force closing at startup and i have to unlock and then lock the sim pin so i can get signal. Im just glad that i can finally enjoy this awesome rom with mobile internet.

Tnx a lot for the rom again i was waiting for something like this for a long time. :)

Edited by Something Wierd
Link to comment
Share on other sites

I'm trying to figure out my wifi has problems from time to time. I look in logcat and I see these lines:

E/WifiHW  (108): Failed to open wlan fw path param (No such file or directory)

E/SoftapController(108): Softap fwReload - failed: -1

E/WifiStateMachine(375): Failed to reload STA firmware java.lang.IllegalStateException: command '157 softap fwreload wlan0 STA' failed with '400 157 Softap operation failed (No such file or directory)'

W/CommandListener(108): Failed to retrieve HW addr for wlan0 (No such device)

D/CommandListener(108): Setting iface cfg

E/WifiStateMachine(375): Unable to change interface settings: java.lang.IllegalStateException: command '159 interface setcfg wlan0 0.0.0.0 0 down' failed with '400 159 Failed to set address (No such device)'

then few seconds later these:
WifiStateMachine(375): Failed to set country code gr

WifiStateMachine(375): Failed to set frequency band 0

While looking at logcat these also pop up very frequently:
E/Trace   (18875): error opening trace file: No such file or directory (2)

E/Sensors (375): sensor_hal set_prox_threshold_data error


E/rmt_storage(123): write_log_file: [MyTag]open: fd=-1

E/rmt_storage(123): block rmt_storage client thread


GlsClient-query(676): requestFailed

QC_MP3DEC(8207): component_init[0x4117f008]component init: role = OMX.qcom.audio.decoder.mp3

and also a list of bluetooth related errors but BT seems to be working fine. (at least pairing with my car)

Link to comment
Share on other sites

Some observations.

The "error opening trace file" is related to gapps. Is it related to the ROM or is a general gapps issue? Can somebody check this?

gapps also throw several warnings related to "face unlock".

The "failed to set country code gr" is strange. My locale is set to gr but wifi region is set europe from the relevant settings menu.

Link to comment
Share on other sites

I got the same message about the ASOP keyboard closing so I downloaded the Google Keyboard from here and saved it to my SD card

http://android.sc/of...e-for-download/

then I went to File Explorer to install the apk, you need to allow non market apps to be able to install in Settings

Now you can change the new Google Keyboard to be the default one, and when that's done you can go to Settings> Apps> All> Android Keyboard, and choose to stop and Disable it - that gets rid of the ASOP Keyboard errors

Hope that helps....

Edited by mc9662
Link to comment
Share on other sites

After several days with this ROM on a Acqua I must say that it runs quite well.

Things I notice:

a. Battery. It can barely last a day with minimal use.

b. Wifi. Sometimes it just doesn't want to connect. Turn off/on will fix this.

c. Phone needs reboot from time to time. It starts by becoming sluggish - eventually it will reboot on its own, but while reaching this point it would be impossible to use.

Other problems I did not had with original ROM.

i. Widget locker 80% of the times just shows the background. Widgets are there but not shown. A quick press of the on button will bring back correct lock screen.

ii. Many times I find the phone unlocked in my pocket and I don't get how this can happen. I have a swipe to unlock and a pattern enabled. Soft keys and volume do nothing when phone is locked. I have the feeling that when a message arrives (missing call, SMS, email) the phone shows a pop up and unlocks. I can't replicate though...

I might try CM10 to see if I get an improvement.

Link to comment
Share on other sites

  • 2 weeks later...

Well updated device but still won't build the FM radio for my pacman cm10 ROM. When I try to build pacman 4.2 it looks if it is building with the radio but I am still getting build errors I can't get past

Link to comment
Share on other sites

Well updated device but still won't build the FM radio for my pacman cm10 ROM. When I try to build pacman 4.2 it looks if it is building with the radio but I am still getting build errors I can't get past

Regarding FM, you'll need similar device manifest update and patches for 4.1 as I released for 4.2 (1,2,3). I haven't uploaded that stuff anywhere yet but it's almost identical to 4.2. FM is still somewhat wip in cm10 when in cm10.1 it's pretty much perfect. I also have another libaudio update for cm10 but I haven't had time to make a clean cm10 build to see if anything is any better.

I'm not sure what I'm going to do cm10 sources anyway. I plan to keep it open source of course but I'm not sure if I'm going to release bunch of patches or push cm10 sources to legaCyMod repo as well. Now that cm10 has been practically dead for about a half an year I wouldn't have worry about constantly merging branches to keep them up to date.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.