Jump to content

Beta 13: MoDaCo.SWITCH HTC One support topic


Guest PaulOBrien

Recommended Posts

Guest ApexPredation

New here first post. I am up and running on the DEV version. I went ahead and got s-off to make things easy I also flashed the root zip to have all the power. So far all seems to be working great. There were a few times that the launcher on the GE side stopped working but it hasn't done it again. I'll watch for that. Also the notification drop down feels slow but it isn't terrible. So far its the best ROM I have ever flashed. Thanks for the invite.

Link to post
Share on other sites
  • Replies 1.8k
  • Created
  • Last Reply

Popular Posts

Hi all! I'm back from holiday and just clearing some urgent workload so I can update Switch! :) Top priority of course is the 4.3 update, but there are some other changes too... i'll be adding t

Now that we are seeing relatively few issues with the Beta, it's probably a good time to talk about what's coming next. First up, in the next day or so I will be making the Beta open, so anybody ca

About MoDaCo.SWITCH MoDaCo.SWITCH is a unique ROM concept for the HTC One which allows you to have two ROMs on your device (Sense and Google Play Edition) but maintaining a single set of data that

Posted Images

Guest descenpet

@Paul

I noticed /system/bin/ , /system/xbin/ and /system/build.prop are not symlinks like other directories in /system.

When switching, these are overwrittem with the files from /system/SWITCH/sense/ or /system/SWITCH/gpe/(depending on destination OS) but any changes made are not saved to current OS's directory in /system/SWITCH/ so the changes are lost upon switching back.

The changes sticks if i directly edit/add to /system/SWITCH/sense/ or /system/SWITCH/gpe/. The xposed installer issues i had earlier are also due to this.

I tried reinstalling from scratch again but it still is the same. Is it by design or is there something wrong with my installer?

On that note, i downloaded the installer 3 times, i get same md5 on all 3 but it is different from the one in first post.

Link to post
Share on other sites
Guest SeBsZ

Hello,

I'm just here to say that I'm not getting root access, at least not on the Google AOSP edition ROM. I haven't tested it on the Sense ROM, but I'm just assuming it won't work there either.

I've flashed beta1, beta8, then S-ON and then root. I just tried flashing root yet another time, but still I get permission denied when trying to access /data/data for example. I'm using clockworkmod recovery, not TWRP.

Thanks, everything else works fine so far.

Link to post
Share on other sites
Guest Lennyuk
Hello,

I'm just here to say that I'm not getting root access, at least not on the Google AOSP edition ROM. I haven't tested it on the Sense ROM, but I'm just assuming it won't work there either.

I've flashed beta1, beta8, then S-ON and then root. I just tried flashing root yet another time, but still I get permission denied when trying to access /data/data for example. I'm using clockworkmod recovery, not TWRP.

Thanks, everything else works fine so far.

Switch to twrp and try to flash root again.

Link to post
Share on other sites
Guest PaulOBrien
@Paul

I noticed /system/bin/ , /system/xbin/ and /system/build.prop are not symlinks like other directories in /system.

When switching, these are overwrittem with the files from /system/SWITCH/sense/ or /system/SWITCH/gpe/(depending on destination OS) but any changes made are not saved to current OS's directory in /system/SWITCH/ so the changes are lost upon switching back.

The changes sticks if i directly edit/add to /system/SWITCH/sense/ or /system/SWITCH/gpe/. The xposed installer issues i had earlier are also due to this.

I tried reinstalling from scratch again but it still is the same. Is it by design or is there something wrong with my installer?

This will change slightly in a forthcoming release.

P

Link to post
Share on other sites
Guest PaulOBrien
Hello,

I'm just here to say that I'm not getting root access, at least not on the Google AOSP edition ROM. I haven't tested it on the Sense ROM, but I'm just assuming it won't work there either.

I've flashed beta1, beta8, then S-ON and then root. I just tried flashing root yet another time, but still I get permission denied when trying to access /data/data for example. I'm using clockworkmod recovery, not TWRP.

Thanks, everything else works fine so far.

Trying to access it how?

P

Link to post
Share on other sites
Guest ApexPredation

I have noticed something strange, when in Facebook if I tap a photo in a post that has more than one photo in the same post, the phone vibrates when the photo opens. This happens on both sides of the switch. I have also confirmed that this doesn't happen on other phones with the same version of FB

Link to post
Share on other sites
Guest owenh10

This is not working out for me.

- Power off through long-press

- Boot into recovery

- Wipe

- Flash zip

- Wipe dalvik/cache (have also tried w/o)

- Reboot (takes a couple of minutes)

- Even on the first boot WiFi is not working.

- Went through the HTC wizard

- Switched off Fastboot

- started Switch

- got rebooted back into sense

I've tried this four times now, including reflashes, wipes and everything, to no avail.

Having same problem.

Link to post
Share on other sites
Guest Omniken

Paul,

Thank You for the invite. It's the actual first chance I'm getting to install it. I have S-On for my HTC One which shouldn't matter right? Also do I just flash Beta 1 and then Beta 8

Link to post
Share on other sites
Guest DyManic

My xposed is no longer working after switching to GE and back. Any ideas Paul?

Edit - flashing the zip again gets it working but not sure if it will survive a switch again.

Edited by DyManic
Link to post
Share on other sites
Guest FilyPhanatic

tried the zip but it didn't fix for me. still lost on switching. maybe my previous tries screwed up something in my system?

so i took the app_process from zip and manually copied it to /system/SWITCH/sense/bin/ and /system/SWITCH/gpe/bin/ then it works fine and survives through switching.

Thanks Paul, I have already tried this. It does work when going from Sense to Stock, but not the other way around. In order to get back, I needed to reinstall the S-ON kit. Is there a fastboot option in the Stock edition that I need to turn off?

Link to post
Share on other sites
Guest Android31

Thanks for the Invite.

Switch is a great Idee and nice to play with it.

But I have a Question:

Can I overwrite the Stock Sense files with a Custom Sense Rom?

Custom Sense + Google Edition would be nice

Link to post
Share on other sites
Guest cezent

Got this installed on my M7 today, straight from beta1 to beta8. I have to say its rather awesome, REALLY REALLY well done Paul! I've not spotted anything major yet but will definitely post it here if i see anything. One small thing I noticed, the MD5 checksum for the beta 1 in the 1st post is different from the actual MD5 of the ROM itself. Minor issue but just in case people might be confused (I downloaded the ROM twice to double check).

Link to post
Share on other sites
Guest FilyPhanatic

Thanks for the Invite.

Switch is a great Idee and nice to play with it.

But I have a Question:

Can I overwrite the Stock Sense files with a Custom Sense Rom?

Custom Sense + Google Edition would be nice

I can speak from experience, it isn't easy to do. I tried simply replacing the files in Beta1 with ones from ARHD, and it didn't work.
Link to post
Share on other sites
Guest Dante07

Well, it was installed for 6 hours and I must to say that is simply awesome. Obviously there are some issues, but nothing strange in a beta version. This issues are

Installed beta 1 and 8 + root package on European unlocked version with S-Off

- Some sounds (like whatsapp notification sound) not survive to the switch. Tried with rings extended, puting the files in the user folder and in the system/media folders.

- Xposed dont survive to the switch. I've installed the zip and nothing to do.

- When switch between both roms, Nova is uninstalled, The problem there isn't the popup for select the launcher, is that I've installed nova launcher prime (key) but not the app. After various tryouts I can solve it with titanium (long tap in both apps nova launcher and nova launcher prime and tap in make system app)

- I need to configure my e-mail accounts separately in both roms. I mean my work accounts (IMAP), the gmail accounts working perfectly.

- Like the others, I've others minor problems like the long time press in the power button or the widgets in nova launcher (when I switch they change or disappear)

For last I want to make a request for every betatesters, what is the best cuatom kernel for this? Is elementalX compatible? Whats the necessary process for flash? And the same for mods.

Again, thanks so much to Paul for the invitation and all for the support

Cheers

Link to post
Share on other sites
Guest boot329

I really appreciate the invite and excited to try this out! :)

Everything seems to be installed/running correctly.

I'll report back here if I notice anything unusual..

Currently using: AT&T HTC One Variant

Recovery: TWRP

Link to post
Share on other sites
Guest IcOpRo

Can anyone confirm , that after switching from Sense to Ge and back to Sense the Clock/Weather widget that's on top of Blinkfeed has no weather data, i have to click on the settings of the widget go into settings and check "Schedule Sync" every time after booting from GE to Sense.

Thanks

Link to post
Share on other sites
Guest cbrooke22

Thank you Paul for the invite. I just had a question on roms. I am a Tmobile user in the US, they have a feature called wifi calling where if you have no signal you can log into a wifi network then you can make and receive calls over the net instead of cell network. Is there a way to make their sense rom the sense portion in switch rom?

Link to post
Share on other sites
Guest AvenueTheory

Loving the ROM so far, everything is working with a few niggles here and there.

Anyone use LINE Messenger? If you activate your account in Stock Android, could you get it working on Sense? I just tried it, but it resulted in the version on the Sense ROM to crash with a black screen.

Link to post
Share on other sites
Guest mathiias

Thank you Paul for the invite. I just had a question on roms. I am a Tmobile user in the US, they have a feature called wifi calling where if you have no signal you can log into a wifi network then you can make and receive calls over the net instead of cell network. Is there a way to make their sense rom the sense portion in switch rom?

Wifi calling is not currently available on any 4.2.2 ROMs. Probably not available until TMO officially releases theirs.

Link to post
Share on other sites
Guest ne0ne

Just installed it. Everything is working fine.

Everytime I switch it boots into recovery and flashes flip.zip.

Is this normal ?

Also does anyone have any experience using bulletproof kernel with this ?

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.