Jump to content

ZTE V790 Roamer2 CyanogenMod 10.1


Guest manfromnn
 Share

Recommended Posts

 

Same link, one last time. Follow the example (physical primary only) to the letter and sdcard will work without a doubt. Or check how it's done on any other CM11 device.
 
Obviously this is wrong (sdcard -> sdcard0).
 
Also storage_list.xml is completely wrong. Non-existing(?) physical internal storage marked as emulated(!) and set as secondary (emulated can only be primary).
 
For clarity it might be also better to remove the usbdisk stuff (and it's wrong in fstab anyway). It's for external OTG USB-sticks/etc and I have no idea if it works on your device. It would need an outside power source anyway (e.g. USB Y-cable).
 
Edit. It might also help if you'd upload valid device sources. I'm certain that building jellybean (CM10) or CM-10.2 (CM10.2) wouldn't produce a working build (I only checked storage and it's not right in any branch for the Android version in question). There's not a working storage configuration anywhere so I can't even tell what the storage layout is supposed to be (physical external sdcard, physical internal sdcard (separate sdcard partition on eMMC) or emulated internal sdcard (/data/media)).

 

So manfrommn and hecatae must rebuild cm11 with these fixes. I will wait for them :D

Link to comment
Share on other sites

 

Same link, one last time. Follow the example (physical primary only) to the letter and sdcard will work without a doubt. Or check how it's done on any other CM11 device.
 
Obviously this is wrong (sdcard -> sdcard0).
 
Also storage_list.xml is completely wrong. Non-existing(?) physical internal storage marked as emulated(!) and set as secondary (emulated can only be primary).
 
For clarity it might be also better to remove the usbdisk stuff (and it's wrong in fstab anyway). It's for external OTG USB-sticks/etc and I have no idea if it works on your device. It would need an outside power source anyway (e.g. USB Y-cable).
 
Edit. It might also help if you'd upload valid device sources. I'm certain that building jellybean (CM10) or CM-10.2 (CM10.2) wouldn't produce a working build (I only checked storage and it's not right in any branch for the Android version in question). There's not a working storage configuration anywhere so I can't even tell what the storage layout is supposed to be (physical external sdcard, physical internal sdcard (separate sdcard partition on eMMC) or emulated internal sdcard (/data/media)).

 

I used storage_list.xml from hire, and on my last build with boot.img from alekcacko sdcard is worked, but only external.  But with this boot.img not recognized sim, although built boot.img I get IMEI from rild socket № 1 and STK in menu of applications.

KonstaT, in one of the build I was getting FM worked. Could this be an important for RIL?

Edited by manfromnn
Link to comment
Share on other sites

Hey, I changed ramdisk in the boot image. The ramdisk is found from another 7x27a device with yaffs2 filesystem. But after that, the screen rotating is not working. So this is a temporary fix. I ned hecatae and manfromn to rebuild cm11 with fixes konstat gave. OK? hecetae rebuild the rom.  And fix the cm11 sd card.

Link to comment
Share on other sites

I used storage_list.xml from hire, and on my last build with boot.img from alekcacko sdcard is worked, but only external.  But with this boot.img not recognized sim, although built boot.img I get IMEI from rild socket № 1 and STK in menu of applications.

KonstaT, in one of the build I was getting FM worked. Could this be an important for RIL?

CAF doesn't have anything for msm7x27a that's beyond Android 4.1. That's when they EOL'ed the platform. Just read the Google reference first and copy/paste the relevant sdcard stuff from my atlas40 cm11 configs. That should work if you had it working in cm10.2(?) that way. What kind of internal sdcard is this device supposed to have, emulated? I've removed mine for a reason (emulated storage can only be set as primary).
 
FM has nothing to do with RIL. Different radios.
 
Do you even have rild running for the second slot? I had the service for a while but no one really bothered to test anything on a dual-SIM device.
Link to comment
Share on other sites

Hey I fixed sd card with tutorial of konstat

But what about wifi in cm10.1?

All build by manfromn are fault.(but thank to him for building these at least :D

Cm10 doesn't boot

cm10.1 has wifi problem

cm10.2 has wifi and sd card problem

cm11 has some problems.

How to fix atleast cm10.1 wifi problem?

Edited by alekcacko
Link to comment
Share on other sites

 

CAF doesn't have anything for msm7x27a that's beyond Android 4.1. That's when they EOL'ed the platform. Just read the Google reference first and copy/paste the relevant sdcard stuff from my atlas40 cm11 configs. That should work if you had it working in cm10.2(?) that way. What kind of internal sdcard is this device supposed to have, emulated? I've removed mine for a reason (emulated storage can only be set as primary).
 
FM has nothing to do with RIL. Different radios.
 
Do you even have rild running for the second slot? I had the service for a while but no one really bothered to test anything on a dual-SIM device.

 

Yes I saved rild running for second slot from my stock ramdisk. I do not know, maybe I'm wrong, but it may be that the ramdisk during the start of the rom is creating a directory structure of the second "virtual" device, and the second ril socket is working on a "virtual" device, but has a soft touch with the basic device? dev/mtd

Edited by manfromnn
Link to comment
Share on other sites

I corrected my locai_manifest from hire, updated the CM11 repo, made device and kernel fixes from latest KonstaT's commits and applied patches from hire.

 
java version "1.7.0_60"
Java SE Runtime Environment (build 1.7.0_60-b19)
Java HotSpot 64-Bit Server VM (build 24.60-b09, mixed mode)
 
javac 1.7.0_60
 
gcc version 4.7.3 (Ubuntu/Linaro 4.7.3-12ubuntu1)

 

And now I get this error:

target thumb C++: libwebcore <= external/webkit/Source/WebCore/platform/graphics/WidthIterator.cpp
target thumb C++: libwebcore <= external/webkit/Source/WebCore/platform/graphics/android/BitmapAllocatorAndroid.cpp
external/webkit/Source/WebCore/platform/graphics/android/BitmapAllocatorAndroid.cpp: In member function 'virtual bool WebCore::BitmapAllocatorAndroid::allocPixelRef(SkBitmap*, SkColorTable*)':
external/webkit/Source/WebCore/platform/graphics/android/BitmapAllocatorAndroid.cpp:62:75: error: no matching function for call to 'SkImageRef_ashmem::SkImageRef_ashmem(WebCore::SharedBufferStream*&, SkBitmap::Config, int&)'
external/webkit/Source/WebCore/platform/graphics/android/BitmapAllocatorAndroid.cpp:62:75: note: candidates are:
In file included from external/webkit/Source/WebCore/platform/graphics/android/BitmapAllocatorAndroid.cpp:30:0:
external/skia/src/images/SkImageRef_ashmem.h:28:5: note: SkImageRef_ashmem::SkImageRef_ashmem(SkFlattenableReadBuffer&)
external/skia/src/images/SkImageRef_ashmem.h:28:5: note:   candidate expects 1 argument, 3 provided
external/skia/src/images/SkImageRef_ashmem.h:22:5: note: SkImageRef_ashmem::SkImageRef_ashmem(const SkImageInfo&, SkStreamRewindable*, int)
external/skia/src/images/SkImageRef_ashmem.h:22:5: note:   no known conversion for argument 1 from 'WebCore::SharedBufferStream*' to 'const SkImageInfo&'
external/skia/src/images/SkImageRef_ashmem.h:20:7: note: SkImageRef_ashmem::SkImageRef_ashmem(const SkImageRef_ashmem&)
external/skia/src/images/SkImageRef_ashmem.h:20:7: note:   candidate expects 1 argument, 3 provided
external/webkit/Source/WebCore/platform/graphics/android/BitmapAllocatorAndroid.cpp:65:79: error: no matching function for call to 'SkImageRef_GlobalPool::SkImageRef_GlobalPool(WebCore::SharedBufferStream*&, SkBitmap::Config, int&)'
external/webkit/Source/WebCore/platform/graphics/android/BitmapAllocatorAndroid.cpp:65:79: note: candidates are:
In file included from external/webkit/Source/WebCore/platform/graphics/android/BitmapAllocatorAndroid.cpp:29:0:
external/skia/include/images/SkImageRef_GlobalPool.h:56:5: note: SkImageRef_GlobalPool::SkImageRef_GlobalPool(SkFlattenableReadBuffer&)
external/skia/include/images/SkImageRef_GlobalPool.h:56:5: note:   candidate expects 1 argument, 3 provided
external/skia/include/images/SkImageRef_GlobalPool.h:18:5: note: SkImageRef_GlobalPool::SkImageRef_GlobalPool(const SkImageInfo&, SkStreamRewindable*, int)
external/skia/include/images/SkImageRef_GlobalPool.h:18:5: note:   no known conversion for argument 1 from 'WebCore::SharedBufferStream*' to 'const SkImageInfo&'
external/skia/include/images/SkImageRef_GlobalPool.h:15:7: note: SkImageRef_GlobalPool::SkImageRef_GlobalPool(const SkImageRef_GlobalPool&)
external/skia/include/images/SkImageRef_GlobalPool.h:15:7: note:   candidate expects 1 argument, 3 provided
make: *** [/home/manfromnn/android/System_CM11/out/target/product/roamer2/obj/STATIC_LIBRARIES/libwebcore_intermediates/Source/WebCore/platform/graphics/android/BitmapAllocatorAndroid.o] Ошибка 1
make: *** Ожидание завершения заданий...
Can you suggest how I can fix this?
Edited by manfromnn
Link to comment
Share on other sites

 

I corrected my locai_manifest from hire, updated the CM11 repo, made device and kernel fixes from latest KonstaT's commits and applied patches from hire.

 
Can you suggest how I can fix this?

 

It's a brand new Android subversion you're building and little patience is required.

 

androidarmv6 has fixes for the old webkit but I haven't tested that myself yet.

Link to comment
Share on other sites

KonstaT, with your last patch for skia managed to build new rom. At this rom not working trebuchet, and  I picked up it from a previous build. Initializing storage I copied from your buildconfigs for blade3 and now I got the sdcard mounted and worked. Before I used to take init.atlas40.rc, renamed it and it was a little edit from my stock init.roamer2.rc. Now I took the init.roamer2.rc entirely from stock ramdisk, and I have two ril slots no signal and no IMEI (previously displayed IMEI on slot # 1) I think now I need to try to fix my init.roamer2.rc and maybe it will give me any result.

I accidentally discovered ZTEQualcommRIL.java. How do you think, should I use it to build a rom?

 

Now I have corrected detection of sim on slot # 1, and now the IMEI displaed (turns out I forgot to put my stock rild into proprietary files) but is not recognized the operator. In the radio log I get this error: E/PHONE (634): Settings Exception Reading Dual Sim Data Call Values. Can you tell me why it happens?

 

I've commented the line: persist.radio.multisim.config=dsds and now that's what I've got: log_radio

post-1036738-0-65668400-1402245316_thumbpost-1036738-0-31221400-1402245317_thumbpost-1036738-0-09707700-1402245318_thumb

Edited by manfromnn
Link to comment
Share on other sites

KonstaT, with your last patch for skia managed to build new rom. At this rom not working trebuchet, and  I picked up it from a previous build. Initializing storage I copied from your buildconfigs for blade3 and now I got the sdcard mounted and worked. Before I used to take init.atlas40.rc, renamed it and it was a little edit from my stock init.roamer2.rc. Now I took the init.roamer2.rc entirely from stock ramdisk, and I have two ril slots no signal and no IMEI (previously displayed IMEI on slot # 1) I think now I need to try to fix my init.roamer2.rc and maybe it will give me any result.

I accidentally discovered ZTEQualcommRIL.java. How do you think, should I use it to build a rom?

 

Now I have corrected detection of sim on slot # 1, and now the IMEI displaed (turns out I forgot to put my stock rild into proprietary files) but is not recognized the operator. In the radio log I get this error: E/PHONE (634): Settings Exception Reading Dual Sim Data Call Values. Can you tell me why it happens?

 

I've commented the line: persist.radio.multisim.config=dsds and now that's what I've got: log_radio

attachicon.gifScreenshot_2014-06-08-20-11-03.pngattachicon.gifScreenshot_2014-06-08-20-11-21.pngattachicon.gifScreenshot_2014-06-08-20-11-37.png

do you accept monetary donations?

Link to comment
Share on other sites

do you accept monetary donations?

I've never thought about it. All I try to do I doing for my development education. 

What do you think, does this can help?

Edited by manfromnn
Link to comment
Share on other sites

When in my file build.prop has this line: ro.telephony.ril_class=QualcommSharedRIL I get an error:

I/PHONE   (  719): Cdma Subscription set to 1
I/PHONE   (  719): RILClassname is QualcommSharedRIL
I/PHONE   (  719): Network Mode set to 0
E/PHONE   (  719): Unable to construct custom RIL class
E/PHONE   (  719): java.lang.NoSuchMethodException: <init> [class android.content.Context, int, int, class java.lang.Integer]
E/PHONE   (  719):      at java.lang.Class.getConstructorOrMethod(Class.java:472)
E/PHONE   (  719):      at java.lang.Class.getConstructor(Class.java:446)
E/PHONE   (  719):      at com.codeaurora.telephony.msim.MSimPhoneFactory.instantiateCustomRIL(MSimPhoneFactory.java:241)
E/PHONE   (  719):      at com.codeaurora.telephony.msim.MSimPhoneFactory.makeMultiSimDefaultPhone(MSimPhoneFactory.java:165)
E/PHONE   (  719):      at com.codeaurora.telephony.msim.MSimPhoneFactory.makeMultiSimDefaultPhones(MSimPhoneFactory.java:80)
E/PHONE   (  719):      at com.android.phone.MSimPhoneGlobals.onCreate(MSimPhoneGlobals.java:134)
E/PHONE   (  719):      at com.android.phone.PhoneApp.onCreate(PhoneApp.java:44)
E/PHONE   (  719):      at android.app.Instrumentation.callApplicationOnCreate(Instrumentation.java:1007)
E/PHONE   (  719):      at android.app.ActivityThread.handleBindApplication(ActivityThread.java:4476)
E/PHONE   (  719):      at android.app.ActivityThread.access$1500(ActivityThread.java:145)
E/PHONE   (  719):      at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1266)
E/PHONE   (  719):      at android.os.Handler.dispatchMessage(Handler.java:102)
E/PHONE   (  719):      at android.os.Looper.loop(Looper.java:136)
E/PHONE   (  719):      at android.app.ActivityThread.main(ActivityThread.java:5149)
E/PHONE   (  719):      at java.lang.reflect.Method.invokeNative(Native Method)
E/PHONE   (  719):      at java.lang.reflect.Method.invoke(Method.java:515)
E/PHONE   (  719):      at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:789)
E/PHONE   (  719):      at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:605)
E/PHONE   (  719):      at dalvik.system.NativeStart.main(Native Method)
E/PHONE   (  719): Unable to construct custom RIL class
Link to comment
Share on other sites

Ah someone try to help this man to build a good cyanogenmod11? Where are you @hecatae? @KonstaT Can you help manfromn? Someone? Anyone? 

Link to comment
Share on other sites

Dear Konstat. I did decompile file tlephony-common.jaj f (rom their ROM which I ril is worked) This  from original CM11 sources. This from my decompylyed file. And this file from vietnams gues. Can fix my file from the original CV11-that he allowed to include the connection?

Link to comment
Share on other sites

Dear Konstat. I did decompile file tlephony-common.jaj f (rom their ROM which I ril is worked) This  from original CM11 sources. This from my decompylyed file. And this file from vietnams gues. Can fix my file from the original CV11-that he allowed to include the connection?

What is this Mobiistar S01 (K-touch w619?) anyway? Is it a V790 variant? Is it even a ZTE device? Are you saying this ROM works on your device and RIL works?
 
Yes, you can use a custom RIL class. Seing you've already reversed it, it shoudn't be much of a problem. I don't know why you would use one from some completely random (non-ZTE) device though. Since they've only changed RIL request commands I doubt it would work with ZTE proprietaries. You can try of course. Did you try using the regular Qualcomm42RIL class?
Link to comment
Share on other sites

 

What is this Mobiistar S01 (K-touch w619?) anyway? Is it a V790 variant? Is it even a ZTE device? Are you saying this ROM works on your device and RIL works?
 
Yes, you can use a custom RIL class. Seing you've already reversed it, it shoudn't be much of a problem. I don't know why you would use one from some completely random (non-ZTE) device though. Since they've only changed RIL request commands I doubt it would work with ZTE proprietaries. You can try of course. Did you try using the regular Qualcomm42RIL class?

 

Yes, the rom is working on v790 device. But this is interesting. I have zte v790 with 256mb ram, and for me, the sim card is working. WHy does sim card not work on 512mb ram device? I just replaced libcm.so from my 2.3.6 rom, and my sim is working.

Link to comment
Share on other sites

Yes, the rom is working on v790 device. But this is interesting. I have zte v790 with 256mb ram, and for me, the sim card is working. WHy does sim card not work on 512mb ram device? I just replaced libcm.so from my 2.3.6 rom, and my sim is working.

I though we were always talking about dual-SIM variant or is there something else getting lost in translation as well?

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.