Jump to content

[DEV][ROM][17.11.] CyanogenMod 11 (Android 4.4.4) for ZTE Open C / Kis 3


Guest KonstaT
 Share

Recommended Posts

Guest GamblerTobi

Hi,

thank you for that great ROM.

To install this ROM I used my PC with Linux Mint as OS. Installing CWM,ROM and Gapps with adb tools was no problem for me.

But I have the following problem:

2-3 times a day, i can't awake the phone from Standby.

When i press the power button, the display stays black. It seems that the phone was shut down, but this isn't the fact.

When i connect the phone to my PC, the PC finds the partitions on the phone.

The only thing i can do is:

I have to remove and insert the battery, and start the phone manually.

I am new to Cyanogenmod, so there is possible a solution for me. Any idea what i can do?

...and yes, i did format the system and i did wipe data and factoy reset before installing the ROM.

Thx

Hylli

Same here.
Link to comment
Share on other sites

@hecatae
I have an ZTE Open C and i upgraded es suggested, from Android Kitkat from here:
http://down.comebuy.com/Open_c_root_Android4.4.rar

FTM mode is new for me, but tested it by pressing Volume +/- while powering up the device.

The phone vibrates as it would boot, but the display always stays black as described. It is possible that the phone boots in this mode, when my problem occurs,.

Hylli

Edited by hylli
Link to comment
Share on other sites

Guest GamblerTobi

@hecatae

I have an ZTE Open C and i upgraded es suggested, from Android Kitkat from here:

http://down.comebuy.com/Open_c_root_Android4.4.rar

FTM mode is new for me, but tested it by pressing Volume +/- while powering up the device.

The phone vibrates as it would boot, but the display always stays black as described. It is possible that the phone boots in this mode, when my problem occurs,.

Hylli

Try booting into fastboot/recovery via adb.
Link to comment
Share on other sites

Guest blankland

 

Never happened to me, but I've never taken my device outside either. :P Post the appropriate logs (logcat, dmesg, last_kmesg) because without them, your guess is as good as any.

 

I don't know how to get these logs, it occurs randomly, and once it occurs, the phone will get into qhsusb_bulk mode.

Link to comment
Share on other sites

@GamblerTobi:

 

Try booting into fastboot/recovery via adb.

 

Booting via adb to recovery...

sudo adb reboot recovery

...works properly for me.

 

The device boots properly to "CWM-based Recovery v6.0.5.0".

 

Booting fastboot via...

sudo adb reboot fastboot

...also works prperly i think, it boots the CM-System.

 

...and now?

 

@blankland:

You can use the App "CatLog" to record logcat to a text file.

 

Hylli

Edited by hylli
Link to comment
Share on other sites

Guest KonstaT

I don't know how to get these logs, it occurs randomly, and once it occurs, the phone will get into qhsusb_bulk mode.

If you can find /proc/last_kmsg after a reboot, please attach that.
 
I think the device lands in that mode after a kernel panic. I had that few times when messing with kernel camera drivers.

 

@GamblerTobi:

 

Booting via adb to recovery...

sudo adb reboot recovery

...works properly for me.

 

The device boots properly to "CWM-based Recovery v6.0.5.0".

 

...and now?

 

@blankland:

You can use the App "CatLog" to record logcat to a text file.

 

Hylli

In that case you should be able to do it with adb.

adb logcat > filename.txt

and

adb shell
su
dmesg > /sdcard/filename.txt
Link to comment
Share on other sites

 

If you can find /proc/last_kmsg after a reboot, please attach that.
 
I think the device lands in that mode after a kernel panic. I had that few times when messing with kernel camera drivers.

 

In that case you should be able to do it with adb.

adb logcat > filename.txt

and

adb shell
su
dmesg > /sdcard/filename.txt

 

...can i disconnect the phone from PC after i executed these commands?

 

The error occured last time on thursday, , so i don't know, when it will occur next time.

 

The error occured always, when i didn't use the phone for a while.

 

Edit:

I testet the commands:

sudo adb logcat > filename.txt

...works, but i can't see any file on my PC?

sudo adb shell
su

...doesn't work, i get the error: "Permission denied".

 

Edit 2:

It occured today between 12.30 and 12.38. I recorded debug logcat with catlog:

http://pastebin.com/b1ZC3ZG1

 

But i think it happened when the log ends.

 

Hylli

Edited by hylli
Link to comment
Share on other sites

Guest KonstaT
sudo adb shell
su

...doesn't work, i get the error: "Permission denied".

You need to enable root access for adb under Settings -> Developer options -> Root access -> Apps and ADB.

 

It's more likely a kernel panic so dmesg or last_ksmg should give better info.

Link to comment
Share on other sites

OK, now the commands are working.

 

What about my question:

 

...can i disconnect the phone from PC after i executed these commands?

 

 

Today i had the error 3 times! The error occured always when i was driving as co-driver in a car for a few kilokemeters. I only hold the Open C in my hand and i did nothing else with it.

 

Hylli

Link to comment
Share on other sites

Guest KonstaT

OK, now the commands are working.

 

What about my question:

 

 

Today i had the error 3 times! The error occured always when i was driving as co-driver in a car for a few kilokemeters. I only hold the Open C in my hand and i did nothing else with it.

 

Hylli

Yes.

 

GPS on? What apps running? You must be doing something differently if you had three reboots today but none since last thursday...

Link to comment
Share on other sites

Hi,

 

GPS is on. At the moment i am using only few apps, e.g. GMail, Navit (for testing GPS/Navigation), some german soccer league apps, Telegram, ...

 

Mostly i end the apps by long pressing the back button (is activated in developer options!).

 

Hylli

Link to comment
Share on other sites

Guest KonstaT

I managed to install this build on my device and I like it but some applications are not opening and showing constant "application has stopped errors".

 

Browser, Play Newsstand, Books, Apollo, Gallery

 

Submission subject

[CRASH]com.andrew.apollo threw java.lang.ArrayIndexOutOfBoundsException

Submission content 

ro.cm.version: 11-20140817-UNOFFICIAL-KonstaKANG-kis3

 

length=0; index=0 same java error for all, however full error seems to be slightly different for each app.

 

Other applications like Chrome, Gmail, are working fine so seems its not specific to gapps.

 

My version is having 850/1900 and it seems to work fine although I had to enter the APN manually to I could use my data.

Actually this is because you don't have an external SD card inserted on your device. Only external SD card is supported on this ROM and some android apps want to write data to primary storage.

 

Noticed this while testing another device without any primary sdcard.

 

Hi,

 

GPS is on. At the moment i am using only few apps, e.g. GMail, Navit (for testing GPS/Navigation), some german soccer league apps, Telegram, ...

 

Mostly i end the apps by long pressing the back button (is activated in developer options!).

 

Hylli

So it could be something GPS/location related, something RIL related switching between towers/network modes, or something completely random. That's why logs could tell a bit more.

 

You shouldn't kill apps with long pressing the back button (that's an option for developers in case of a misbehaving app) or using any task managers/killer! Closing apps from the multi-tasking view is the way to go but generally you don't need to do that either. Android is more than capable of handling the memory management without user interference.

Link to comment
Share on other sites

Following problem with "dmesg > filename.txt":

 

The file is only 128kb in size. When i delete it an d create a new one, then i get dmesg messags from 2 minutes after last dmesg messages.

 

Actually i get the dmesg messages from 09.33 am, but we have already 11.39 am in Germany.

 

How can i get a higher size for dmesg file or how can i get dmesg messages from actual time or the time when the error occured (e.g. the last 20-30 Minutes)?

 

Hylli

Edited by hylli
Link to comment
Share on other sites

Guest KonstaT

Following problem with "dmesg > filename.txt":

 

The file is only 128kb in size. When i delete it an d create a new one, then i get dmesg messags from 2 minutes after last dmesg messages.

 

Actually i get the dmesg messages from 09.33 am, but we have already 11.39 am in Germany.

 

How can i get a higher size for dmesg file or how can i get dmesg messages from actual time or the time when the error occured (e.g. the last 20-30 Minutes)?

 

Hylli

Are you taking timezone into consideration? Works fine for me here in Finland, it's precisely three hours off from the actual time (GMT+2 and and daylight saving hour).
 
You should take it when the error occurs. There will be more than plenty in the log. There's no way of seeing it in dmesg if you've already had to reboot your device. If kernel panic caused a reboot, there should be /proc/last_kmsg.
Link to comment
Share on other sites

Hi,

 

OK i didn't consider the timezone. Will check this out.

 


 

You should take it when the error occurs.

 

This is a big problem for me! I can't say when it happens.

 

...and when it happened, i can't enter the command to write a file for dmesg.

 

When i connect the phone to my Linux-PC after it happened and enter the command via adb tool, my PC will freeze because file manager window for window is opening, and the only thing i can do, is disconnecting the phone and closing the windows.

 

When i  remove and insert the battery and reboot afterwards, there is no /proc/last_kmsg.

 

Edit:

When i connect the phone to my Lubuntu Notebook after the error occurs, the windows with the partitions appear and disappear, appear and disappear, ...

lsusb

...tells me that the ZTE Open C is connected, but when i try to connect with adb, i get no connected device.

 

So for me it seems inpossible to take a log when the error occurs.

 

The only possibility i see is, when i could take a log for a longer time when i think the error could occur next time, e.g. when driving from/to home.

Hylli

Edited by hylli
Link to comment
Share on other sites

Guest derpin7

EDIT: Just FYI im in the USA and i think this might have something to do with 850mhz stuff

 

Just FYI, thank you for this awesome rom, everything works out of the box except for one little (important!) detail!  on my phone when im running your CM11 build i cannot connect to 3g services, only EDGE...

 

but when i flash this build (looks like its based on ZTE Kis 3?): 

 
 
 
3g works out of the box, but bluetooth wont connect to my car stereo.
 
when i flash your build (CM11) BLUETOOTH works out of the box but i cant connect over 3g only EDGE 
 
ALSO, i have double checked APN / DATA settings on both and they are identical.
 
 
is there anyway to pull the radio out of the 7z file i posted above and slap it into CM11 ?
 
thank you for your time on this project!
 
btw this is where i found instructions with the ZTE_OPEN_C.7Z file posted above:
 
 
 
 
 
 
Edited by derpin7
Link to comment
Share on other sites

Guest KonstaT

 

EDIT: Just FYI im in the USA and i think this might have something to do with 850mhz stuff

 

Just FYI, thank you for this awesome rom, everything works out of the box except for one little (important!) detail!  on my phone when im running your CM11 build i cannot connect to 3g services, only EDGE...

 

but when i flash this build (looks like its based on ZTE Kis 3?): 

 
 
 
3g works out of the box, but bluetooth wont connect to my car stereo.
 
when i flash your build (CM11) BLUETOOTH works out of the box but i cant connect over 3g only EDGE 
 
ALSO, i have double checked APN / DATA settings on both and they are identical.
 
 
is there anyway to pull the radio out of the 7z file i posted above and slap it into CM11 ?
 
thank you for your time on this project!
 
btw this is where i found instructions with the ZTE_OPEN_C.7Z file posted above:
That's the windows flash tool, right? Btw that tool also changes your partition layout so if ever want to go back to Firefox OS, you have to use another windows tool to flash the 'unlocked' Firefox OS firmware.
 
There's usually no radio/modem included in any custom ROMs, including this one. So the one you have from the last stock firmware you've installed is what you still have. That is also the reason why you need to update your Open C to KitKat first - RIL doesn't work with Jelly Bean (Firefox OS) modem.
 
Proprietary files in my ROMs are extracted from stock GEN_EU_P821E10V1.0.0B10 build. You could try updating to that first (so you'll also have a B10 modem) to see if that makes any difference. Only try to install that if you've used the windows tool to convert your device into a Kis 3 (also use the stock recovery to install). It won't fit the regular Open C partition layout (I already tried that :P).
Link to comment
Share on other sites

Guest KonstaT

still no dice :(  let me ask you a question when i do a CWM backup and restore does that restore the radio/modem stuff as well ???

No, it does not. Radio/modem is only changed when flashing official ZTE firmware packages (NON-HLOS.bin, goes to /dev/block/platform/msm_sdcc.1/by-name/modem).

 

CWM only backups/restores the usual partitions that a ROM flash would change or where your personal data is stored (/boot, /system, /data, /cache).

Link to comment
Share on other sites

Guest derpin7

ok, im going to try updating to this ZTE Kis 3 Ver 5.0 http://download.ztedevices.com/UpLoadFiles/product/567/4778/soft/2014081409055370.zip at this link.  then flash cyanogenmod and see what the hell happens! because the link build you had me flash, actually flashed a "B01" not a "B10" ( ro.build.display.id=ZTE_KIS_III_V3.0

ro.build.inner.version=GEN_EU_P821E10V1.0.0B10) ..????

 

am i correct in assuming that the last 3 digits of the build number in android is the modem ver ?

Link to comment
Share on other sites

Guest KonstaT

ok, im going to try updating to this ZTE Kis 3 Ver 5.0 http://download.ztedevices.com/UpLoadFiles/product/567/4778/soft/2014081409055370.zip at this link.  then flash cyanogenmod and see what the hell happens! because the link build you had me flash, actually flashed a "B01" not a "B10" ( ro.build.display.id=ZTE_KIS_III_V3.0

ro.build.inner.version=GEN_EU_P821E10V1.0.0B10) ..????

 

am i correct in assuming that the last 3 digits of the build number in android is the modem ver ?

That was the B10. I usually only talk about/use stuff from the generic stock firmwares GEN_EU_P821E10V1.0.0BXX (not carrier branded builds). Those are the last three digits from those builds. B06 is what you had if you flashed using the windows tool.

 

There's really no way of knowing if there's any differences between the modems. We just assume that their the same version as the rest of the firmware.

Link to comment
Share on other sites

Guest derpin7

any idea where this came from ? \2014081409055370.zip\Norway Kis 3 SD card upgrading instruction & software package(ZTE Norway AS)-256880B0374ZTE_KIS_III_V5.0 ??????

Link to comment
Share on other sites

Guest KonstaT

any idea where this came from ? \2014081409055370.zip\Norway Kis 3 SD card upgrading instruction & software package(ZTE Norway AS)-256880B0374ZTE_KIS_III_V5.0 ??????

From Norway? :P These are all listed in the stock ROMs thread I already linked.
 
I think ZTE messed up there because the Montenegro update is exactly the same (even tagged with NOR_EU_XXXXXXXXXX). It probably should have been a generic build. Just stick with the 'real' generic updates though.
 
Another thing that could be tested would be to flash back the B06 firmware with the windows tools. Then replace the RIL proprietaries in CM11 with the ones extracted from the B06 firmware (bin and lib only, not app/etc/framework unless you deodex first).
Link to comment
Share on other sites

Hi,

 

 

So it could be something GPS/location related, something RIL related switching between towers/network modes, or something completely random. That's why logs could tell a bit more.

even when i deactivate the GPS completely, the error occurs.

 

Today i watched the phone during the way from/to home to/from my workplace. I determined, that the signal of my mobile provider get lost for two times on this way.

 

As i didn't let the phone go to standy, the error didn't occur today.

 

So i think it is possible, that it is a combination of standby and losing or reestablishing the connection to my mobile provider.

 

But i think it is very difficult to log this. I need a longer period of time, to log with dmesg.

 

Hylli

Edited by hylli
Link to comment
Share on other sites

Guest derpin7

h

 

 

From Norway? :P These are all listed in the stock ROMs thread I already linked.
 
I think ZTE messed up there because the Montenegro update is exactly the same (even tagged with NOR_EU_XXXXXXXXXX). It probably should have been a generic build. Just stick with the 'real' generic updates though.
 
Another thing that could be tested would be to flash back the B06 firmware with the windows tools. Then replace the RIL proprietaries in CM11 with the ones extracted from the B06 firmware (bin and lib only, not app/etc/framework unless you deodex first).

 

I guess in regards to the norway build, i was thinking it must be the newest version because of the "ro.build.display.id=ZTE_KIS_III_V5.0" v5.0 specifcally.   its the only v5.0 on the page i can find.  i guess that might be some internal-numbering-system ?

when you say B06 firmware, you are referring to "ZTE_Open_C.7z\Android_4.4_EU_P821E10V1.0.0B06_DL" im assuming ? (the ZTE_Open_C.7z) 
ro.build.display.id=ZTE_KIS_III_V1.0

ro.build.inner.version=GEN_EU_P821E10V1.0.0B06... right ;)? 

ok, so how can you explain the RIL proprietaries in just a little more detail, im sorry im knew to messing with the internals this deep.

 

thank you very much for your help, do you have a bitcoin address so i can tip you ?

 

 

ro.build.display.id=ZTE_KIS_III_V5.0

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.