Jump to content

[DEV][ROM][17.11.] CyanogenMod 11 (Android 4.4.4) for ZTE Open C / Kis 3


Guest KonstaT
 Share

Recommended Posts

my ver_info.txt says m8610AAAAANLYD180333.1

Yes, I'm quite sure it'll be that same on all KitKat modems.

 

pretty sure I used the US firmware from this page:

 

http://en.comebuy.com/developer-firefox-os-open-c.html

But you must have installed EU_FFOS+to+Android.zip after that or in some other way updated your device to KitKat first. Telephony (and wifi) would never work with Firefox OS (Jelly Bean) modem.

 

After I installed the new build battery life seems to be significantly shorter. I tried calibrating the battery but it still goes fast

Shouldn't be any difference in battery life. How exactly did you calibrate battery?

Link to comment
Share on other sites

Guest snorkel2

been testing the cellular data speed and when it says H+ with 3 bars the connections are timing out.

Not sure what the deal is, and wifi is bit faster, I am getting around 40kb a second.

Link to comment
Share on other sites

Guest Pipotron3000

On my device (ZTE FR FFOS 1.3, see hardware thread for details), i used the official ZTE french website "Pack root du ZTE Open C" but they removed it now ;)

ROM name is : P821A10_FR_ENG_20140806

I used it, because i totally messed my install with Comebuy FFOS to Android (EU, not FR...)

 

After that, i made a full factory reset. Everything was working again (camera, no crash...)

 

After that, i totally followed your instructions : Comebuy FFOS to Android 4.4 (again), CWM...you know

The only difference are the gapps : i used "pa_gapps-stock-4.4.2-20140608-signed".

 

A little hint, may be : camera crashed again some hours ago, but phone was still working ;)
I will install a switch on the battery instead of opening the case  :lol:  ;)

Link to comment
Share on other sites

Guest snorkel2

"But you must have installed EU_FFOS+to+Android.zip after that or in some other way updated your device to KitKat first. Telephony (and wifi) would never work with Firefox OS (Jelly Bean) modem."

 

Yes I did install the EU_FFOS+to+Android.zip afterwards.  So that must the modem I have now.   When it was on the AOSP build of android the data was not this slow.

Link to comment
Share on other sites

On my device (ZTE FR FFOS 1.3, see hardware thread for details), i used the official ZTE french website "Pack root du ZTE Open C" but they removed it now  ;)

ROM name is : P821A10_FR_ENG_20140806

I used it, because i totally messed my install with Comebuy FFOS to Android (EU, not FR...)

Direct link I put in stock ROMs thread seems to still work. 

 

I used Battery Calibration app from the play store and followed the instructions

 

https://play.google.com/store/apps/details?id=com.nema.batterycalibration&hl=en

Yeah, that doesn't actually do anything. That's why I asked. ;)

 

That myth was debunked by a Google engineer few years ago already.

https://plus.google.com/105051985738280261832/posts/FV3LVtdVxPT

Link to comment
Share on other sites

 

hallo
 
I come from Indonesia 
 
after flash cm 11. why my sim card is not detected?
can help me
 
sorry for bad my english

 

What device you have? Kis 3 or V811W? I thought devices sold in Indonesia are V811W dual-SIM variants?
 
If it's a dual-SIM version, you might be able to convert your device into a singe SIM version by flashing a Kis 3 modem. For actual dual-SIM support I'd probably need to have a dual-SIM device myself or atleast someone with a dual-SIM device who knows his/her way around Android system.
Link to comment
Share on other sites

in your firmware does not work ART. And the constant crash applications. (Annex ..... error occurred)

Maybe it broke when you winzipped my ROMs and mirrored them to Russian forums... :P

Link to comment
Share on other sites

 
 
Hello! Thank you for Your excellent work! I have Your "CWM+CM11/Kis3+gapps on beeline smart2. All works great. One question: how can I make a "swap to SD"? Thank you.
P.S. I'm Russian, but not all Russians think the same. Thanks again.
Link to comment
Share on other sites

Hello! Thank you for Your excellent work! I have Your "CWM+CM11/Kis3+gapps on beeline smart2. All works great. One question: how can I make a "swap to SD"? Thank you.

P.S. I'm Russian, but not all Russians think the same. Thanks again.
KitKat already uses zRAM so I'm not sure why you'd need swap, I wouldn't recommend using swap at least. I think I'm also going to increase the zRAM size if/when there's another build.
 
Swap would work the same way it works everywhere else. You create a swap file somewhere with 'mkswap' (or create a swap partition on external sdcard) and you activate it with 'swapon'.
 
Could you (or someone else with Beeline Smart2) post a screenshot of hardware info app to the appropriate thread? There's one notable difference in Beeline Smart2's that isn't addressed yet. I'd need some intelligent way to identify Beeline Smart2's first (ro.boot.hwversion possibly?).
Link to comment
Share on other sites

Guest angwhydn

 

What device you have? Kis 3 or V811W? I thought devices sold in Indonesia are V811W dual-SIM variants?
 
If it's a dual-SIM version, you might be able to convert your device into a singe SIM version by flashing a Kis 3 modem. For actual dual-SIM support I'd probably need to have a dual-SIM device myself or atleast someone with a dual-SIM device who knows his/her way around Android system.

 

 

thanks for the response 
yes I use the dual sim w811w 
do I have to re-port? 
Can you provide a tutorial for it
Edited by angwhydn
Link to comment
Share on other sites

thanks for the response 

yes I use the dual sim w811w 
do I have to re-port? 
Can you provide a tutorial for it
Like said, you might only need to flash Kis 3 modem to have it working with single SIM.
 
I'll add back the dual-SIM scripts/services/etc if/when there will be an another release. After that it should be a matter of setting one system property from dual-SIM (might also need replacing some RIL proprietaries from a dual-SIM device). Problem is that I'd need some intelligent way to identify V881W's first (ro.boot.hwversion possibly?). Could you (or someone else with V881W) post a screenshot of hardware info app to the appropriate thread?
Link to comment
Share on other sites

Guest angwhydn

 

Like said, you might only need to flash Kis 3 modem to have it working with single SIM.
 
I'll add back the dual-SIM scripts/services/etc if/when there will be an another release. After that it should be a matter of setting one system property from dual-SIM (might also need replacing some RIL proprietaries from a dual-SIM device). Problem is that I'd need some intelligent way to identify V881W's first (ro.boot.hwversion possibly?). Could you (or someone else with V881W) post a screenshot of hardware info app to the appropriate thread?

 

if you mean this?

 

pic.twitter.com/Z4pgA5Bp7i

Link to comment
Share on other sites

Guest angwhydn

Thanks, that's exactly what I meant. Haven't seen wmfA.6 on any other device before. Now would only need to verify from other V881W's that it's always the same.

 

I also posted your screenshot to the app thread so it doesn't get lost.

 

 

thanks bro 
I hope the help of your
Link to comment
Share on other sites

Guest duttyend

 

This is my port of CyanogenMod 11 for ZTE Open C / Kis 3. It is unofficial and unsupported by the CyanogenMod team. It's for advanced users only.
 
Important. Prerequisites!!! You need to install Android KitKat on your Open C first (e.g. EU_FFOS+to+Android.zip will do). You also need to have this ClockWorkMod or this TWRP recovery installed.
 
 
Please don't mirror my builds!
 
cm-11-20140914-UNOFFICIAL-KonstaKANG-kis3.zip
md5:73fe0ac6d33fb98cf5dd5cf9d7594230
 
Google Apps:
 
Working:
  • RIL (mobile network, SMS & data)
  • Wifi
  • Audio (playback/input/routing/headphones/etc)
  • Bluetooth
  • Camera (photos, camcorder & panorama)
  • FM radio
  • GPS
  • Hardware acceleration and OpenGL rendering
  • Hardware video decoding & encoding
  • 'Project Butter'
  • SD card
  • USB-storage (on external sdcard) & adb
  • USB-tethering
  • Wifi-tethering
  • Touchscreen/multi-touch
  • Sensors
  • LEDs
Not working:
  • ???
Sources:
Thanks:
  • CyanogenMod team & everyone who's been working on CM11

 

Thank you SO much KonstaT for this amazing ROM !!!

I had been following this thread for a few weeks, in hope of an update to FFOS 1.4 by ZTE but I couldn't resist anymore and took the plunge yesterday to install your CM11 on my ZTE Open C.

 

I used Ubuntu to fastboot CWM and install your ROM directly. I didn't install Comebuy Android KK 4.4 before and this led me to not having a modem. This problem was solved flashing the KitKat Modem.zip provided by "vampirefo" on XDA.

 

I am very grateful to you, the install went very straightforward and the phone is behaving very well.

 

I just have one issue for the moment : I cannot set up my Google account to sync my Calendar and Contacts (not using Gmail and don't want GApps, just use AOSP apps). When I choose to add a "Corporate" account and then specify "Exchange", enter "m.google.com" as the server (as I used to do with my CM11 M10 on my Android phone) and my login and passwords, I get the following error: "You don't have permission to sync with this server. Contact your server's administrator for more information". Could you please help me ?

 

 

These are my HW details :

 

Accelerometer:

0x33

 

Camera:

BACK Camera ID:GALAXYCORE,GC2235, 2M

Bayer sensor

 

eMMC:

HYNIX H9DP32A4JJMCGR 4G eMMC

 

LCD panel:

IC:ILI9806C+TXD; Glass:CMI; Resolution:480*800

 

Touchscreen:

name : goodix

i2c address : 0x5d

IC type: goodix GT968

firmware version : 968_1060

module : LiHe

 

ro.boot.hwversion:

wkzA.4

Link to comment
Share on other sites

Guest salv2014

Hi, I have the same problem of the user hylly.

 

I correctly installed step-by-step as the guide say, I had no problems, the installation seems all ok. But 2-3 times per day I can't awake from standby, I need to remove the battery and start again.

 

I have this problem with and without ClockWorkMod flashed, now I have no apps installed ( just the Pico Modular Package ).

 

This morning after the last freeze, when I removed the battery, replugged and turned on the phone, I had a loop message "Trebuchet crash" ( I have the Italian Language ), and I can't use the phone even rebooting & turn off.

 

I tried to reset/install cyanogenmod port different times with the same result.

Edited by salv2014
Link to comment
Share on other sites

this is dual sim version>?

Neither Open C or Kis 3 is a dual-SIM device. Did you read the few posts above yours?

 

I used Ubuntu to fastboot CWM and install your ROM directly. I didn't install Comebuy Android KK 4.4 before and this led me to not having a modem. This problem was solved flashing the KitKat Modem.zip provided by "vampirefo" on XDA.

 

I just have one issue for the moment : I cannot set up my Google account to sync my Calendar and Contacts (not using Gmail and don't want GApps, just use AOSP apps). When I choose to add a "Corporate" account and then specify "Exchange", enter "m.google.com" as the server (as I used to do with my CM11 M10 on my Android phone) and my login and passwords, I get the following error: "You don't have permission to sync with this server. Contact your server's administrator for more information". Could you please help me ?

And now you have Jelly Bean bootloaders and KitKat modem. I wouldn't recommend having such mix&match combinations. It could potentially lead to all kinds of issues.

 

As for your issue, I don't know. All I can say that it should work if it works with CM11 on another device.

 

Hi, I have the same problem of the user hylly.

 

I correctly installed step-by-step as the guide say, I had no problems, the installation seems all ok. But 2-3 times per day I can't awake from standby, I need to remove the battery and start again.

 

I have this problem with and without ClockWorkMod flashed, now I have no apps installed ( just the Pico Modular Package ).

 

This morning after the last freeze, when I removed the battery, replugged and turned on the phone, I had a loop message "Trebuchet crash" ( I have the Italian Language ), and I can't use the phone even rebooting & turn off.

 

I tried to reset/install cyanogenmod port different times with the same result.

Yes, it's been reported several times already! It really doesn't help if can't provide any additional information.
 
Current theory is, that it's caused by something related to wifi (weak/poor wifi signal? open networks? wifi location?). No one has been able to provide any steps to reliably reproduce this issue (which I still can't on my device) and there's no logs of this issue occuring (preferably dmesg). Without this your guess is as good as any.
 
Workaround - turn wifi off when you're not using it.
Link to comment
Share on other sites

Guest angwhydn

Thanks, that's exactly what I meant. Haven't seen wmfA.6 on any other device before. Now would only need to verify from other V881W's that it's always the same.

 

I also posted your screenshot to the app thread so it doesn't get lost.

 

whether already found a solution, to this problem?

 

thanks

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.