Jump to content

[DEV][ROM][13.11.] CyanogenMod 12.1 (Android 5.1.1) for Huawei Y5


Guest KonstaT
 Share

Recommended Posts

On 3/18/2016 at 0:09 AM, b3007201 said:

What do you think about the Motorola Moto G XT1039?

In your opinion is it a valid alternative to this huawei or do you know a cheaper alternative?

It's a decent device. It's getting a little old now and it's not going to receive an official Marshmallow update (well, I doubt this device is either). 2nd gen Moto G might be a better option. msm8909 chipset on this device and msm8x26 on Moto G 1st and 2nd gen (and on various mid-range devices past couple of years) are practically the same. Moto G has better display than this.

It's getting off topic...

Edited by KonstaT
Link to comment
Share on other sites

Hi thanks for your work. I guess 4g works as well?

What bothers me most of the Y560 is that I can not put in an USB stick to copy data from SD to a USB. Is that possible in Cyanogen rom you made?

 

Can you expand your install guide to make it idiot proof as I never changed a rom and want to put on your rom. So a bit more detailed perhaps? Thank you so much.

Does this Cyanogen rom  has root access by default?

Edited by dutchdog
Link to comment
Share on other sites

11 hours ago, dutchdog said:

Hi thanks for your work. I guess 4g works as well?

What bothers me most of the Y560 is that I can not put in an USB stick to copy data from SD to a USB. Is that possible in Cyanogen rom you made?

Can you expand your install guide to make it idiot proof as I never changed a rom and want to put on your rom. So a bit more detailed perhaps? Thank you so much.

Does this Cyanogen rom  has root access by default?

Yes, 4G works.

You mean USB OTG? I haven't looked into it yet but I guess hardware doesn't support it.

There's instructions in TWRP thread how to install custom recovery. There's installation instruction in the third post of this thread how to install this ROM. I really can't make it any simpler than that. It's no different to installing a custom ROM on any regular Android device.

Yes, CyanogenMod comes with built in root management but you need to enable it in the settings (FAQ, third post).

Link to comment
Share on other sites

Hi, I have an issue with not-working back-camera of my Y560-L01 Instead front camera since I installed your fantastic mod. I lurked everywhere but no one seems have had that issue or similar.

Tnx!!

Link to comment
Share on other sites

On 3/29/2016 at 4:25 PM, metalzone said:

Hi, I have an issue with not-working back-camera of my Y560-L01 Instead front camera since I installed your fantastic mod. I lurked everywhere but no one seems have had that issue or similar.

Tnx!!

I haven't heard of any issues with camera. Maybe your device has different camera hardware. Please post dmesg after booting and logcat after trying to initialize camera.

I've also written an app that pulls some hardware info. What does your's say under primary camera? Here's the app: http://konstakang.com/devices/y560/Y5Info (edit. updated to support Y560-U23)

Screenshot_20160329-171751.png

Edited by KonstaT
Link to comment
Share on other sites

1 hour ago, metalzone said:

:0 !!!!!!!!!!

Does it still work in stock ROM? Hardware failure?

Can you attach a dmesg booting stock ROM? What does the app say on stock ROM? What's your stock ROM version (build.prop)?

Edited by KonstaT
Link to comment
Share on other sites

thnaks to TWRP i restored the stock-rom and the back-camera returns to works!! :0

When I'll have much more time I'll give you the info that you asked me. Tnx!!

 

Screenshot_2016-03-30-11-52-10.png

Edited by metalzone
Link to comment
Share on other sites

3 hours ago, metalzone said:

thnaks to TWRP i restored the stock-rom and the back-camera returns to works!! :0

When I'll have much more time I'll give you the info that you asked me. Tnx!!

51 minutes ago, kurbus said:

I have the same issue as metalzone.

I checked my camera model with y5info.apk, it is the same as metalzone's.

Yeah, it seems you have slightly different camera hardware. This should be easy to fix. Just need to use kernel from your stock firmware and add few missing binary blobs.

Can you upload boot.* and system.* from your stock TWRP backup? I'll need the boot image very least. These don't hold any of your personal information.

Edited by KonstaT
Link to comment
Share on other sites

Alright, I'll check for corruption and begin the upload as soon as possible

Finally done http://www.filehosting.org/file/details/557319/ggggdd.zip

Use https://dropmail.me/en/ for temporary email to get the download link. Sorry, I was unaware of this requirement

 

http://www.filedropper.com/ggggdd another link

Edited by kurbus
avoid double post
Link to comment
Share on other sites

13 hours ago, kurbus said:

Alright, I'll check for corruption and begin the upload as soon as possible

Huh, it's exactly the same firmware (Y560-L01V100R001C577B040) I have and what I'm using kernel and proprietary blobs from. :o Maybe we'll just need the missing binary blobs then. Install this in TWRP and report back. If it still doesn't work, I'll need those logs (dmesg, logcat).

cm-y560-hi544-qunhui-camera.zip
http://www.mediafire.com/?8u6ttr44qpmoqpx
md5:14d8a761258930b2f47017263aefad3d

Edited by KonstaT
Link to comment
Share on other sites

That is just superb. The camera works now.

That's what I figured. I checked the files in /system/vendor/lib/, there were camera related files with the string 'f140858r' but none with the other camera model.

Would this work for your CM13 build? I am tempted to try it but I assumed the camera wouldn't work so I didn't bother.

Link to comment
Share on other sites

1 hour ago, kurbus said:

That is just superb. The camera works now.

That's what I figured. I checked the files in /system/vendor/lib/, there were camera related files with the string 'f140858r' but none with the other camera model.

Would this work for your CM13 build? I am tempted to try it but I assumed the camera wouldn't work so I didn't bother.

Great :)

Yes, same patch will work on CM13, too.

Edited by KonstaT
Link to comment
Share on other sites

HI konstaT,

I would like to say a BIG "thank you"! I was able to install your TWRP Recovery Image and after that i installed your CM12 ROM without problems.

I appreciate your work, and hope you can win your GPL battle with HUAWEY.

Federico

 

Link to comment
Share on other sites

 

On 31/3/2016 at 9:17 AM, KonstaT said:

Huh, it's exactly the same firmware (Y560-L01V100R001C577B040) I have and what I'm using kernel and proprietary blobs from. :o Maybe we'll just need the missing binary blobs then. Install this in TWRP and report back. If it still doesn't work, I'll need those logs (dmesg, logcat).

cm-y560-hi544-qunhui-camera.zip
http://www.mediafire.com/?8u6ttr44qpmoqpx
md5:14d8a761258930b2f47017263aefad3d

tnx fot the patch but I encountered another issue -.-

when I try to re-install your mod following the steps in the instruction and install the gapps-pico and the patch, the phone automatically boot on TWRP. 

So I try to reinstall the stock backed-up before and the scenario shows the same. 

retried to reinstall the mod that gave the same results upon.

:(

Link to comment
Share on other sites

On 3/31/2016 at 7:28 PM, blackdede said:

HI konstaT,

I would like to say a BIG "thank you"! I was able to install your TWRP Recovery Image and after that i installed your CM12 ROM without problems.

I appreciate your work, and hope you can win your GPL battle with HUAWEY.

Federico

Well, it's not my battle alone. This concerns anyone who has this device or anyone who has a Huawei/honor device as releasing incomplete kernel sources seems to be more or less company policy from what I've heard. Even if you'd never install a custom ROM/kernel you have every right to inspect the source code you're running in binary form on your device.

I've since managed to partially reconstruct the kernel source. I was looking into purchasing Lenovo Tab 2 A10-30 because I'd still want some msm8909 device as a dev toy. :P I downloaded its kernel source and to my surprise saw bunch of 'yep' stuff that are also present in the Huawei Y5 kernel source. It turns out both of these devices are ODM/OEM'd by YEP Telecom(?) and they're part of the same 'family'. I found the missing touchscreen driver there and bunch of other stuff. Currently everything besides audio is basically working. I still consider the kernel source to be too incomplete for any actual use, though. https://github.com/KonstaT/android_kernel_huawei_msm8909/tree/reconstruct

1 hour ago, metalzone said:

tnx fot the patch but I encountered another issue -.-

when I try to re-install your mod following the steps in the instruction and install the gapps-pico and the patch, the phone automatically boot on TWRP. 

So I try to reinstall the stock backed-up before and the scenario shows the same. 

retried to reinstall the mod that gave the same results upon.

:(

Check the integrity of your files. Or try without the gapps. You've already managed to install it at least once. ROM hasn't changed - TWRP hasn't changed...

Link to comment
Share on other sites

2 hours ago, KonstaT said:

Check the integrity of your files. Or try without the gapps. You've already managed to install it at least once. ROM hasn't changed - TWRP hasn't changed...

re-installing the stock recovery resolves that issue. -.-
I suppose something gone wrong that has corrupted the TWRP. 

Scuse me for not post the logs, but I got not much time in these days.

Thank you for assistance supporting!!

Edited by metalzone
Link to comment
Share on other sites

Mine (well not exactly, its firms phone) stock rom randomly reboots, not even sure why. I have only few apps. Any ideas what to do? Well apart from flashing this rom.

Edited by Pofka
Link to comment
Share on other sites

On 4/1/2016 at 11:08 PM, metalzone said:

re-installing the stock recovery resolves that issue. -.-
I suppose something gone wrong that has corrupted the TWRP. 

Scuse me for not post the logs, but I got not much time in these days.

Thank you for assistance supporting!!

I highly doubt that. Never heard of recovery getting corrupted.

5 hours ago, Pofka said:

Mine (well not exactly, its firms phone) stock rom randomly reboots, not even sure why. I have only few apps. Any ideas what to do? Well apart from flashing this rom.

Old trick with putting some paper between battery helps? I doubt flashing any ROM will make any difference.

Link to comment
Share on other sites

7 hours ago, KonstaT said:

I highly doubt that. Never heard of recovery getting corrupted.


It happened to me too, I was fiddling with the phone and somehow got it to recovery loop. Don't remember what I did to achieve that. I fixed it by flashing stock recovery and kernel. My google skills told me a recovery flag was stuck on somewhere or something... Anyway, that's when I flashed back to stock and I took a backup which enabled me to send it to you, KonstaT.
 

If anyone needs the stock rom, it is available here: http://consumer.huawei.com/at/support/downloads/detail/index.htm?id=56623

I flashed it by booting stock recovery, the update.App needed to be in a folder named dload on sdcard. It started it automatically for me, YMMV.

Link to comment
Share on other sites

On 2016-04-04 at 8:06 PM, KonstaT said:

Old trick with putting some paper between battery helps? I doubt flashing any ROM will make any difference.

What kind of old trick is this? Where exactly do I need to place paper?

Link to comment
Share on other sites

Hello, I own a huawei y560-u23 and I wanted to ask if all the development done to the y560-l01 (recoveries, roms, etc...) can be installed without issues on this variant of the phone?. If some info is needed to confirm this, I'll try to help. 

I noticed inside my /system/lib/hw there are files with msm8909 on its names.

Edit1:

Ok, I saw this message that you posted in the TWRP thread

Quote

This should work on Huawei Y5 Qualcomm msm8909 variants (Y560-L01/L02/L03). CyanogenMod builds might need some work to support Y560-L02/L03 depending what's different on those devices (if any? - haven't looked into it). Y560-U23 has different camera and sensors afaict.

According to that, I suppose it indeed will work on the U23 variant but CM won't have working camera and sensors. So another question, does that kind of issue could be fixed with some kind of patch similar to the one you uploaded on previous messages?

Edited by Alonso98
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.