Jump to content

[DEV][ROM][28.1.] CyanogenMod 12.1 (Android 5.1.1) for Chuwi Vi10 Plus, Hi10 Plus, Hi10 Pro, Hibook, Hibook Pro & Hi12


Guest KonstaT
 Share

Recommended Posts

Hi risoterapia, 

Thank your for the reply but it is not the first time I use twrp or cm. 

Cyanogenmod installs fine, the problem is the gapps. At the end when unmounting system it ends the flashing routine with error 139. (eventhough gapps report installation complete) 

They keep FC though. 

I tried to find a description for error 139 but wasn't successful. 

I would be really happy to get some hint what's wrong here. Maybe I have to go back to remix and flash again? 

Have a great day all! 

Link to comment
Share on other sites

12 hours ago, mhoppi said:

Hello together,

first of all thank you for the cm12 build for this tablet. I just unlocked the bootloader and flashed twrp and installed cm12.
After that I tried to flash Gapps but it ended with error 139. No further messages. Play Services are stopping.

I tried to flash older Gapps but same error code. Without Gapps CM12 boots fine. 
Anyone knows how to solve this problem?

Furthemore I noticed that scrolling is very edgy. If i connect usb mouse and scroll with it, everything is fluid and quick, but with finger on touchpad it stutters a lot. Maybe this is bad drivers?

I have Chuwi HI10 Plus.

Thanks for every help and thanks a lot to the dev for this great work!

Make sure you have the right gapps package. Follow link on the first post of this thread (opengapps, x86, 5.1, pico).

I can't reproduce any issue with scrolling on my device.

Link to comment
Share on other sites

Here's another patch for Hibook Pro. This should get camera working. Please test that camera and camcorder work on both rear and front facing cameras. Rear facing camera should have 1080p option and please test that it also works.

cm-12.1-20161014-cht_cr_mrd_w-HibookPro-v2.zip
https://www.androidfilehost.com/?fid=385035244224387010
md5:cd1c0c61507586db2cc3c4170e259eaf

Link to comment
Share on other sites

47 minutes ago, KonstaT said:

Make sure you have the right gapps package. Follow link on the first post of this thread (opengapps, x86, 5.1, pico).

I can't reproduce any issue with scrolling on my device.

Hi KonstaT,

 

could you kindly attach your gapps you used or send me in a pm? 

I already thought the Gapps package from 23rd might be faulty. thats why I downloaded another alternative gapps package (1 year old) which neither worked.

What I mean with Touchscreen is, that it is very bad precision, when you enable touchscreen data in developer menu, you can see that it skips like 7 pixel at least.

I tried precision on windows and it is a lot better. its the same on stock remix though.

 

thanks for the effort!

Link to comment
Share on other sites

On 10/25/2016 at 0:53 PM, mhoppi said:

could you kindly attach your gapps you used or send me in a pm? 

I already thought the Gapps package from 23rd might be faulty. thats why I downloaded another alternative gapps package (1 year old) which neither worked.

What I mean with Touchscreen is, that it is very bad precision, when you enable touchscreen data in developer menu, you can see that it skips like 7 pixel at least.

I tried precision on windows and it is a lot better. its the same on stock remix though.

https://github.com/opengapps/x86/releases/download/20161012/open_gapps-x86-5.1-pico-20161012.zip

Can reproduce any touch precision issue either. Works fine on my device.

Edit. Yeah, now I see what you mean. On horizontal (x-axis) it goes every 6 pixels. On vertical (y-axis) it goes every ~2.6 pixels. I'm using the stock kernel (no kernel source available) so there's really nothing I can do about this.

Edited by KonstaT
Link to comment
Share on other sites

1 hour ago, KonstaT said:

Here's another patch for Hibook Pro. This should get camera working. Please test that camera and camcorder work on both rear and front facing cameras. Rear facing camera should have 1080p option and please test that it also works.

cm-12.1-20161014-cht_cr_mrd_w-HibookPro-v2.zip
https://www.androidfilehost.com/?fid=385035244224387010
md5:cd1c0c61507586db2cc3c4170e259eaf

All is working. I tested everything and all is fine. Thanks KonstaT!

Link to comment
Share on other sites

1 hour ago, davigar said:

All is working. I tested everything and all is fine. Thanks KonstaT!

Cool! Would you also mind testing the TWRP image I added to TWRP thread?

How about this? Or is the 20160616->20160906 OTA file available somewhere?

Quote

Do you have backup from before you installed SuperSU and modified boot image? I'd need untouched boot partition and original /system/bin/install-recovery.sh to create a stock recovery image and to verify sha1sums for stock boot and recovery images.

 

Edited by KonstaT
Link to comment
Share on other sites

6 hours ago, KonstaT said:

Cool! Would you also mind testing the TWRP image I added to TWRP thread?

How about this? Or is the 20160616->20160906 OTA file available somewhere?

I tested the TWRP image and works perfectly. I don't have and i can't find the 20160906 file. What is OTA update directory? I can flash the 20160616 version with phone flash tool and i can download ota.

EDIT: Here is the OTA update zip.

 

Edited by davigar
Link to comment
Share on other sites

1 hour ago, davigar said:

I tested the TWRP image and works perfectly. I don't have and i can't find the 20160906 file. What is OTA update directory? I can flash the 20160616 version with phone flash tool and i can download ota.

EDIT: Here is the OTA update zip.

Thanks. Got everything I needed. There's now stock recovery image in TWRP thread and patched boot image to disable dm-verity in root thread.

Link to comment
Share on other sites

Thank you for making this rom. But unfortunately it still freezes my vi10plus 2gb32gb (just like remix os) Funny thing is when i got a freeze on either one of my two tablets, the screen becomes unresponsive, but i am still capable of pulling down from the notification bar and eg. swipe away notifications. For example I could have a notification about a app is installed and i can swipe that away but the small icon on the top left in notification bar wil not dissapear as it normally would do. I can also press the settings wheel in the pull down window, but nothing happens.The android buttons at the bottom also lights up when i press them but nothing happens. everything else is frozen. The tablet keeps working as far as i can tell, despite the screen is of for ten minutes, because its a tiny bit warm, not much but just enough to tell that it isnt sleeping. I have no clue of what is going on with this model but its very annoying. ps. The screen on every 30sec when attached to keyboard problem still exists.

Edit. Ok that would be sometimes. This time the freeze would become complete freeze, after pulling down from notification bar two times.

Edit 2. And this was strange. New freeze, but this time with screen off. Was waiting to see screen wake up attached to keyboard but it didn't.  The clock had gone from 11.11 to 11.12. Actually the clock was 11.15. I figuren it had frozen in screen off mode and tried to swipe hope, that was possible for a couple of times but then everything was as frozen as the clock.

What could cause this strange behavior? Is there other things than wifi active in screen off mode? I am puzzled.

Many People have this problem with vi10plus Remix only model and saw a guy with hi10plus with same problem. Really not good

Edited by FatFreddyDK
Link to comment
Share on other sites

2 hours ago, FatFreddyDK said:

Thank you for making this rom. But unfortunately it still freezes my vi10plus 2gb32gb (just like remix os) Funny thing is when i got a freeze on either one of my two tablets, the screen becomes unresponsive, but i am still capable of pulling down from the notification bar and eg. swipe away notifications. For example I could have a notification about a app is installed and i can swipe that away but the small icon on the top left in notification bar wil not dissapear as it normally would do. I can also press the settings wheel in the pull down window, but nothing happens.The android buttons at the bottom also lights up when i press them but nothing happens. everything else is frozen. The tablet keeps working as far as i can tell, despite the screen is of for ten minutes, because its a tiny bit warm, not much but just enough to tell that it isnt sleeping. I have no clue of what is going on with this model but its very annoying. ps. The screen on every 30sec when attached to keyboard problem still exists.

Edit. Ok that would be sometimes. This time the freeze would become complete freeze, after pulling down from notification bar two times.

Edit 2. And this was strange. New freeze, but this time with screen off. Was waiting to see screen wake up attached to keyboard but it didn't.  The clock had gone from 11.11 to 11.12. Actually the clock was 11.15. I figuren it had frozen in screen off mode and tried to swipe hope, that was possible for a couple of times but then everything was as frozen as the clock.

What could cause this strange behavior? Is there other things than wifi active in screen off mode? I am puzzled.

Many People have this problem with vi10plus Remix only model and saw a guy with hi10plus with same problem. Really not good

Yeah, these are underlying issues somehere in BIOS, bootloader, kernel (no kernel source - using prebuilt stock kernel here as well), etc. Chuwi needs to release a software update to resolve these issues.

I've tested three kernels with CM12.1 (Vi10/Hi10 Plus Remix OS, Vi10 stock Android, Hi10 Pro Remix OS) and keyboard dock wake and touch precision issue are present with every one. Touchscreen precision issue also makes the stylus pen practically unusable. I've also experienced couple of random freezes with CM12.1. Even got logs (logcat, dmesg) but there was nothing specifically interesting there. To me it seems like the eMMC just stops responding. You can still access things that are in loaded in the RAM (launcher, systemui, etc) but can't read/write from/to the storage.

Link to comment
Share on other sites

Thanks for this rom.  I've also experienced random freezes with CM12.1. Downloaded a CM Theme from Playstore, and when I applied it, the Tablet froze. Had to do a forced shutdown, and when I restarted I had a bootloop[ on CM logo. Started from scratch with fastboot android rom and continued with dmverity, TWRP etc. Now back to where I was last night. Seems it's best to stay away from themes. Hopefully Chuwi will pay some attention to our problems and release a fix. I have sent in a request but thus far have not received a reply.

Link to comment
Share on other sites

Thanks for animering. I will wait or rater hope for a solution, the freezing is drivning me nuts.

In my desperation i have tried to flash Hi10 android rom from Chuwi forum on my Vi10. I took gpt file from Remix rom and boot.img from vi10plus android rom (dont ask me why 'cause i dont know what i am doing :-))

The result: 

Possive: seems a little more stabel but still freezes, but not that often (could be wishfull thinking)

Wifi a lot faster. Made 30-40 tests all with same result. Vi10plus rom, Remix and cm12 give 15-18 Mbit download and Hi10 rom give 27-30 sitting in the same distance from router. 

Keyboard wakeup is not every 30 sec. It's after 2min and then it seems random but with several minutes to between. 

Negative (dosnt really matter): the White on the screen eg. background in settings have a vague yellow teint.

No camera 

Rotation (accelrerometer) inverted. 

Volume way to loud

 

 

Edited by FatFreddyDK
Link to comment
Share on other sites

Found a big issue:

- Tablet ends in blackscreen, if sd card is inserted and the sd card contains more files

Only fix is to eject sd card and insert it after boot

On recovery & Windows there is no problem.

Screenshot_2016-10-27-23-37-25.jpg

Link to comment
Share on other sites

9 hours ago, yener90 said:

Found a big issue:

- Tablet ends in blackscreen, if sd card is inserted and the sd card contains more files

Only fix is to eject sd card and insert it after boot

On recovery & Windows there is no problem.

Logs (logcat, dmesg)? Screenshots are usually quite useless reporting issues.

You might have just described the infamous freeze issue...

Link to comment
Share on other sites

1 hour ago, KonstaT said:

Logs (logcat, dmesg)? Screenshots are usually quite useless reporting issues.

You might have just described the infamous freeze issue...

It doesnt happen suddenly, after every boot. I can't get it working anymore.

The thing is, i installed in Windows Visual Studio on SD Card, since then Android didnt start anymore with that issue.

USB connection didnt worked, also couldn't start anything to log. So cant provide it. 

But i found the solution: deleting /system/bin/fsck.exfat solved my problem. I know, deleting this, sd card will be no more checked, but couldn't find an other way.

Also realized, that if i tried to delete something from sd card, tablet restarted. Therefore i used mount.exfat from your provided twrp, which works much more stable.

 

although fsck.exfat is just a symlink to mount.exfat, replacing mount.exfat didnt solve the problem. fsck.exfat needs to be removed.

Edited by yener90
Link to comment
Share on other sites

On 10/27/2016 at 0:26 PM, KonstaT said:

Yeah, these are underlying issues somehere in BIOS, bootloader, kernel (no kernel source - using prebuilt stock kernel here as well), etc. Chuwi needs to release a software update to resolve these issues.

I've tested three kernels with CM12.1 (Vi10/Hi10 Plus Remix OS, Vi10 stock Android, Hi10 Pro Remix OS) and keyboard dock wake and touch precision issue are present with every one. Touchscreen precision issue also makes the stylus pen practically unusable. I've also experienced couple of random freezes with CM12.1. Even got logs (logcat, dmesg) but there was nothing specifically interesting there. To me it seems like the eMMC just stops responding. You can still access things that are in loaded in the RAM (launcher, systemui, etc) but can't read/write from/to the storage.

Hi Konsta,

I have sent a number of messages to "Emily" on Chuwi Forum, but to date have not had a response. Perhaps if we all kept bombarding her with our complaints/problems, we might get a reply.

Also complained to Gearbest who have agreed to give me a partial refund ( 25%), and also allow me to keep the tablet, (return shipping would cost too much).

All we need now is for Chuwi to upgrade the android firmware, so you can do a fix for CM12.1.

Thanks for your efforts, and kind regards.

Link to comment
Share on other sites

New build.

cm-12.1-20161028-UNOFFICIAL-KonstaKANG-chuwi_vi10plus.zip
https://www.androidfilehost.com/?fid=385035244224388281
md5:2d57fa51a6baf9b0a475c7cc5a926b13

-rename device codename to chuwi_vi10plus
-SELinux enforcing
-fix Play Store compatibility with some apps (location permissions)
-build wifi (wpa_supplicant/hostapd) from source
-stylus pen "works"

Hibook Pro patch needs an update, too.

cm-12.1-20161028-chuwi_vi10plus-HibookPro.zip
https://www.androidfilehost.com/?fid=385035244224388282
md5:941c7d793ea9741122b3b2add2795a09

Link to comment
Share on other sites

10 hours ago, yener90 said:

It doesnt happen suddenly, after every boot. I can't get it working anymore.

The thing is, i installed in Windows Visual Studio on SD Card, since then Android didnt start anymore with that issue.

USB connection didnt worked, also couldn't start anything to log. So cant provide it. 

But i found the solution: deleting /system/bin/fsck.exfat solved my problem. I know, deleting this, sd card will be no more checked, but couldn't find an other way.

Also realized, that if i tried to delete something from sd card, tablet restarted. Therefore i used mount.exfat from your provided twrp, which works much more stable.

although fsck.exfat is just a symlink to mount.exfat, replacing mount.exfat didnt solve the problem. fsck.exfat needs to be removed.

So you've formatted your sdcard as exFAT? I'd still recommend using FAT32 where possible.

Maybe you've corrupted your sdcard somehow or it just takes really long time for fsck to check the card. Logs would likely tell. You can 'adb logcat' even when the device is booting.

7 hours ago, mattiesrag said:

Hi Konsta,

I have sent a number of messages to "Emily" on Chuwi Forum, but to date have not had a response. Perhaps if we all kept bombarding her with our complaints/problems, we might get a reply.

Also complained to Gearbest who have agreed to give me a partial refund ( 25%), and also allow me to keep the tablet, (return shipping would cost too much).

All we need now is for Chuwi to upgrade the android firmware, so you can do a fix for CM12.1.

Thanks for your efforts, and kind regards.

Maybe I should ask Gearbest for my money back, too. Got a partial refund for my previous tablet (Cube iWork8 Ultimate) as it has charging/battery issues.

I've been able to reproduce the freezing issue couple of times but it really doesn't bother me that much. I bought this device mainly just as a dev toy anyway. Sadly keyboard dock is practically useless because of the wake issue and stylus pen is practically useless because of touchscreen accuracy issue (+no pressure sensitivity & no palm rejection in Android).

Edited by KonstaT
Link to comment
Share on other sites

On 27/10/2016 at 0:26 PM, KonstaT said:

Yeah, these are underlying issues somehere in BIOS, bootloader, kernel (no kernel source - using prebuilt stock kernel here as well), etc. Chuwi needs to release a software update to resolve these issues.

I've tested three kernels with CM12.1 (Vi10/Hi10 Plus Remix OS, Vi10 stock Android, Hi10 Pro Remix OS) and keyboard dock wake and touch precision issue are present with every one. Touchscreen precision issue also makes the stylus pen practically unusable. I've also experienced couple of random freezes with CM12.1. Even got logs (logcat, dmesg) but there was nothing specifically interesting there. To me it seems like the eMMC just stops responding. You can still access things that are in loaded in the RAM (launcher, systemui, etc) but can't read/write from/to the storage.

You are probably right about this emmc. I have flashed very many times last 6 weeks and a couple of times tablet freezes already opon first boot when optimizing apps.

Link to comment
Share on other sites

2 hours ago, FatFreddyDK said:

You are probably right about this emmc. I have flashed very many times last 6 weeks and a couple of times tablet freezes already opon first boot when optimizing apps.

I've even read some reports of this freezing happening every ten minutes or so. It's nowhere near the severe on my device. Only happened couple of times and I've really tried to punish my device hard last couple of days and can't reproduce it even if I wanted to. Makes wonder if there's also some hardware aspect to this problem. I'd still say it's a software issue as there's been reports this is not happening with Windows.

Link to comment
Share on other sites

I've even read some reports of this freezing happening every ten minutes or so. It's nowhere near the severe on my device. Only happened couple of times and I've really tried to punish my device hard last couple of days and can't reproduce it even if I wanted to. Makes wonder if there's also some hardware aspect to this problem. I'd still say it's a software issue as there's been reports this is not happening with Windows.

Mine is pretty frequent. I am rocking 1 hour if am Lucky. It's not a heat problem as it also happens when tablet is cold. And it's total random. Could be at boot or after 1 hour. And i do not need to do anything special to make it freeze. It just happens. Open browser and load Google.com.....freeze. Watch YouTube, suddently freeze. And just the same on both my tablets (and same as all other owners with this tablet and this problem) Yeah if Windows 10 works without freeze it gives hope. Wandering why Chuwi is ignoring this.

Link to comment
Share on other sites

I don't have this problem on Hi10 Pro. it doesn't freeze. just the deep sleep bug.

My emmc is from Samsung. Get sd insight and check your internal memory.

Edited by yener90
Link to comment
Share on other sites

2 hours ago, yener90 said:

I don't have this problem on Hi10 Pro. it doesn't freeze. just the deep sleep bug.

My emmc is from Samsung. Get sd insight and check your internal memory.

[email protected]_vi10plus:/ # cat /sys/devices/pci0000:00/80860F14:00/mmc_host/mmc0/mmc0:0001/name
NCard

 

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.