Jump to content

LineageOS 14.1 for Vodafone Smart Ultra 6


Guest nutsda
 Share

Recommended Posts

Guest Odour Fone

Automatic battery optimization setting fixed the glitches with the UI.

no need for governor tweaks.

Edited by Odour Fone
Link to comment
Share on other sites

  • 4 weeks later...
  • 2 weeks later...
Guest ghoula_lo

So... i had the latest rom and the apps in my phone suddenly asking to be closed due to some errors...

it was constant, so I decided to reboot. when it turned on, it said the encryption wasnt sucessful.. so i went to recovery mode and did a factory reset.. 

it was done but when i turn on the phone it got in a loop (so i tought to clear cache). i did but then appeared an error. "unmount data".. ou "unmount storage"

i went to two phone shops none had a solution.. my phone is dead :/

Link to comment
Share on other sites

Guest Odour Fone
17 hours ago, ghoula_lo said:

So... i had the latest rom and the apps in my phone suddenly asking to be closed due to some errors...

it was constant, so I decided to reboot. when it turned on, it said the encryption wasnt sucessful.. so i went to recovery mode and did a factory reset.. 

it was done but when i turn on the phone it got in a loop (so i tought to clear cache). i did but then appeared an error. "unmount data".. ou "unmount storage"

i went to two phone shops none had a solution.. my phone is dead ?

You have twrp recovery? Just goto wipe > advanced wipe, select √system, √data, √dalvic √cache, then flash the ROM again.

Edited by Odour Fone
Link to comment
Share on other sites

Guest nutsda
9 hours ago, ghoula_lo said:

So... i had the latest rom and the apps in my phone suddenly asking to be closed due to some errors...

it was constant, so I decided to reboot. when it turned on, it said the encryption wasnt sucessful.. so i went to recovery mode and did a factory reset.. 

it was done but when i turn on the phone it got in a loop (so i tought to clear cache). i did but then appeared an error. "unmount data".. ou "unmount storage"

i went to two phone shops none had a solution.. my phone is dead ?

The only thing I can suggest is to try formatting the partitions from the advanced wipe menu & re-install Lineage

Link to comment
Share on other sites

Guest nutsda

Just a quick update! I have finally managed to get Oreo booting, but at the moment not much is working. As I don't have much free time please don't ask for an ETA, I will upload a beta for testing when I've ironed out the major bugs.

IMG_20180820_053024.jpg

Link to comment
Share on other sites

Guest AGENTU007
On 8/19/2018 at 8:40 PM, nutsda said:

Just a quick update! I have finally managed to get Oreo booting, but at the moment not much is working. As I don't have much free time please don't ask for an ETA, I will upload a beta for testing when I've ironed out the major bugs.

IMG_20180820_053024.jpg

thanks for your work

Link to comment
Share on other sites

  • 4 weeks later...
  • 2 weeks later...

OK, I'm having a spot of trouble rooting 6.0.1 VDF-995NB02-UK10d

The recommended apps dont seem to be working. I'm guessing it's due to the latest update last year sometime.

Is there a recommended way to root at the moment?

Re this ROM, do I need to install on top of marshmallow or can I roll back to lollipop somehow, root and then install lineage?

Link to comment
Share on other sites

Guest yomarshmellow
On 8/19/2018 at 6:40 PM, nutsda said:

Just a quick update! I have finally managed to get Oreo booting, but at the moment not much is working. As I don't have much free time please don't ask for an ETA, I will upload a beta for testing when I've ironed out the major bugs.

IMG_20180820_053024.jpg

Could I ask for some help about porting? I am a beginner at porting roms and I have attempted to port RR 5.8.5 to this phone. I followed all the instructions of what to do from this thread: https://forum.xda-developers.com/showthread.php?t=1941239

The phone installed the rom successfully however it gets stuck in the 'Powered by Android' screen for a while till it reboots back into recovery.

This rom was ported from the Mi 4i. If you could give me some advice that would be greatly helpful, thank you. ?

Link to comment
Share on other sites

Guest tcpaulh
3 hours ago, yomarshmellow said:

Could I ask for some help about porting? I am a beginner at porting roms and I have attempted to port RR 5.8.5 to this phone. I followed all the instructions of what to do from this thread: https://forum.xda-developers.com/showthread.php?t=1941239

The phone installed the rom successfully however it gets stuck in the 'Powered by Android' screen for a while till it reboots back into recovery.

This rom was ported from the Mi 4i. If you could give me some advice that would be greatly helpful, thank you. ?

I know very little but there is this... If you have made an insecure boot image then adb access is enabled much earlier for debugging. Maybe this will help

Link to comment
Share on other sites

Guest nutsda
5 hours ago, yomarshmellow said:

Could I ask for some help about porting? I am a beginner at porting roms and I have attempted to port RR 5.8.5 to this phone. I followed all the instructions of what to do from this thread: https://forum.xda-developers.com/showthread.php?t=1941239

The phone installed the rom successfully however it gets stuck in the 'Powered by Android' screen for a while till it reboots back into recovery.

This rom was ported from the Mi 4i. If you could give me some advice that would be greatly helpful, thank you. ?

I've never had a go porting ROMs that way, I just know that the base & port ROMs have to the same android version & that you also have to modify the boot.img also.

Due to the fact it's stuck on the powered by android screen, I believe the issue lies with boot.img / kernel side of things not loading. I actually did compile RR 5.8.5 from source a while ago (but have since removed the RR source code from my PC to free up space). Here is a copy of the build I did for you to try if you like RR-N-v5.8.5-20180716-p839v55-Unofficial.zip

Link to comment
Share on other sites

Has anyone had problems with apps crashing due to not being able to obtain X.509 key.
Having installed the latest ROM I have got this with 2 apps.
Strangely they both work on a Samsung SM-T900 with Lineage 14.1, although an earlier build and on a Samsung SM-T900
A google search just brings up some people who have had the same problem but no solutions.
The security settings look to be the same.
Any suggestions gratefully received.

The logcat shows the following in both cases.

AndroidRuntime: Caused by: java.security.UnrecoverableKeyException: Failed to obtain X.509 form of public key
AndroidRuntime:        at android.security.keystore.AndroidKeyStoreProvider.loadAndroidKeyStorePublicKeyFromKeystore(AndroidKeyStoreProvider.java:230)
AndroidRuntime:        at android.security.keystore.AndroidKeyStoreProvider.loadAndroidKeyStoreKeyPairFromKeystore(AndroidKeyStoreProvider.java:259)
AndroidRuntime:        at android.security.keystore.AndroidKeyStoreKeyPairGeneratorSpi.loadKeystoreKeyPair(AndroidKeyStoreKeyPairGeneratorSpi.java:509)
AndroidRuntime:        ... 23 more
AndroidRuntime: Caused by: android.security.KeyStoreException: -32
AndroidRuntime:        at android.security.KeyStore.getKeyStoreException(KeyStore.java:676)
AndroidRuntime:        at android.security.keystore.AndroidKeyStoreProvider.loadAndroidKeyStorePublicKeyFromKeystore(AndroidKeyStoreProvider.java:231)
AndroidRuntime:        ... 25 more

Link to comment
Share on other sites

Guest alexandrecsf
On 10/14/2018 at 7:15 AM, fstfst said:

Has anyone had problems with apps crashing due to not being able to obtain X.509 key.
Having installed the latest ROM I have got this with 2 apps.
Strangely they both work on a Samsung SM-T900 with Lineage 14.1, although an earlier build and on a Samsung SM-T900
A google search just brings up some people who have had the same problem but no solutions.
The security settings look to be the same.
Any suggestions gratefully received.

The logcat shows the following in both cases.

AndroidRuntime: Caused by: java.security.UnrecoverableKeyException: Failed to obtain X.509 form of public key
AndroidRuntime:        at android.security.keystore.AndroidKeyStoreProvider.loadAndroidKeyStorePublicKeyFromKeystore(AndroidKeyStoreProvider.java:230)
AndroidRuntime:        at android.security.keystore.AndroidKeyStoreProvider.loadAndroidKeyStoreKeyPairFromKeystore(AndroidKeyStoreProvider.java:259)
AndroidRuntime:        at android.security.keystore.AndroidKeyStoreKeyPairGeneratorSpi.loadKeystoreKeyPair(AndroidKeyStoreKeyPairGeneratorSpi.java:509)
AndroidRuntime:        ... 23 more
AndroidRuntime: Caused by: android.security.KeyStoreException: -32
AndroidRuntime:        at android.security.KeyStore.getKeyStoreException(KeyStore.java:676)
AndroidRuntime:        at android.security.keystore.AndroidKeyStoreProvider.loadAndroidKeyStorePublicKeyFromKeystore(AndroidKeyStoreProvider.java:231)
AndroidRuntime:        ... 25 more

I just wanted to add that I had keystore problems as well, both on LineageOS 14.1 and 13.
I don't think it was "failed to obtain X.509" but rather the keystore "wasn't there" (or something similar).
Signal, the messaging app, would crash on start unless I used a much older .apk that didn't use the keystore.
BItwarden wouldn't work either.
I had to get the Gipsy ROM for a simple ROM with root (which meant I downgraded from Marshmallow to Lollipop).
 

Link to comment
Share on other sites

  • 2 weeks later...
Guest yomarshmellow
On 10/6/2018 at 11:34 PM, nutsda said:

I've never had a go porting ROMs that way, I just know that the base & port ROMs have to the same android version & that you also have to modify the boot.img also.

Due to the fact it's stuck on the powered by android screen, I believe the issue lies with boot.img / kernel side of things not loading. I actually did compile RR 5.8.5 from source a while ago (but have since removed the RR source code from my PC to free up space). Here is a copy of the build I did for you to try if you like RR-N-v5.8.5-20180716-p839v55-Unofficial.zip

Hey, it's me again. I learnt that the best way to get RR running to the device is through compiling it through the sources. I followed this video (listed below) on how to compile RR to your device and at some point the man mentioned how you had to download the Lineage device repo and kernel repo from Github and download them through terminal. The problem is there are no repos for p839v55. Am I overlooking something? Thanks.

Video: https://www.youtube.com/watch?v=cWNaMgyrVGM

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.