• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

"No Service" after reassembling MPx220

1 post in this topic


I recently bought a new black housing for my MPx220 on eBay. I took the phone apart today to put the new housing on and everything went great except that now I get a "No Service" message when I turn my phone on.

I don't know what's causing this. I made sure to transfer the antenna sticker over to the new housing, and everything looks like it's connecting just fine. The antenna was a little wrinkled when I moved it over, but it flattened out and stuck to the new housing without much trouble. It doesn't seem to be torn anywhere. I've also tried another SIM card just to be sure it wasn't that. For the record, I followed the instructions here: http://www.cnn.cn/mpx220/mpx220instruction.htm

I've taken it back apart and reseated everything half a dozen times. Does anybody have any advice on what I could try next? =[


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.