• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

Qtek 8310 Mainboard question

1 post in this topic

Posted · Report post

So I got a brand new Qtek 8310 phone a month ago. With my luck, it got stolen but I managed to have it returned to me (Long story).

When I got it back, the person who stole my phone tried to charge it without the proper charger and somehow short circuited the phone or something. When I had it looked at by a phone tech in the area, he said the leads that connect the charger to the mainboard are all rusted out and have come off. He said I would have to get a new or used mainboard for the phone and it would be fine.

Does anyone know what I should do about this?

Where can I get a new or used mainboard for the qtek 8310 or Imate SP-5 or any of the sister phones?

How much would that cost me?

Or is there a way I can get the phone working without replacing the complete board? Only the part which connects the charger lead to the mainboard allowing the phone to charge is messed up.

The battery does not power up the phone either....but I think thats because the battery is completely drained out.

Also, I dont know if this helps, but after a few days, I tried charging the phone again and the charge light on the phone came on and then faded off slowly after a second. And then nothing.

Any help would be appreciated!

Thanks

H P

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.