htctouchcruiser

SIM trouble

3 posts in this topic

He everybody,

Just got my new HTC Touch Cruise, unlocked. Used it in the US, with an AT&T SIM, no problem. Got back to Costa Rica, and plugged in the SIM from the local phone company, and now the device says "no SIM found". What's up? Did the AT&T service now lock the phone to only their SIM? Tried also another SIM from the local phone company, not recognized either. Put the AT&T SIM back in, and that works.

Can anybody help? Been browsing around, and found many people have this problem, and no one seems to be able to find a common explanation/solution.

0

Share this post


Link to post
Share on other sites

I would imagine that If you bought the phone from AT&T on a contract then they would probably lock the device to their network only. If it is locked to the network, you may be able to unlock the device by calling AT&T??.. might charge you though.

0

Share this post


Link to post
Share on other sites

i had trouble with my sim, make sure you have fully pressed the SIM down till it clicks, if you have done this and still no joy, moouch on over to XDA forum theres a Hard Spl out for the polaris which will unlock it

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.