Jump to content

SIM trouble


Guest htctouchcruiser
 Share

Recommended Posts

Guest htctouchcruiser

He everybody,

Just got my new HTC Touch Cruise, unlocked. Used it in the US, with an AT&T SIM, no problem. Got back to Costa Rica, and plugged in the SIM from the local phone company, and now the device says "no SIM found". What's up? Did the AT&T service now lock the phone to only their SIM? Tried also another SIM from the local phone company, not recognized either. Put the AT&T SIM back in, and that works.

Can anybody help? Been browsing around, and found many people have this problem, and no one seems to be able to find a common explanation/solution.

Link to comment
Share on other sites

  • 2 months later...
Guest Cal472

I would imagine that If you bought the phone from AT&T on a contract then they would probably lock the device to their network only. If it is locked to the network, you may be able to unlock the device by calling AT&T??.. might charge you though.

Link to comment
Share on other sites

  • 4 months later...

i had trouble with my sim, make sure you have fully pressed the SIM down till it clicks, if you have done this and still no joy, moouch on over to XDA forum theres a Hard Spl out for the polaris which will unlock it

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.