inutero

ADB server keeps shutting down

1 post in this topic

Have my Legend running prebaked MCR R4 (Froyo).

Installed AdFree, copied hosts from sdcard to /data/data, renamed original hosts file in /system/etc, and symlinked the new file. So there was no problem connecting the device and using ADB. Didn't install any other apps after that.

I don't know what happened, 2-3 hours have passed. I try to connect the device the same way (using Clockworkmod recovery and adb shell). The ADB server keeps shutting down! I can't perform a single command :)

Installed the SDK on an other PC. Same thing. The server keeps shutting down.

So I suppose the problem might be caused by the phone, not by the PC software. Tried a different USB cable. No change.

Does anyone have any idea, what could be causing the problem? I'm frustrated!

UPD: can't run recovery-windows.bat to have a custom recovery menu...

The thing is that the ADB server shuts down (or times out) when the phone is in recovery mode. When I connect it in HTC Sync mode, everything is OK, but I have no rights to perform the needed operations

Edited by inutero
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.