• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

Lost SD Card and USB ability..

1 post in this topic


If any of you are XDA members I apologise ive also posted this there but im in desperation now..

Hi guys, had a perfectly working legend running CM7, been helping a mate root his phone so I downloaded a rom onto my phone (we had no sd card readers), swapped out my sd card into his and all was well.

Placed the card back in my legend and now:

Cant see the sdcard/phone on my computer when attached through USB.

The phone cant see ANY SDcard I place inside it (tried 2).

Phone cant seem to USB charge either on or off (although on my home computer i seem to be able to keep a charge cycle going.. must be a driver thing).

When I connect to the computer when its on, the charge icon appears and a minute later disappears no longer seems to register charging whilst on. But whilst off the phone displays the usual red led light for a minute, then starts flashing red and green led, wtf is going on?

Running adb I can get it to register with adb devices.

running fastboot mode on the phone, i can get cmd shell, fastboot devices to also register a device, so both adb and fastboot are working via usb.

Running the R4-Legend recovery bat starts the process, then stops i cant see the error...this goes for step 1 step 2 and recovery.bat i believe its immediately after pushing a file across it complains that /sdcard cannot be found.

this is further proved in a terminal editor on the phone: running cd /sdcard, cannot be found..

Cant get to cwm since i cant run the recovery program (above) i can get to the red triangle with exclamation mark screen (recovery)..

Ive been trying to follow the usb unbrick but im stumped how i get the files into /data without use of a sd drive... downloading in google mail (app and web app) results in a fail because there is no sdcard present..great. It would seem that even though you can turn a android device on without a sd-card, all apps seem to depend on a sd card being present.

Used fastboot oem enableqxdm 0 in windows cmd shell (multiple times ive tried so theres no sp) it says it works, then fastboot reboot but alas Still no sd card present when the device loads..

C:\android_sdk\android_windows\tools>fastboot devices

HT03KNX0XXXXX fastboot

C:\android_sdk\android_windows\tools>fastboot oem enableqxdm 0

... OKAY [ 0.018s]

finished. total time: 0.018s

C:\android_sdk\android_windows\tools>fastboot oem boot

... INFOsetup_tag addr=0x60000100 cmdline add=0x9D



INFOTAG:smi ok, size = 0

INFOTAG:hwid 0x0

INFOTAG:skuid 0x22F00

INFOTAG:hero panel = 0x0

INFOTAG:engineerid = 0x0

INFOMCP dual-die

INFOMCP dual-die

INFOTAG:mono-die = 0x0

INFODevice CID is not super CID



INFOserial number: HT03KNX01884

INFOcommandline from head: no_console_suspend=1 console=null

INFOcommand line length =439

INFOactive commandline: board_legend.disable_uart3=0 board_legen

INFOd.usb_h2w_sw=0 board_legend.disable_sdcard=0 diag.enabled=0

INFOboard_legend.debug_uart=0 smisize=0 userdata_sel=0 androidbo

INFOot.emmc=false androidboot.baseband= androidboot.

INFOcid=HTC__001 androidboot.carrier=HTC-WWE androidboot.mid=PB7

INFO610000 androidboot.keycaps=qwerty androidboot.mode=normal an

INFOdroidboot.serialno=HT03KNX01884 androidboot.bootloader=0.43.

INFO0001 no_console_suspend=1 console=null







INFOpartition number=6

INFOValid partition num=6

INFOmpu_nand_acpu_rw 8F2 1000

FAILED (status read failed (Too many links))

finished. total time: 0.911s


Heres a fastboot oem boot log:

WTF have I done? Have i physically broken it when i put the sd card back in?

Im not sure if this is usb bricked as I should be able to see the sd card on the phone right?


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.