• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.

gen1 to gen2 and gen2 to gen1, windows flashing only

350 posts in this topic

Posted · Report post

that's great news for anyone who bought a gen1 device, but for those who bought a gen2 device, this guide is still needed. You cant revert to Gen1 if your device never was Gen1.

What do you mean? If you bought a gen2 device, why would you want to upgrade to gen2? For the repartitioning of /system and /cache and OEM? Don't even know id it works. Does it?

I'd modify the first post and link to the simpler and risk free version of wbaw, the windows method claimed some victims.

@dibbles and Mahendra Soni - no idea what's wrong there. I'd try to copy on the card Sebastian's Gen2 clockwork update.zip (see the stickies) and flash it from recovery.

0

Share this post


Link to post
Share on other sites

Posted · Report post

sounds like the new boot.img is not taking effect.

Any solution please .... i m so upset :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

format it, and stay in clockwork then install rls4b

I assure you I have done.

I have just done the whole process again and then flashed with 4b and it will boot to CWM each and every time.

I hope I have not got a brick now :)

Thanks for any help

0

Share this post


Link to post
Share on other sites

Posted · Report post

I assure you I have done.

I have just done the whole process again and then flashed with 4b and it will boot to CWM each and every time.

I hope I have not got a brick now :)

Thanks for any help

Same here ... I also repeated the same process and even flashed with "Swedish_Spring_RLS5.zip" but still it automatically boots into recovery.

0

Share this post


Link to post
Share on other sites

Posted · Report post

groan this is not encouraging :)

best of luck to you Mahendra

0

Share this post


Link to post
Share on other sites

Posted · Report post

Just went through the whole process again and this time with the std partition layout. That worked a treat. But then with an install of SS RLS4b it will only now boot into recovery.

I am quite distraught :)

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Don't panic, as long as you come into recovery, nothing can go wrong, you don't have a brick. Try to flash CM7 N41 and see if it works. Or maybe combined with kallt_kaffe's universal converter from here.

For all people wanting to upgrade to Gen2, use wbaw's TPT method here, it's much simpler, risk-free, TPT remains enabled and switching to Gen1 is done through TPT without corrupting the IMEI. If you are already on Gen2 don't TPT wbaw's method or else you could brick it.

Edited by Rotmann
0

Share this post


Link to post
Share on other sites

Posted · Report post

@Rotmann - thanks for your words of encouragement

I have got it to work BUT.....

My IMEI number is not the same as the one under the battery cover..?! The phone works fine and I have my original channel1.nvm file so is there anything that I can do to sort that out..?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Don't panic, as long as you come into recovery, nothing can go wrong, you don't have a brick. Try to flash CM7 N41 and see if it works. Or maybe combined with kallt_kaffe's universal converter from here.

For all people wanting to upgrade to Gen2, use wbaw's TPT method here, it's much simpler, risk-free, TPT remains enabled and switching to Gen1 is done through TPT without corrupting the IMEI. If you are already on Gen2 don't TPT wbaw's method or else you could brick it.

Hi Rotomann, I was having the same as Dibbles was, but while trying my Blade done, I not only formatted data, but also system, boot etc in Mount sdcard menu. Now after restart my blade is stuck on green android logo. Even i try to get into recovery mode, it still stuck on green android logo. I know i have messed up with my mobile and i think now i have completely bricked it.

Is there still any hope for me plz :)

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

@Rotmann - thanks for your words of encouragement

I have got it to work BUT.....

My IMEI number is not the same as the one under the battery cover..?! The phone works fine and I have my original channel1.nvm file so is there anything that I can do to sort that out..?

Did you revert back to Gen1? Could you explain EXACTLY STEP BY STEP what you did?

Hi Rotomann, I was having the same as Dibbles was, but while trying my Blade done, I not only formatted data, but also system, boot etc in Mount sdcard menu. Now after restart my blade is stuck on green android logo. Even i try to get into recovery mode, it still stuck on green android logo. I know i have messed up with my mobile and i think now i have completely bricked it.

Is there still any hope for me plz :)

Oh crap you have formatted recovery with format /boot I think. You can try this guide. Tell us if you made it.

Edited by Rotmann
0

Share this post


Link to post
Share on other sites

Posted · Report post

Did you revert back to Gen1? Could you explain EXACTLY STEP BY STEP what you did?

Oh crap you have formatted recovery with format /boot I think. You can try this guide. Tell us if you made it.

Ok i am trying it now. Thanks for you help.

I keep my fingers crossed :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

Did you revert back to Gen1? Could you explain EXACTLY STEP BY STEP what you did?

What I did (out of desperation)

Is to go back to Gen 1. Using this method...

Why I need back to Gen1 ? because i have voice problem from caller after Gen2

What files I have?

1. Gen1 >> Gen2 conversion ( Thread How to upgrade GEN1 to GEN2, windows only...)

2. Standard Partition Size (TPT) TFT/OLED [GEN1] (NO ROM) provided by kallt_kaffe

3. restore stock recovery (include from Gen1 >> Gen2 conversion )

1. Boot into clockwork and install stock recovery

2. Boot into FTM (volume-down)

3. Extract Standard Partition Size (image_original.zip) and replace the files in "to_gen2_xxxmb_system/files" directory

4. run "download_nochecksGen2.exe"

5. wait for reboot into clockwork.

6. install any Gen1 Rom you like

Then I went back to Gen 2 using gen2_136mb_system_no_oem_15mb_cache and not only did it then work perfectly as soon as I then installed SS RLS4b it then booted perfectly normally. But with the changed IMEI number.

This only started as I was lead to believe that if I ran the Gen2 converter again it would back up my channel1.nvm file (which I failed to do the first time). It did and I have now got that. BUT tha tis where this issue started. It did not seem to like going from a GEN 2 to a GEN 2 without getting stuck in that CWM boot loop.

Installing any ROM - n41 or SSRLS4b or using the n41 and the Universal Converter simply would not work.

So even though I now have a fully functioning phone I have the wrong IMEI number but a valid channel1.nvm file but I do not know how to get that number back to what is under the battery compartment.

Thanks for any help

0

Share this post


Link to post
Share on other sites

Posted · Report post

You have to inject Channel1.nvm between 6% and 11% when converting to Gen2 again. You have to try it several times but you will succeed if you perseverate. Here's a guide.

0

Share this post


Link to post
Share on other sites

Posted · Report post

You have to inject Channel1.nvm between 6% and 11% when converting to Gen2 again. You have to try it several times but you will succeed if you perseverate. Here's a guide.

you are a very generous person with your help, thank you :)

I have had so many ROM's and flashes and fixes on this phone in the last few hours then I have in the last few weeks I have owned it...!!!

Following that link I did EXACTLY as it was stated and now I have the correct IMEI number (it was easy to insert it at the right time).

Then I had to root the phone again - Universal root.

Then Clockwork

Then install Lance's variation of SS.

Now I'm restoring via Titanium

What an experience and I really did think that I bricked my phone.

Not too sure why re-running the GEN 2 converter would cause the issues it did though..?

Thanks for your help :)

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Oh crap you have formatted recovery with format /boot I think. You can try this guide. Tell us if you made it.

I have managed to boot my Blade again into recovery mode using burstlam's tool. Now again even after flashing CM N41 ROM, its getting into recovery mode again. I can't make my Blade reboot normally. It always going into recovery after rebooting :)

Edited by Mahendra Soni
0

Share this post


Link to post
Share on other sites

Posted · Report post

Revert to Gen1 and use wbaw's method to go to Gen2, this method is too risky.

@hectae, what about taking this guide offline and putting wbaw's guide as sticky? I don't really see any real benefit of this are there are a few people who had problems with this.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Revert to Gen1 and use wbaw's method to go to Gen2, this method is too risky.

@hectae, what about taking this guide offline and putting wbaw's guide as sticky? I don't really see any real benefit of this are there are a few people who had problems with this.

You make a valid point but for those who have used the files and the guide there is still a need to have access to it, and the files if we wish to repartition, as we can't use the alternative method provided by wbaw.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Just for add a little note.

We have a solution to restore original IMEI on GEN1 after downgrade with Windows program. I don't know if this work for all, or if peoples have this problem but it's working for me. Two conditions for that:

-be able to switch to GEN2>GEN1 with Windows flasher and tools from related post.

-Only for people who have the real IMEI on GEN2 and fake IMEI after GEN2>GEN1 downgrade (000039.... even with channel1.nvm trick)

Thanks to leromarinvit who have guide me and burstlam who have given the program to achieve that. :)

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi

At the outset, I need you to write that my English is not too good.

I upgrade my OSF to gen2, but I'm too small partitions (128mb) I would like to change it to 136 mb but I do not know how.

Can you help me ?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Hi

At the outset, I need you to write that my English is not too good.

I upgrade my OSF to gen2, but I'm too small partitions (128mb) I would like to change it to 136 mb but I do not know how.

Can you help me ?

You could try this

http://android.modaco.com/content/zte-blad...l-windows-only/

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I tried but I do not know how to use it, there is described a way to change the Gen1 to Gen2, but I am already on the gen2. I guess that something is not understood.

I downloaded the progam on the computer, generate by these two files and pasted them into a file downloaded files on your computer but do not know what's next.

Would you describe it to me step by step?

Edited by Geodeta
0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

I tried but I do not know how to use it, there is described a way to change the Gen1 to Gen2, but I am already on the gen2. I guess that something is not understood.

I downloaded the progam on the computer, generate by these two files and pasted them into a file downloaded files on your computer but do not know what's next.

Would you describe it to me step by step?

Just follow the instructions in the first post apart from an extra step after step two: if you want to change the partitions sizes you just have to replace partition_zte.mbn and appsboot.mbn in the "files" folder with the partition_zte.mbn and appsboot.mbn files created when you use the custom partition layout tool Cobble posted.

NOTE: It worked for me when I was already on gen 2 and I just wanted to change the partition sizes. It may not work for you.

Edited by Decadence
0

Share this post


Link to post
Share on other sites

Posted · Report post

Just follow the instructions in the first post apart from an extra step after step two: if you want to change the partitions sizes you just have to replace partition_zte.mbn and appsboot.mbn in the "files" folder with the partition_zte.mbn and appsboot.mbn files created when you use the custom partition layout tool Cobble posted.

NOTE: It worked for me when I was already on gen 2 and I just wanted to change the partition sizes. It may not work for you.

I have just used the flasher again to create partition sizes more suited to my needs using that partition tool and replacing those files as you did. It worked a treat.

0

Share this post


Link to post
Share on other sites

Posted · Report post

I have just used the flasher again to create partition sizes more suited to my needs using that partition tool and replacing those files as you did. It worked a treat.

Nice one, but I thought you had downgraded from gen 2 to gen 1 so you could use the TPT method to change gen version...?

0

Share this post


Link to post
Share on other sites

Posted (edited) · Report post

Hello guy's.

I need help.

After upgrading my blade to gen2, my blade never worked the same. :)

With 2.2 rom I have clockworkmod recovery working, now I don't.

So, I've never been able to upgrade my blade to another rom, any longer. I'm using N41.

With 2.3.3 rom Universal androot dosen't work, so i installed Z4root but it starts to root but seems never ending...

Revovery manager v.0,6b dosen't work either, keeps Force closing...

strangely my wireless, after a perfect day working, stop working the very nest day. :)

Is there any method to put the blade in recovery mode using the pc?

this cood be noob questions but I don't know what more to try.

Any help is well apretiated.

Sory for my poor english...

Regards from Portugal.

Ok, guys.

I've managed to solve the problem by following this thread

http://android.modaco.com/content/zte-blad...en2-conversion/

Thanks

Edited by msylva
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.