• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

Samsung Omnia II Official Twitter v2.20 (UPDATED 04/05/2011)

58 posts in this topic

Posted

could you upload the .exe and post the link??

thanks!,

nachoijs

I extracted the exe from the .cab using MSCEInf, I send the twitter app via bluetooth and it's working perfect, but in english and korean. I don't know whats the problem :-(

post-422176-1308849921_thumb.jpgpost-422176-1308850120_thumb.jpg

0

Share this post


Link to post
Share on other sites

Posted (edited)

could you upload the .exe and post the link??

thanks!,

nachoijs

of course..

the original (non translated) Korean .exe (but, you should use the original .cab)

Twitter_v2.20_SKT.CAB

Twitter.exe

Edited by eXPerience
0

Share this post


Link to post
Share on other sites

Posted

it runs, but when i enter my user & pass i get a network error...,

but the connection is ok

:)

of course..

the original (non translated) Korean .exe (but, you should use the original .cab)

Twitter_v2.20_SKT.CAB

Twitter.exe

0

Share this post


Link to post
Share on other sites

Posted (edited)

Connection error? Is it failed to login like the old v1.2 that around?

----------------------

For error when running:

I think I managed to cornered the issue, why every apps can work OK without any proper cert in my Omnia II. Long time ago I was updating my Omnia II device policy, allowing it to open anything (it can run any program that's normally signed with some certs but unsigned. and it can run almost every signed program without needing to have a proper cert installed).

The name of the program is: Security Configuration Manager

The configuration preset for my device is: Security Off

The program also capable of signing any file with any certs...

Edited by CrescendoFire
0

Share this post


Link to post
Share on other sites

Posted

Try this file, I already unsign it and re-sign it with SDKCerts that you mentioned before in the Korean ROM development... Hope it'll work.... ^^

Twitter.exe

0

Share this post


Link to post
Share on other sites

Posted

exactly, like the old one....

Connection error? Is it failed to login like the old v1.2 that around?

----------------------

For error when running:

I think I managed to cornered the issue, why every apps can work OK without any proper cert in my Omnia II. Long time ago I was updating my Omnia II device policy, allowing it to open anything (it can run any program that's normally signed with some certs but unsigned. and it can run almost every signed program without needing to have a proper cert installed).

The name of the program is: Security Configuration Manager

The configuration preset for my device is: Security Off

The program also capable of signing any file with any certs...

0

Share this post


Link to post
Share on other sites

Posted

nop.... "not signed" problem.....

thanks for your effort!!!!,

Try this file, I already unsign it and re-sign it with SDKCerts that you mentioned before in the Korean ROM development... Hope it'll work.... ^^
0

Share this post


Link to post
Share on other sites

Posted

Try this file, I already unsign it and re-sign it with SDKCerts that you mentioned before in the Korean ROM development... Hope it'll work.... ^^

I tried it before, it is not working, rapid81 said me that we have to remove the original certificate an resign it. but I don't know how to remove the original signature.

You need to remove the certificate, do whatever you want, then sign the file again. You can found the signer here in the forum, with the SDKCerts 2010. The remover is easy with google.

or maybe we have to use .mui files?

0

Share this post


Link to post
Share on other sites

Posted (edited)

mmm... I'm going to sleep

original unsigned twitter.exe success

now we can modify it, and run it with no problems. I think the solution is to unsign it before modify.

maybe now it can run on other devices, or maybe not XD

we can sign it again with sdk certificates

CrescendoFire I'll send you the original exe unsigned, please translate it, so we can try it again.

Edited by eXPerience
0

Share this post


Link to post
Share on other sites

Posted (edited)

OK guys... Done it!

-Thx. to CrescendoFire for his original translation, I used it to translate the Korean strings (I have no idea of Korean)

And here it is, based on the korean .exe file (extracted from the original .cab, posted by CrescendoFire), unsigned before modify it, translated using strings of the CrescendoFire translation, and here is the result:

Twitter.exe

Enjoy it! maybe I'll made a .cab but latter, or another day... who knows.

ok, non translated -> fonts sizes and autoupdate..., I don't find it on the exe to translate.... :-(

EDit: I used reshacker to translate it, is there any better software to do it? becose the translated twitter.exe is so unstable...

Edited by eXPerience
0

Share this post


Link to post
Share on other sites

Posted

OK guys... Done it!

-Thx. to CrescendoFire for his original translation, I used it to translate the Korean strings (I have no idea of Korean)

And here it is, based on the korean .exe file (extracted from the original .cab, posted by CrescendoFire), unsigned before modify it, translated using strings of the CrescendoFire translation, and here is the result:

Twitter.exe

Enjoy it! maybe I'll made a .cab but latter, or another day... who knows.

ok, non translated -> fonts sizes and autoupdate..., I don't find it on the exe to translate.... :-(

EDit: I used reshacker to translate it, is there any better software to do it? becose the translated twitter.exe is so unstable...

YEAH!!! Sorry for awaiting my reply... Just back from my girl's home... Don't have any internet connection there, it's countryside... ^^

Hmmm.... Maybe it'll work with TouchPlayer.... I used Unsigner.exe from XDA-Devs to unsign the apps before translating, is that the program that you use?

No need the cab file, it basically only the exe that should be copied to Windows folder... The setup.xml in cab file says that...

And about the font and autoupdate thing, maybe it need the hex editor to edit that, its not visible in the strings.

And You can try to use XN Resource Editor to edit the 'other language' apps... Since ResHacker can't read the font. But, use XN Res Editor for READING THE STRING ONLY. And apply it using ResHacker. Its more reliable than XN beside font issue...

And can you describe the unstable thing? What's the problem and steps to reproduce, maybe I can help... Because it run fine on my Omnia2, I left it running overnight without any problem at all... ^^

0

Share this post


Link to post
Share on other sites

Posted (edited)

YEAH!!! Sorry for awaiting my reply... Just back from my girl's home... Don't have any internet connection there, it's countryside... ^^

Hmmm.... Maybe it'll work with TouchPlayer.... I used Unsigner.exe from XDA-Devs to unsign the apps before translating, is that the program that you use?

No need the cab file, it basically only the exe that should be copied to Windows folder... The setup.xml in cab file says that...

And about the font and autoupdate thing, maybe it need the hex editor to edit that, its not visible in the strings.

And You can try to use XN Resource Editor to edit the 'other language' apps... Since ResHacker can't read the font. But, use XN Res Editor for READING THE STRING ONLY. And apply it using ResHacker. Its more reliable than XN beside font issue...

And can you describe the unstable thing? What's the problem and steps to reproduce, maybe I can help... Because it run fine on my Omnia2, I left it running overnight without any problem at all... ^^

the unstable problem is when I'm using it for a few minutes 2 min o3 at max, the application exits without showing any message.. I don't know what happens :-(

it happens to me with the original signed app... maybe is because I'm using it in other folder

HAPPY TO SE YOU HERE AGAIN XD

Edited by eXPerience
0

Share this post


Link to post
Share on other sites

Posted

i am not lucky.....

i still have "The username, email or password do not match", message, i tried with 2 different accounts, i am typing right.....

OK guys... Done it!

-Thx. to CrescendoFire for his original translation, I used it to translate the Korean strings (I have no idea of Korean)

And here it is, based on the korean .exe file (extracted from the original .cab, posted by CrescendoFire), unsigned before modify it, translated using strings of the CrescendoFire translation, and here is the result:

Twitter.exe

Enjoy it! maybe I'll made a .cab but latter, or another day... who knows.

ok, non translated -> fonts sizes and autoupdate..., I don't find it on the exe to translate.... :-(

EDit: I used reshacker to translate it, is there any better software to do it? becose the translated twitter.exe is so unstable...

0

Share this post


Link to post
Share on other sites

Posted

it is case sensitive.

0

Share this post


Link to post
Share on other sites

Posted

the unstable problem is when I'm using it for a few minutes 2 min o3 at max, the application exits without showing any message.. I don't know what happens :-(

it happens to me with the original signed app... maybe is because I'm using it in other folder

HAPPY TO SE YOU HERE AGAIN XD

Yes, it also happened to me when I tried to move it to my storage and run it from there.... And when I did that, I think it break some registry settings. Its become unstable even though I re-move it back to Windows folder... I'll restore my device now and see if it'll be OK...

0

Share this post


Link to post
Share on other sites

Posted

I just found out that the unsigned Twitter.exe actually can run perfectly on my O2.... But hasn't check for stability yet...

0

Share this post


Link to post
Share on other sites

Posted

yes, i know, i am sure that i am typing ok letter by letter

it is case sensitive.
0

Share this post


Link to post
Share on other sites

Posted

yes, i know, i am sure that i am typing ok letter by letter

mmm. I don't know what is causing the poblem, sorry...

0

Share this post


Link to post
Share on other sites

Posted

I'm gonna re-flash my O2 with JG5...and gonna try this Twitter again...

It never happened before with old JC ROM (the network problem, I encountered once last night. the 2 minutes auto-exit problem, it's haunting me now.)

0

Share this post


Link to post
Share on other sites

Posted

registry data found here:

[HKEY_CURRENT_USER\Software\Samsung\Twitter]

0

Share this post


Link to post
Share on other sites

Posted (edited)

Anyone here experiencing auto-exit issue?

---------------------------

Thanks eXPerience... But the registry is nothing to do with the auto-exit-problem.... I've tried to delete it but it still like that...

Yesterday I managed to open it for 15 minutes before it auto-exit...

Edited by CrescendoFire
0

Share this post


Link to post
Share on other sites

Posted

yes, i know, i am sure that i am typing ok letter by letter

I know this problem when I HRed my phone and tried to run it from my fresh O2... It simply can't login.. Maybe it got something to do with OAuth again (Twitter side problem maybe?)

But when I restored my backup, it simply can run again but with auto-exit per 1 minutes....

Currently using JH1 but still experiencing that issue.... Anyone using the older ROM or else than stock ROM please advise if this program can run OK in your device... Thanks....

0

Share this post


Link to post
Share on other sites

Posted (edited)

CONFIRMED!!! Twitter OAuth changed again. Echofon also throw an error saying that Twitter has changed their authorization system.

SCREENSHOT ATTACHED!!

Untitled_1.bmp

Edited by CrescendoFire
0

Share this post


Link to post
Share on other sites

Posted

damm it, so we have to wait to the next version...

0

Share this post


Link to post
Share on other sites

Posted

it only work OK around 2 weeks for me then this damn twitter broke the Auth system again... Why twitter love to change their auth system every now and then?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.