Jump to content
Sign in to follow this  

Root With Locked Bootloader (update #2)

Recommended Posts

Some NA providers not only locked out the possibility of unlocking the boot loader the prevent you from accessing it as well.


Holding down the search button while plugging in usb process has been disabled.

I know fo a fact that Rogers Canada has done so.

Over at xda they have devloped GingerBreak Which Has worked in my case and should work for you as well!


(this is still a work in progress)


The GingerBreak APK is a wrapper around the newly released GingerBreak exploit (credits to The Android Exploid Crew), which is meant to attain root access on GingerBread. This specific exploit may work on various Froyo and Honeycomb versions as well.

What the APK and exploit do is as follows:

- The APK puts the right files in the right place to run the exploit

- The APK runs the exploit

- The exploit attempts to attain root access

- If it succeeds, the exploit remounts /system as read-write and runs the installer script

- The installer script attempts to install the su binary and superuser APK, and reboots

Some important things to know:

- You must have USB debugging enabled on your device

- You need to have an SD card (formatted and) inserted - if it doesn't work, try formatting the SD card in your computer, or switching it with a different (or old, etc) SD card

- The APK must be installed to device, NOT SD card

- The exploit may take a while to run, but not more than 10 minutes, if it does, get me a logcat, and reboot the device. In rare occasions, even if the device does not reboot, you may still have root. So check that out after you manually pull battery after 15 minutes or so of being stuck.

- Always reboot between root attempts!

- While (temporary?) root access may be attained, due to locked bootloaders, efuses, S-ON, and whatnot this may still not work on your device. For temproot purposes, use the raw binary exploit (linked below), not this APK.

- The GingerBreak exploit should not be used to attain temproot and continue using the device. It fscks vold, you do not want to be running like that. You want to reboot! So if the root doesn't stick, you (still) have a problem.


- Optional: Press the Thanks button below this post

- Make sure USB debugging is enabled

- Make sure you have an SD card (formatted and) inserted

- Get the APK on the phone somehow, and install it

- Open the APK, press the root button

- Wait a few minutes. If there are no problems, the device will reboot (note that the reboot itself can take like 10 minutes due to cache wipe)

- Make sure the Superuser app is install and working

- Optional: Install BusyBox from Market (I personally prefer the stericsson installer)

- Optional: Uninstall GingerBreak, you don't need it on your phone anymore

- Optional: Make a donation

WARNING: Apparently on some devices the root exploit causes the SD card (internal or external) to be formatted. Also, if it gets stuck but you do see the card mounting/unmounting, try formatting your SD card yourself and try again (or use a different SD card) - often this works (a fix for both issues is being looked at)


WORKS ON A RARE SGS2, BUT NOT ON MOST (seems to be only pre-release devices that are rootable this way)

ACER A500 / ICONIA Look here (click). Will eventually be integrated, I guess


Please report back if it does or doesn't work on specific devices. If it doesn't, don't forget to post your logcat as attachment, and mention your device details and GingerBreak version.


- I made the APK and did some slight modding to the exploit code to install from an APK

- The exploit ("GingerBreak") itself is made by The Android Exploid Crew. Original code can be found here: http://c-skills.blogspot.com/2011/04...ngerbreak.html

Manual rooting

From v1.1 it is no longer possible to manually root the device over an ADB connection using the files from this APK. Please use the original binaries from the c-skills website to do this. There are several guides posted here on XDA about how to do this manually, some are mentioned/linked-to in the first few pages of this thread.


GingerBreak is not specific to any device, but there is code in there that may not work on device X or Y. The exploit is generic, but that does not mean one size fits all, nor does it mean that there will be no firmwares out there that fix this exploit. A special version may need to be compiled for your device, ask your favorite hacker from your specific device's forum. This APK is meant to make the process easier, but also adds dependancies so that it may not work on your device.



26.04.2011: v1.2

- Removed some code that may break operation while the code itself isn't needed

- Added UnRoot option

- The APK now logs exploit output semi-live

22.04.2011: v1.1

- Modded exploit code to not need /data/local/tmp - this should fix the problem extracting assets as well as be more compatible with various devices (in theory). In case the APK notices that this cannot work, it will warn you about this.

- Added some warnings and errors to the APK

21.04.2011: v1.0

- First release of APK

- Slight mods to the exploit source to have it work better from APK


Please support the developers and Donate! donation links are on the original thread as well as the download link

Update: some apps disappear from the app drawer. Backup user apps with titanium and restore them and they re appear. Not sure if its temporary, will update tomorrow.

The Fix Using Titanium IS temporary! I tried a wipe, system stayed rooted and app disappear from drawer, but also prevent from started st startup. Ive had issues with the touchscreen not working. Controller did not startup with phone. USE AT DISCRETION. It does work, but patience needed to work with the bugs. Im going to try to "un-root" using the same app and see if bugs go with it.

Never un-rooted as it seems after enough reboots (and backup restores via titanium) It resolves itself (probably a cache bug)

Edited by simplyRobbie

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this