• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

Is your bootloader unlocked?

6 posts in this topic

Posted · Report post

If you have recently acquired a Nokia Lumia device, you may be surprised to find out that Nokia has not locked down the bootloader, giving full NAND read/write access!

To check:

  • Turn off your phone
  • Hold down Volume Up and Power
  • Connect your phone to your computer with the USB cable, you will hear a short vibration
  • Keep holding those buttons

Check your computer and see what device is detected. You can find this in Devices and Printers on Windows, in the Device Manager, or just check what device it is trying to install drivers for. If you're on Linux, run lsusb.

On Windows:

if you see NOKIA DLOAD, you have a locked bootloader.

but if you see Qualcomm MMC Storage USB Device you have an unlocked bootloader!

On Linux, using lsusb:

if you get Qualcomm, Inc your bootloader is unlocked.

usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
scsi 2:0:0:0: Direct-Access Qualcomm MMC Storage 2.31 PQ: 0 ANSI: 2
sd 2:0:0:0: Attached scsi generic sg2 type 0
sd 2:0:0:0: [sdb] 31047680 512-byte logical blocks: (15.8 GB/14.8 GiB)
sd 2:0:0:0: [sdb] Write Protect is off
sd 2:0:0:0: [sdb] Mode Sense: 0f 0e 00 00
sd 2:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
sdb: sdb1 sdb2 sdb3 sdb4 < sdb5 sdb6 sdb7 sdb8 sdb9 >
sdb: p9 size 30632075 extends beyond EOD, enabling native capacity[/code]

0

Share this post


Link to post
Share on other sites

Posted · Report post

I have a slightly different message, "Qualcomm CDMA Technologies MSM" on my Lumia 800

And while doing this managed to start the lets pretend to be a bricked device again syndrome. Now to wait until it will let me reboot again.

0

Share this post


Link to post
Share on other sites

Posted · Report post

Sorry to hear that, so no mention of NOKIA DLOAD anywhere?

0

Share this post


Link to post
Share on other sites

Posted · Report post

Not that I noticed, this was tested on W8 so may be slightly different to a W7?

0

Share this post


Link to post
Share on other sites

Posted · Report post

I think it is something different for the lumia 800. I tried loads of times without sucess. Then I held both volume buttons and got it on the second try. By definition though if you can update with Zune you have Nokia Dload

Sent from my Lumia 800 using Board Express

0

Share this post


Link to post
Share on other sites

Posted · Report post

I used to be able to get into osbl mode (vol-up + power) but for some reason not anymore.. althou by using a program called NSS Pro , I can get there. The good thing is that my lumia shows as Qualcomm CDMA Technologies MSM , as it should , but it does not map any drives... exactly the same on linux side : It's idenftified (lsusb) as Qualcomm Inc. but still no drives :/

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.