Kra1o5

[RECOVERY][ALL] Official TWRP 2.7.1.0 & Root [01/08/2014]

464 posts in this topic

there's really no difference in this latest builds.as long as you can flash roms without errors there's no big deal

0

Share this post


Link to post
Share on other sites

TWRP for the Y300 is kind of buggy and it has been for a while. It seems like nobody has made any attempt to fix the issues either.

  • All apps moved to the SD card become unlinked when restoring a backup
  • If you change any of the settings within TWRP then it'll lose the settings eventually
  • Wipe the internal storage and you get the error "unknown mtp message type: 1"

There's more errors too. Half of these issues aren't there in older TWRP versions such as 2.7.0.2 though.

Edited by H3ROS
0

Share this post


Link to post
Share on other sites

TWRP for the Y300 is kind of buggy and it has been for a while. It seems like nobody has made any attempt to fix the issues either.

  • All apps moved to the SD card become unlinked when restoring a backup
  • If you change any of the settings within TWRP then it'll lose the settings eventually
  • Wipe the internal storage and you get the error "unknown mtp message type: 1"
There's more errors too. Half of these issues aren't there in older TWRP versions such as 2.7.0.2 though.
The 3rd error is only a warning

Dees_Troy moved some of them to log ( after I asked him like 3 times to hide them hahah . S/He was olways offline / afk ) ;)

The 2nd one happen when you wipe internal storage and maybe data

Twrp stores settings in internal storage in devices with sdcard ;)

The other one I really don't know never used link2sd or something

Edited by luca020400
0

Share this post


Link to post
Share on other sites

In 2.7.0.2 if you wipe the SD card or all internal memory the settings will stick. So the new version must format and then either fail or not even attempt to then write back the current settings.

As for app moving I mean via the built in move to SD card function. It fails to restore things to exactly how they were even with a "full" backup. Once you do a restore you'll be missing any large games or any app you've moved.

0

Share this post


Link to post
Share on other sites

2.6.3.3 has never given me any issues. Later versions do not support second SD partition so I don't want to update anyway.

1

Share this post


Link to post
Share on other sites

2.6.3.3 has never given me any issues. Later versions do not support second SD partition so I don't want to update anyway.

 

I'll try that out shortly. At the moment I've gone to ClockworkMod as that works perfectly. I prefer to use TWRP though simply for the touch screen support.

 

There's one confusing thing about CWM and that's that the memory names are different.

 

sdcard0 = Internal memory

sdcard1 = SD card

 

When booted to Android though though sdcard0 is the SD card and sdcard1 is the internal memory.

Edited by H3ROS
0

Share this post


Link to post
Share on other sites

I'll try that out shortly. At the moment I've gone to ClockworkMod as that works perfectly. I prefer to use TWRP though simply for the touch screen support.

 

There's one confusing thing about CWM and that's that the memory names are different.

 

sdcard0 = Internal memory

sdcard1 = SD card

 

When booted to Android though though sdcard0 is the SD card and sdcard1 is the internal memory.

 

I think it's not wrong, on stock when you set external SD as default it swaps to sdcard0, but normally it should be sdcard1 and internal memory sdcard0

0

Share this post


Link to post
Share on other sites

Yeah, it's just a little confusing at first sight. I almost formatted the wrong thing which would of been really bad.

 

Edit: I tried TWRP 2.6.3.3 and can confirm that it fully works. It's much better than newer versions.

Edited by H3ROS
0

Share this post


Link to post
Share on other sites

Yeah, it's just a little confusing at first sight. I almost formatted the wrong thing which would of been really bad.

Edit: I tried TWRP 2.6.3.3 and can confirm that it fully works. It's much better than newer versions.

I have never moved on from 2.6.3.3, it's the last build that will back up /sd-ext. And I think a number if other options were slowly dropped after that build too.

On a side note, I see Chil360 has preliminary support for f2fs added to his LP kernel, has there been a recovery built to support that?

Edited by wbrambley
0

Share this post


Link to post
Share on other sites

Hi,can someone post the flashable zip of twrp 2.6.3.3 please?

0

Share this post


Link to post
Share on other sites

Hi,can someone post the flashable zip of twrp 2.6.3.3 please?

G510 or Y300?
0

Share this post


Link to post
Share on other sites

I have never moved on from 2.6.3.3, it's the last build that will back up /sd-ext. And I think a number if other options were slowly dropped after that build too.

On a side note, I see Chil360 has preliminary support for f2fs added to his LP kernel, has there been a recovery built to support that?

Luca tried to compile TWRP with F2FS support, but failed.
0

Share this post


Link to post
Share on other sites

Hi,can someone post the flashable zip of twrp 2.6.3.3 please?

G510 or Y300?

Excuse me.. Y300..:-)

0

Share this post


Link to post
Share on other sites

I have the 2.8.0.0

 

why you used the oldest versions? I see that the most used is the 2.7.0.1 but why?

0

Share this post


Link to post
Share on other sites

I have the 2.8.0.0

 

why you used the oldest versions? I see that the most used is the 2.7.0.1 but why?

 

We "lost" the official support once Kra1o5 left the development of this device, latest 100% working build was 2.6.3.3, after that, Kra1o5 removed the "sd-ext" feature due to black screens (there are some on 2.7.1.0 too, even without the sd-ext support) and then peoples that make use of link2sd sticked to 2.6.3.3, also, the more you update the recovery, more bugs you will encounter, our TWRP device tree is outdated and future builds will probably get more bugs, i personally use 2.7.1.0 just because the wipe process is faster, but i suggest you to use 2.6.3.3.

Edited by fonz93
0

Share this post


Link to post
Share on other sites

We "lost" the official support once Kra1o5 left the development of this device, latest 100% working build was 2.6.3.3, after that, Kra1o5 removed the "sd-ext" feature due to black screens (there are some on 2.7.1.0 too, even without the sd-ext support) and then peoples that make use of link2sd sticked to 2.6.3.3, also, the more you update the recovery, more bugs you will encounter, our TWRP device tree is outdated and future builds will probably get more bugs, i personally use 2.7.1.0 just because the wipe process is faster, but i suggest you to use 2.6.3.3.

Do you recommend using twrp over latest cwm for flashing roms?

 

melo puoi scrivere in italiano?

 

Lorenzo

And,

Can you stop spamming the forums please? Ty.

0

Share this post


Link to post
Share on other sites

Do you recommend using twrp over latest cwm for flashing roms?

 

I don't use CWM because:

 

- no /cust partition backup (this one can probably be added "easily")

- Is not touch, (this is just my opinion, i don't like using volume and power buttons, it takes ages doing something in recovery)

- Troubles with assert lines, users reported errors while flashing some ROMs (status 7 or something like that)

- Weird yellow LED on while using the recovery (device specific bug)

 

If you don't care about them, you can use CWM, if bugfree, it's better than TWRP (cleanest code)

Edited by fonz93
0

Share this post


Link to post
Share on other sites

I don't use CWM because:

 

- no /cust partition backup (this one can probably be added "easily")

- Is not touch, (this is just my opinion, i don't like using volume and power buttons, it takes ages doing something in recovery)

- Troubles with assert lines, users reported errors while flashing some ROMs (status 7 or something like that)

- Weird yellow LED on while using the recovery (device specific bug)

 

If you don't care about them, you can use CWM, if bugfree, it's better than TWRP (cleanest code)

Yea i've had that status 7 problem with some roms (i just deleted the assert lines from the updater-script lol)

Anyway i have another question about my phone, i have the g510-0251 but i flashed a stock rom for the .-0200 so i obviously lost 3g, some days ago i found the exact stock rom for my phone and carrier, but it fails at step 2 (installing), anyway i found a flashable baseband for my region but nothing happens after flashing it (tried with euro baseband and still the same), is there something i can do to recover 3g on my phone?

0

Share this post


Link to post
Share on other sites

Deleted. (I have reason)

Edited by Jairus1998
2

Share this post


Link to post
Share on other sites

For u8951 or u8833?

For u8951 or u8833?

Sorry I forgot to metion that this is for U8833. I haven't do for U8951. I will do that soon

1

Share this post


Link to post
Share on other sites

thanks looks dope.tho it didn't change the splash screen

I might have uploaded the wrong file. I will fix that soon.

1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2016. MoDaCo uses IntelliTxt technology.