Jump to content
Spacecaker

[ROM][4.1.2]PAC-Rom V19.3.0[1-9-13][Acer S500 Cloudmobile][swing][RC3][Updated]

Recommended Posts

weird

have u tried this

wipe data

wipe cache

wipe dalvik cache

?

or after boot

return to recovery

goto mounts and storage and mount sdcard and reboot ?

or tried to follow this ?

http://forum.xda-developers.com/showthread.php?t=1615418

or go to Developer options in settings and find "protect external SD" set it to on

or try to type this in terminal emulator

Su

mount -o bind /mnt/emmc /sdcard/external_sd

or this in terminal emulator

Su

mount -o bind /mnt/sdcard /external_sd/external_sd

mount -o bind /mnt/external_sd /sdcard

mount -o bind /mnt/external_sd/external_sd /external_sd

I will try it later today as now I have access to wifi

PS. The S-off fix for xternal SD can't be done for me because I only have one SD 16gb almost full with lots of documents. Can't format it atm.

Edited by scarba

Share this post


Link to post
Share on other sites

Tried V2 version and SD card still doesn't seem to work.

i am trying to fix it but it takes so much time to compile on my pc

currently i need to compile full kernelcto get sd to work properly :/,

  • Upvote 1

Share this post


Link to post
Share on other sites

i am trying to fix it but it takes so much time to compile on my pc

currently i need to compile full kernelcto get sd to work properly :/,

I know teh feeling mate I did it too once for a SGS+ like a year ago but I quited this hobby because I have no free time ;)

Share this post


Link to post
Share on other sites

I know teh feeling mate I did it too once for a SGS+ like a year ago but I quited this hobby because I have no free time ;)

but your pc builded it in propably less then 4 hours

mine takes 9/14 hours :(

Share this post


Link to post
Share on other sites

hmm weird :/

In the /mnt directory I only see:

asec

obb

secure

so I guess only theese are mounted

in teh storage directory I see

sdcard0

sdcard1 <- this should be the external SD but it shows empty when I access it

I guess there is a conflict with the mounting points from stock JB kernel (this mounts them in /storage/sdcard0,sdcard1) and the CM kernel wich mounts them (if I remember correct - to /mnt/sdcard,external_sd)

pretty darn hard because I can`t really provide a logcat yet...I try again and post it here if I can ;)

PS logcat here http://db.tt/zQt8iz3M and here http://db.tt/mCmb8ADN

Edited by scarba
  • Upvote 1

Share this post


Link to post
Share on other sites

good one I know it but:

"...This app will not work on devices with Jelly Bean (Android 4.1+) because of changes to Android security." ;)

use alogcat app

https://play.google.com/store/apps/details?id=org.jtb.alogcat&feature=search_result#?t=W251bGwsMSwxLDEsIm9yZy5qdGIuYWxvZ2NhdCJd

Edited by Spacecaker

Share this post


Link to post
Share on other sites

can u try GPS ?

i have used new configs for those so it might work ?

Unfortunately today I sold my S500 and I can`t help you guys anymore with testing ... Wish you all the best in the future of development!

Share this post


Link to post
Share on other sites

if someone can try this version of the rom ;)

i compiled it with cleaned sources

and compiled custom kernel with the rom aswell this time

my pc took 4 days to fully compile it :/

so i hope sd card is fixed

i did noticed that the files size was from 150 mb increased to 192 mb

as CM10 also has this sae size i think its ok now

Dl link here

http://www.mediafire.com/download/bog76zgwyql7l5f/PAC_swing_spacecaker_14-7-13.zip

please try and report :D

Edited by Spacecaker
  • Upvote 1

Share this post


Link to post
Share on other sites

Did not boot for me. Stuck at boot logo. Seems to be a kernel issue.

Edited by vache

Share this post


Link to post
Share on other sites

hmm weird :/ i just dont understand if i compile pac it compiles it but then at the end it uses the prebuilt kernel instead of the new compiled kernel

so i used the tools that where share here on modaco to compile new boot.img

with the zimage of arch/arm/boot/Zimage

:/

and if u try to flash cm10 kernel it boots or not ?

Share this post


Link to post
Share on other sites

Yes it boots with another kernel. You may check if it uses the right defconfig when building kernel.

  • Upvote 1

Share this post


Link to post
Share on other sites

Yes it boots with another kernel. You may check if it uses the right defconfig when building kernel.

i used

acer_a9_cm_defconfig

and the kernel source of github.com/vachounette

does sd card work now finally? :P

thank u

Edited by Spacecaker

Share this post


Link to post
Share on other sites

try to flash the kernel with this cwm zip

i have repacked and recompiled + moddified the kernel now again

so i think this one works now

http://www.mediafire.com/?fu8lgrobv4qoach

just do install zip from sdcard and its flashed after u flashed the rom offcourse

also here is my boot.img

for manually flashing with cmd or terminal

http://www.mediafire.com/?52sax66on6cv5o1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×