Jump to content

[ROM][4.1.2]PAC-Rom V19.3.0[1-9-13][Acer S500 Cloudmobile][swing][RC3][Updated]

Guest Spacecaker

Recommended Posts

Guest Spacecaker


P A C man ALL IN 1

The struggle to find the rom you need is over. Some people like CyanogenMod 10, Some prefer AOKP, Some like the advantages of Paranoid Android

To cure your rom hunt we have come up with the P A C man Rom.

PACman is a unique rom.

We have picked the best features from CM10, Aokp and PA and combined them in a single rom so you get the experience you deserve

To enjoy the features of every available project without the hassle of flashing regularly.

The Rom is rock stable for an average user but keep in mind the Rom is in WIP stage so expect some minor hickups but we are trying our best to resolve these issues



* Your warranty is now void.


* I am not responsible for bricked devices, dead SD cards,

* thermonuclear war, or you getting fired because the alarm app failed. Please

* do some research if you have any concerns about features included in this ROM

* before flashing it! YOU are choosing to make these modifications, and if

* you point the finger at me for messing up your device, I will laugh at you.



Source built for the Acer S500 Cloudmobile (swing)


AOKP Milestone 1

Paranoid Android 2.55


People at Modaco


If I somehow missed you, first off, I apologize. Please PM me so I can remedy my oversight.

Sources uses:

Edited by Spacecaker
Link to comment
Share on other sites

Guest Spacecaker


RC3 V6

Enable KSM .

Enable Ramdumptags.

Enable ammsLastlog.

add conservative governor .

set ondemand as default governor .

enable netfilter xt target hl.

enable netfilter xt mach esp.

enable IP6 .

enable SCSII .

Set VBUS Draw to 2.

enable magic sysrq.

disable Bugverbose Debug.

moddified ramdisk.

custom bootlogo

Moddified settings to display kernel version properly.

RC2 V5

Fix PA Settings

Fix permission


RC1 V4

SDCard Fixed

HeadPhones Working + fixed

Everything working :D

Finally a working version

V3 Third Release * unknown date *

Fixed Kernel during compile

Updated Kernel * boot.img *

Hopefully now sdcard fixed

Updated Libs + vold

Resetted Device Configs started all over again

Make Cleaned

fix some part in configs

V2 Second Release * 05-07-13 *

Fix External SDCard *FAIL*

Fix SdCard *FAIL*

Fix USB Connection *FAIL*

Fix Storage_lists

Possible fix for gps

Compile time was 448 minutes =_=

V1 initial Release

based upon latest PAC sources

Fixed Powertop isseus

Fixed Kernel not compiling error

Initial modifications of Swing sources especially for PAC

fixed small bootanimation

Compile time was 648 minutes =_= roughly 11 hours

How To Install? :

Put ROM & GApps on your external SD

Reboot to recovery

Format data/factory reset

Flash ROM


Flash GApps


Edited by Spacecaker
Link to comment
Share on other sites

Guest Spacecaker

i use a HP Pavilion G7 laptop

with VMware manager

and Linux 64 bit

compile always take long time

CM7 CM9 CM10 aokp etc

i tried them all

also it doesnt matter wich device i try to compile always takes this long time after make clean

Samsung Galaxy Ace/Gio Xperia Play/U Acer S500 etc

OS: Linux 3.5.0-17-generic x86_64 ** Distro: LinuxMint "nadia" 14 ** CPU: 2 x AMD A6-4400M APU with Radeon HD Graphics (AuthetiicAMD) @ 2.69GHz ** RAM: Physical: 4.0GB, 91.3% free ** Disk: Total: 94.3GB, 32.7% free ** VGA: VMware SVGA II Adapter ** Sound: Not present ** Ethernet: Intel Corporation 82545EM Gigabit Ethernet Controller *

Edited by Spacecaker
Link to comment
Share on other sites

Guest Spacecaker

Found a bug : doesn't read external SD :)

ahh :/ hmm will try to fix it asap ;)

if possible could you post some screenshoots :D

thank u

Link to comment
Share on other sites

Guest Namuhk2k

It says that com.android.process.media has stopped working..when connecting usb to pc ..

Same here! Also my navigation buttons have disappeared for some reason (they still work though)...

Also, my signal bars are always full? Witch is impossible since I have the suckiest signal in my apartment!

Aaaand going to settings from notification bar is a no go, it worked at first...

EDIT: Navigation buttons are back after a restart. I've attached log.txt


Edited by Namuhk2k
Link to comment
Share on other sites

Guest Ivan69

In order to see how it looks, could you post some screenshots, like home, settings and so on?

Edited by Ivan69
Link to comment
Share on other sites

Guest Spacecaker

i compiled it from PAC-Rom sources


about navbar

it gets resets if u touch any options or what like phablet or tablet etc

always reboot to get all settings to work proper

thats my advice

Link to comment
Share on other sites

Guest Spacecaker

07-04 16:08:52.304 W/MountService(618): getVolumeState(/storage/sdcard1): Unknown volume

07-04 16:08:52.314 E/AndroidRuntime(2780): FATAL EXCEPTION: main

07-04 16:08:52.314 E/AndroidRuntime(2780): java.lang.RuntimeException: Unable to create service com.android.providers.media.MtpService: java.lang.IllegalArgumentException

07-04 16:08:52.314 E/AndroidRuntime(2780): at android.app.ActivityThread.handleCreateService(ActivityThread.java:2504)

07-04 16:08:52.314 E/AndroidRuntime(2780): at android.app.ActivityThread.access$1600(ActivityThread.java:145)

07-04 16:08:52.314 E/AndroidRuntime(2780): at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1293)

07-04 16:08:52.314 E/AndroidRuntime(2780): at android.os.Handler.dispatchMessage(Handler.java:99)

07-04 16:08:52.314 E/AndroidRuntime(2780): at android.os.Looper.loop(Looper.java:137)

07-04 16:08:52.314 E/AndroidRuntime(2780): at android.app.ActivityThread.main(ActivityThread.java:4978)

07-04 16:08:52.314 E/AndroidRuntime(2780): at java.lang.reflect.Method.invokeNative(Native Method)

07-04 16:08:52.314 E/AndroidRuntime(2780): at java.lang.reflect.Method.invoke(Method.java:511)

07-04 16:08:52.314 E/AndroidRuntime(2780): at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:791)

07-04 16:08:52.314 E/AndroidRuntime(2780): at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:558)

07-04 16:08:52.314 E/AndroidRuntime(2780): at dalvik.system.NativeStart.main(Native Method)

07-04 16:08:52.314 E/AndroidRuntime(2780): Caused by: java.lang.IllegalArgumentException

07-04 16:08:52.314 E/AndroidRuntime(2780): at android.os.Parcel.readException(Parcel.java:1429)

07-04 16:08:52.314 E/AndroidRuntime(2780): at android.os.Parcel.readException(Parcel.java:1379)

07-04 16:08:52.314 E/AndroidRuntime(2780): at android.os.storage.IMountService$Stub$Proxy.getVolumeState(IMountService.java:241)

07-04 16:08:52.314 E/AndroidRuntime(2780): at android.os.storage.StorageManager.getVolumeState(StorageManager.java:573)

07-04 16:08:52.314 E/AndroidRuntime(2780): at com.android.providers.media.MtpService.onCreate(MtpService.java:117)

07-04 16:08:52.314 E/AndroidRuntime(2780): at android.app.ActivityThread.handleCreateService(ActivityThread.java:2494)

07-04 16:08:52.314 E/AndroidRuntime(2780): ... 10 more

this seems to be error of the usb connection and sdcard

Link to comment
Share on other sites

Guest Spacecaker

after even further investigation i found why Sdcard wasnt seen

it was storage_list.xml

currently i fixed it to this

<StorageList xmlns:android="http://schemas.android.com/apk/res/android">

<!-- removable is not set in nosdcard product -->

<storage android:mountPoint="/storage/sdcard0"





android:mtpReserve="100" />

<storage android:mountPoint="/storage/sdcard1"




android:maxFileSize="4096" />


so i hope MTP will now also work :D

will compile today ;)


Edited by Spacecaker
Link to comment
Share on other sites

Guest Spacecaker

V2 Released

Check Changelog for the changes :D

Please try and report :D

if any new bugs will come i will try to fix them asap :D

Edited by Spacecaker
Link to comment
Share on other sites

Guest Spacecaker

sdcard should be fixed

give me logcat or show screenshoot of storage

also try to take screenshoot of External_sd in root explorer

Link to comment
Share on other sites

Guest scarba

sdcard should be fixed

give me logcat or show screenshoot of storage

also try to take screenshoot of External_sd in root explorer

Flashed last nite V2 and external SD isn`t mounted and also my PC doesn`t access my phone. When I try to enter into Settings -> Storage Settings FC. Can`t provide any logcat or screenshots atm since I don`t have access to any wifi :( and as I said can`t access my phone with adb.

Link to comment
Share on other sites

Guest Spacecaker


have u tried this

wipe data

wipe cache

wipe dalvik cache


or after boot

return to recovery

goto mounts and storage and mount sdcard and reboot ?

or tried to follow this ?


or go to Developer options in settings and find "protect external SD" set it to on

or try to type this in terminal emulator


mount -o bind /mnt/emmc /sdcard/external_sd

or this in terminal emulator


mount -o bind /mnt/sdcard /external_sd/external_sd

mount -o bind /mnt/external_sd /sdcard

mount -o bind /mnt/external_sd/external_sd /external_sd

Edited by Spacecaker
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.