• Announcements

    • Reminder - MoDaCo position on illegal content   07/30/15

      ILLEGAL CONTENT I'd like to just reaffirm MoDaCo's position regarding piracy and illegal content in the light of some recent questions / postings. Posts will be censored by myself or my moderation team if the contain or link to: Illegal / pirated / cracked software or sites that host such softwareNintendo emulators / ROMs or sites hosting them (in light of Nintendo's legal stance)CUSTOM ROMS You may discuss and post links to custom device ROMs on MoDaCo, provided the following rules are adhered to: ROMs must not contain any illegal 3rd party software (this includes trial versions included without permission)ROMs must give full credit to the original authorISSUES If you have any issues with this policy, please contact PaulOBrien directly via PM.
    • Reminder: Selling items on the forum directly is not allowed   07/30/15

      Please note that selling items on the forum directly is not allowed by the forum rules. There is a forum for eBay auctions whereby you can list the items on eBay and link to them there. This is the ONLY forum for this type of activity. You may also advertise links to the eBay forum in your signature. Please note that selling directly in contravention of these rules will result in a warning / suspension / ban.
Sign in to follow this  
Followers 0

Is my phone totally bricked or is there a hope? PLZ Help Me!!!

2 posts in this topic


The phone do not go into any mode except SD download mode which shows error.

I tried to install new ROM through Acer LMT tool. The process went smooth and showed success in the program but my phone don't wake up from the sleep... :( I tried fastboot but it show waitng for device and don't go any further than that. Only thing positive is my PC recognize that the phone is connected.

Please help me out..... I know the phone is low on RAM and memory and all. But I have many good memories with it. Please help



Share this post

Link to post
Share on other sites


I had a hard way. But this informations I have collected:


Q: All *.bin are down. How can I find (extract) the bin file

A: Download the build you are searching for from the acerside (its a zip-file with an exe in it) , install it.

Don't close the setup wizard
open: C:\Program Files\Acer Inc\Acer LiquidMT Tool\acer_EuuDownload_Tool\acer_MergedOSFile
that is the bin file you are looking for.


My MT120S was bricked and I have installed the only bin a could find, with was an GEN2 (for Asia), now am not able to flash a other bin, because it doesn´t except a GEN1.bin.

USB istn´t responding (so no ADB, AcerDownloadTool and no updateingtool is working) I only can use SD Card-mode.

In SD Card Mode the S120

-checks the language (Gen1 or Gen2) so if you have already installed one of them>no chance

-If you use a downgrade (4.001 installed, back to eg. 3.00x) you get an invalid file massage

-If you use an upgrade (4.001 installed, up to 4.013) you get: "wrong MD5 checksum...are you a hacker"

So. If YOU only see the "Acer"-logo and you aren´t able to boot or get into the recovery.
Go to "SD Card mode" (Vol- and Cam and Power)
Insert a SD Card and copy the !right! "...Gen1.bin" for Europe/US (or "....Gen2.bin") for Asia to
the following folder  (SdCard:\)acer_ug/acer_xx


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

MoDaCo is part of the MoDaCo.network, © Paul O'Brien 2002-2015. MoDaCo uses IntelliTxt technology.