Jump to content
KonstaT

[DEV][ROM][28.1.] CyanogenMod 12.1 (Android 5.1.1) for Chuwi Vi10 Plus, Hi10 Plus, Hi10 Pro, Hibook, Hibook Pro & Hi12

Recommended Posts

17 minutes ago, Javi1313 said:
Hello, I do not work the screen rotation on android, I have a chuwi hi12. Is there a solution for this? Thanks greetings

Have you installed the correct compatibility patch?

Share this post


Link to post
Share on other sites

 

Sorry, the state looking for the forum and I do not get the right one. I have remixOs,

Everything works perfectly, the only problem is the rotation. Thanks

Share this post


Link to post
Share on other sites
53 minutes ago, Javi1313 said:

Sorry, the state looking for the forum and I do not get the right one. I have remixOs,

Everything works perfectly, the only problem is the rotation. Thanks

???

Which Hi12 compatibility patch did you install and have you tried with the other one? What stock firmware version was your device shipped with?

Share this post


Link to post
Share on other sites

I installed remix os 2.0 (Android 5.1.1) instead of the android that came on the tablet (5.0) from the official installer of intel (Phone flash tool). The installation has gone smoothly, everything works correctly in remixes, the only problem is the rotation. Thanks for your interest

Share this post


Link to post
Share on other sites
1 hour ago, Javi1313 said:

I installed remix os 2.0 (Android 5.1.1) instead of the android that came on the tablet (5.0) from the official installer of intel (Phone flash tool). The installation has gone smoothly, everything works correctly in remixes, the only problem is the rotation. Thanks for your interest

That's none of my problem then. I only provide support for my custom ROMs and you have posted on a completely wrong place.

You've installed a ROM that is not meant for your device! If you install e.g. this Remix OS with the right compatibility patch, I'm sure everything will work. http://konstakang.com/devices/chuwi_vi10plus/RemixOS/

Edited by KonstaT

Share this post


Link to post
Share on other sites
Updated with your rom remix os and the standard patch without serial number (my model is HQ64G45170104616) and the same rotation problem continues.
 What can it be? Thanks for your time

 

Share this post


Link to post
Share on other sites
47 minutes ago, Javi1313 said:
Updated with your rom remix os and the standard patch without serial number (my model is HQ64G45170104616) and the same rotation problem continues.
 What can it be? Thanks for your time

 

3 hours ago, KonstaT said:

???

Which Hi12 compatibility patch did you install and have you tried with the other one? What stock firmware version was your device shipped with?

 

 

Share this post


Link to post
Share on other sites

Hi, I am working on a new hi10 plus. The rom date from build.prop is 201705 (LQ64G42170903xxxx).

Everything rocks but the camera :( Looking at my backup of the firmware it  is the same hardware you have a patch for (GC2355 and gc2355b). The rear camera works with Open Camera and other apps (such as the bar code reader) but the front camera does not.

I merged the patch into the stock firmware and diff against the stock image just comparing system folders basically, there are some differences in configuration files and some xml files missing. I will try copying these over and see if they help. Is there anything else I could look for ? I'm not sure what to copy and what not to copy from the original firmware (are the aiqb files in atomisp copied from the original firmware or do you generate them).
Many thanks for the work on this and very grateful for any time you spend responding.

Edited by lowearthorbit
see next post. I fixed it.

Share this post


Link to post
Share on other sites

Fixed it! - both cameras work now.
I took a punt and copied these 2 xml files on to the device (remounted /system rw first).
    /system/etc/media_profiles_gc2355b.xml
    /system/etc/media_profiles_gc2355.xml

Looking at the insmod these seemed to be likely candidates :D
This post seemed to suggest that these files might be useful to the apps, lsmod showed that 
the modules were loaded. I hadn't got as far as looking for errors in logs.

I hope this helps someone :D

If you are reading this and going how?
Connect to your adb computer (there are plenty of guides on how to get adb running).
Pick the USB debug notification out of your notifications, it should take you to delevoper options where you can enable root for adb.
remount system rw ( adb root; adb shell; mount -o remount,rw /system; exit)
either :
grab the files from the system image (download the firmware for the hi 10 plus from chuwi forums).
or : grab your backup and unpack system backup, or like me use f7 on the keyboard with a kali linux boot stick, boot Kali in forensic mode, dd the android_system partition (back the whole thing up at the same time).
then :
get system.img and open it with 7zip (on 'linux 7z x system.img' in a folder)
in system/etc grab the files listed above

push them to the rom
adb push media_profiles_gc2355b.xml /system/etc
adb push media_profiles_gc2355.xml /system/etc

kill any camera apps and voila,
reboot the device and remove root priv from adb in the developer options


 

Share this post


Link to post
Share on other sites
14 hours ago, lowearthorbit said:

Fixed it! - both cameras work now.
I took a punt and copied these 2 xml files on to the device (remounted /system rw first).
    /system/etc/media_profiles_gc2355b.xml
    /system/etc/media_profiles_gc2355.xml

Looking at the insmod these seemed to be likely candidates :D
This post seemed to suggest that these files might be useful to the apps, lsmod showed that 
the modules were loaded. I hadn't got as far as looking for errors in logs.

I hope this helps someone :D

If you are reading this and going how?
Connect to your adb computer (there are plenty of guides on how to get adb running).
Pick the USB debug notification out of your notifications, it should take you to delevoper options where you can enable root for adb.
remount system rw ( adb root; adb shell; mount -o remount,rw /system; exit)
either :
grab the files from the system image (download the firmware for the hi 10 plus from chuwi forums).
or : grab your backup and unpack system backup, or like me use f7 on the keyboard with a kali linux boot stick, boot Kali in forensic mode, dd the android_system partition (back the whole thing up at the same time).
then :
get system.img and open it with 7zip (on 'linux 7z x system.img' in a folder)
in system/etc grab the files listed above

push them to the rom
adb push media_profiles_gc2355b.xml /system/etc
adb push media_profiles_gc2355.xml /system/etc

kill any camera apps and voila,
reboot the device and remove root priv from adb in the developer options

I've added CM12.1 and Remix OS compatibility patches for Hi10 Plus devices shipped with 20170504 firmware to my site.

Those two media_profiles_*.xml configs do absolutely nothing with CM12.1 (see https://github.com/CM-CHT/android_frameworks_av/commit/ec43dabccae4fc3d5dc482fd2b95c15eff102c0e).

Well done figuring out the rest. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×