Jump to content


Photo

No ADB & No SD

- - - - -

  • Please log in to reply
104 replies to this topic

#101
Michael S

Michael S

    Newbie

  • Members
  • Pip
  • 11 posts
  • Devices:HTC Hero
Hi Mike,

I've managed to get the goldcard and patch the modified hboot.
the command - Run "fastboot oem eraseconfig" was succeed.
But still no ADB & Mass Storage.

Hmm, maybe the eraseconfig is the wrong one then? I must admit I can't remember if there was another command which I typed as well. Actually, I just run "fastboot oem ?" and found some commands, which I tried some of them (because there was nothing to loose when the phone seemed to be quite broken already). Unfortunately there is almost nothing about those fastboot commands on the net, but maybe try if there is anything related with "erase", "clear", "config", "cache", etc.
Hope that helps!

  • 0

#102
mike enjoys android

mike enjoys android

    Newbie

  • Members
  • Pip
  • 34 posts
  • Location:Zug, Switzerland
  • Devices:HTC HERO with Cyanogen Mod

Hi Mike,

Hmm, maybe the eraseconfig is the wrong one then? I must admit I can't remember if there was another command which I typed as well. Actually, I just run "fastboot oem ?" and found some commands, which I tried some of them (because there was nothing to loose when the phone seemed to be quite broken already). Unfortunately there is almost nothing about those fastboot commands on the net, but maybe try if there is anything related with "erase", "clear", "config", "cache", etc.
Hope that helps!

Yeah, i tried a few commands - but for the most i've no idea what they stand for. Attached you can find all possible commands. Maybe you see the one i need :-)

Attached Files


  • 0

#103
Michael S

Michael S

    Newbie

  • Members
  • Pip
  • 11 posts
  • Devices:HTC Hero

Yeah, i tried a few commands - but for the most i've no idea what they stand for. Attached you can find all possible commands. Maybe you see the one i need :-)

When you run "fastboot oem boot", what is the output you see then? E.g. is the sdcard still disabled? If not, make sure that you ran "fastboot oem enableqxdm 0".
So, from all these options, I would recommend to try out these (but without any warranty, so maybe google them before you try):
- fastboot oem enableqxdm
- fastboot oem eraseconfig
- fastboot oem erase (hmm, seems like this would require an additional argument)
- fastboot oem reset

  • 0

#104
varda

varda

    Newbie

  • Members
  • Pip
  • 1 posts
Found solution for both no USB/adb, no sd card after diving in deep in !!!!!!!
Solution for SD card not recognized on android device
U should be able to go into fastboot usb mode ( Volume dwn + power button hold simultaneously)
Plug in ur phone usb to PC to enter Fastboot usb mode.
Hits.
1) Open command in windows(as admin on vista/win7)
dir must be set to android\android-sdk\tools( or what ever dir struct it is)

Guid to set up sdk on windows
http://www.mydroidwo...s-easy-way.html
2) Type in your command without quotes
“fastboot oem enableqxdm 0”
3) Once done reboot ur device
4) Your SD card must be recognized now.





Solution for USB not recognized on android device
URL: http://forum.xda-dev...266#post6641266
Steps involved:

1. Find out your CID. Go into fastboot mode, and do 'fastboot oem boot'.

The log will say something like the following:

CODE
#INFOTAG:Ramdisk OK
#INFOTAG:smi ok, size = 0
#INFOTAG:hwid 0x0
#INFOTAG:skuid 0x21F04
#INFOTAG:hero panel = 0x0
#INFOTAG:engineerid = 0x0
#INFOMCP dual-die
#INFOMCP dual-die
#INFOTAG:mono-die = 0x0
#INFODevice CID is not super CID
#INFOCID is HTC__E11


In this specific case, the CID is HTC__E11.
)For HTC hero it will b HTC_023)

2. Get the following mtd0.img from the above url

Edit this image to the CID you found above with a hex editor.
(Use hex editor & change the first line containing the CID to the CID which u get from ‘fastboot oem’

3. Get flash_image from the attached files below
Move this to /data/ ,
You can move both mtd0.img and flash_image by putting it on your sdcard,
Remember!!!!!!
You must move these 2 files to /data/ of your device not to ur /sd !!!!!!!
1) use root exploere to move or
2) issueing the following command in a terminal emulator:
'cat /sdcard/flash_image > /data/flash_image'
'cat /sdcard/mtd0.img > /data/mtd0.img'

You might have to do 'chmod u+x /data/flash_image' before you run the commands (or chmod 755 /data/flash_image)

3) After moving issue this command in the terminal emulator in your devie.(Better Terminal Emulator)

/data/flash_image misc /data/mtd0.img


4. Repeat step 3 a couple of times if it doesn't seem to work well.This may throw some erro, dosent matter go ahead & reboot.

5. All done! Reboot, you should have normal usb connectivity. Post your 'fastboot oem boot' log and intermediate steps if it fails.

Attached Files


  • 0

#105
bestg1

bestg1

    Newbie

  • Members
  • Pip
  • 2 posts
  • Location:mid Germany
  • Devices:DHD, Hero GSM, G1
Hi @ all! (first post for me in modaco`s)

@varda: hope you`re still monitoring this thread......Just one, probably a noob question:

Before entering the command of 3). from your above TUT in termminal emulator, do I have to type `su`to get the # instead of the $ ??

I`m now on that issue for about three days and this is really my last hope. Done everything including a complete
move back to the oldest factory setup 1.76.405.1, no succes with nothing so far!!
I`ve the SD properly working in the phone, I`ve fastboot but ain`t got ADB and the phone pop ups when connecting "alive".
Now again completely back to the oldest stock ROM with root and custom recovery installed, but still S-ON and I don`t want to knacker the device.


Thanks in advance :D


btw.: happy new year @all

bestg1

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users