Jump to content


Photo

USB brick/rickrolled/b0rked -> FIXED!

- - - - -

  • Please log in to reply
51 replies to this topic

#41
bestdaniel20

bestdaniel20

    Newbie

  • Members
  • Pip
  • 2 posts

the best info :rolleyes:

thnx :huh:

my legend non-bricked img:
INFOCID is HTC__032
INFOsetting->cid::HTC__032

Help me understand what to do with flash_image, when you give the link, and my pops a page with writing, what should I do? With hex editor does not know how to work, I tried to place the entire page in hex editor and could not understand anything.
infocid is HTC__Y13

Edited by bestdaniel20, 12 November 2010 - 08:37 AM.

  • 0

#42
mertins

mertins

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:legend
Guess something is wrong?

C:\androidSDK\tools>fastboot eom enableqxdm 0
usage: fastboot [ <option> ] <command>

commands:
update <filename> reflash device from update.zip
flashall flash boot + recovery + system
flash <partition> [ <filename> ] write a file to a flash partition
erase <partition> erase a flash partition
getvar <variable> display a bootloader variable
boot <kernel> [ <ramdisk> ] download and boot kernel
flash:raw boot <kernel> [ <ramdisk> ] create bootimage and flash it
devices list all connected devices
reboot reboot device normally
reboot-bootloader reboot device into bootloader

options:
-w erase userdata and cache
-s <serial number> specify device serial number
-p <product> specify product name
-c <cmdline> override kernel commandline
-i <vendor id> specify a custom USB vendor id
-b <base_addr> specify a custom kernel base address
-n <page size> specify the nand page size. default:
2048

Any ideas?

My device can be found by fastboot devices

  • 0

#43
Dusan Djokic

Dusan Djokic

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:HTC Legend
You, sir, are my hero!
Thank you soooooo much!!!

  • 0

#44
i4o

i4o

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:HTC Legend
Hi, my friend have a problem.
When try to install FROYO 3.15, he receives error - Error:[110]
It only appears a black screen with htc logo and ends there.
Help please
What can I do?

C:\Documents and Settings\NEW>fastboot oem boot
							  ... INFOsetup_tag addr=0x60000100 cmdline add=0x9D
07B198
INFOTAG:Ramdisk OK
INFOTAG:smi ok, size = 0
INFOTAG:hwid 0x0
INFOTAG:skuid 0x22F00
INFOTAG:hero panel = 0x0
INFOTAG:engineerid = 0x0
INFOMCP dual-die
INFOMCP dual-die
INFOTAG:mono-die = 0x0
INFODevice CID is not super CID
INFOCID is HTC__032
INFOsetting->cid::HTC__032
INFOserial number: HT03ZNX05896
INFOcommandline from head: no_console_suspend=1 console=null
INFOcommand line length =445
INFOactive commandline: board_legend.disable_uart3=0 board_legen
INFOd.usb_h2w_sw=0 board_legend.disable_sdcard=0 diag.enabled=0
INFOboard_legend.debug_uart=0 smisize=0 userdata_sel=0 androidbo
INFOot.emmc=false  androidboot.baseband=7.08.35.21 androidboot.c
INFOid=HTC__032 androidboot.carrier=HTC-EastEurope androidboot.m
INFOid=PB7610000 androidboot.keycaps=qwerty androidboot.mode=nor
INFOmal androidboot.serialno=HT03ZNX05896 androidboot.bootloader
INFO=1.01.0000 no_console_suspend=1 console=null
INFOaARM_Partion[0].name=misc
INFOaARM_Partion[1].name=recovery
INFOaARM_Partion[2].name=boot
INFOaARM_Partion[3].name=system
INFOaARM_Partion[4].name=cache
INFOaARM_Partion[5].name=userdata
INFOpartition number=6
INFOValid partition num=6
FAILED (status read failed (Too many links))
finished. total time: 0.938s

Problem is solved.

Edited by i4o, 20 December 2010 - 09:28 PM.

  • 0

#45
eepunk

eepunk

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:HTC Legend
My Legend will sometimes (read: infrequently) mount with USB but by and large it just charges when plugged into a PC. I've tried the debricking technique but it hasn't had any positive outcomes.

I've also tried three different cables and five different PCs. The same cables and PCs work with my friends' Android phones.


The log;

[codebox]C:\Android\android-sdk-windows\tools>fastboot oem boot
... INFOsetup_tag addr=0x60000100 cmdline add=0x9D
07B198
INFOTAG:Ramdisk OK
INFOTAG:smi ok, size = 0
INFOTAG:hwid 0x0
INFOTAG:skuid 0x22F00
INFOTAG:hero panel = 0x0
INFOTAG:engineerid = 0x0
INFOMCP dual-die
INFOMCP dual-die
INFOTAG:mono-die = 0x0
INFODevice CID is not super CID
INFOCID is HTC__038
INFOsetting->cid::HTC__038
INFOserial number: HT043NX02726
INFOcommandline from head: no_console_suspend=1 console=null
INFOcommand line length =440
INFOactive commandline: board_legend.disable_uart3=0 board_legen
INFOd.usb_h2w_sw=0 board_legend.disable_sdcard=0 diag.enabled=0
INFOboard_legend.debug_uart=0 smisize=0 userdata_sel=0 androidbo
INFOot.emmc=false androidboot.baseband=7.13.35.05 androidboot.c
INFOid=HTC__038 androidboot.carrier=HTC-India androidboot.mid=PB
INFO7610000 androidboot.keycaps=qwerty androidboot.mode=normal a
INFOndroidboot.serialno=HT043NX02726 androidboot.bootloader=1.01
INFO.0000 no_console_suspend=1 console=null
INFOaARM_Partion[0].name=misc
INFOaARM_Partion[1].name=recovery
INFOaARM_Partion[2].name=boot
INFOaARM_Partion[3].name=system
INFOaARM_Partion[4].name=cache
INFOaARM_Partion[5].name=userdata
INFOpartition number=6
INFOValid partition num=6
FAILED (status read failed (Too many links))
finished. total time: 0.902s

[/codebox]

  • 0

#46
Shawry_1981

Shawry_1981

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:HTC Legend
I've been at this for days now to no evail. My USB bricked with my SD card after a recovery from cyanogenmods rom (should of stuck with custom modaco rom but wanted to see what else there was)

Fixed the SD card no drama but the rest is hazy. I've tried so many different things that I'm not even sure if my device is still rooted.

This is my 'fastboot oem boot' output:
________________________________________________________________
C:\AndroidSDK\tools>fastboot oem boot

... INFOsetup_tag addr=0x60000100 cmdline add=0x079570
INFOTAG:Ramdisk OK
INFOTAG:smi ok, size = 0
INFOTAG:hwid 0x0
INFOTAG:skuid 0x22F00
INFOTAG:hero panel = 0x0
INFOTAG:engineerid = 0x0
INFOMCP dual-die
INFOMCP dual-die
INFOTAG:mono-die = 0x0
INFODevice CID is not super CID
INFOCID is VODAP021
INFOsetting->cid::VODAP021
INFOserial number: HT05WNX00453
INFOcommandline from head: no_console_suspend=1 console=null
INFOcommand line length =445
INFOactive commandline: board_legend.disable_uart3=1 board_legen
INFOd.usb_h2w_sw=1 board_legend.disable_sdcard=0 diag.enabled=0
INFOboard_legend.debug_uart=0 smisize=0 userdata_sel=0 androidbo
INFOot.emmc=false androidboot.baseband=7.08.35.21 androidboot.c
INFOid=VODAP021 androidboot.carrier=VODA-Australia androidboot.m
INFOid=PB7610000 androidboot.keycaps=qwerty androidboot.mode=nor
INFOmal androidboot.serialno=HT05WNX00453 androidboot.bootloader
INFO=0.43.0003 no_console_suspend=1 console=null
INFOaARM_Partion[0].name=misc
INFOaARM_Partion[1].name=recovery
INFOaARM_Partion[2].name=boot
INFOaARM_Partion[3].name=system
INFOaARM_Partion[4].name=cache
INFOaARM_Partion[5].name=userdata
INFOpartition number=6
INFOValid partition num=6
INFOmpu_nand_acpu_rw 8F2 1000
FAILED (status read failed (Too many links))
finished. total time: 0.877s
________________________________________________________________

So my CID is VODAP021. I downloaded the mtd0legend and modified it in Hex editor to VODAP021,& renamed it mtd0, then downloaded flash_image.
I put them on my (non goldcard) SD card in the root directory, as well as in a folder called 'data'.... am i on the right track? now I've used the cmd prompt to carry out the "/data/flash_image misc /data/mtd0.img" command, is this right? it didn't work so I'm guessing not. I couldn't get any terminal emulators to work on my phone from the marketplace. (leads me to believe my phone is no longer rooted). I went back to my original vodafone official release because I was following a random method to unbrick the usb, but it didn't work, obviously.

Anyway, none of this has worked. Those commands don't find the path or it doesn't recognize the commands.

When it says:
_____________________________________________
Move this to /data/ , and flash the modified image using:

"/data/flash_image misc /data/mtd0.img"
_____________________________________________

in step 3. What exactly do you mean & how exactly is this done.

Or, if you see the error of my ways in the dumbed down step by step above could you let me know.
I've tried going through the entire process of creating a goldcard again, downgrading versions & rooting the phone again but I can't do any of it without usb working properly.
Also tried HtcSync software downgrades & upgrades, sometimes the drivers will say they are installed but it still doesn't work properly.
All I want to do is get back to the Custom Modaco ROM that I had running ever so sweetly, Argh

Edited by Shawry_1981, 04 January 2011 - 03:18 PM.

  • 0

#47
aikon96

aikon96

    Newbie

  • Members
  • Pip
  • 1 posts
Yeah, this saved my Legend !
Thank u very much!


Here´s the VODAP102 from the German Vodaphone Legend:

INFOCID is VODAP102
INFOsetting->cid::VODAP102

PS: Just rename "mtd0legend.img" -> "mtd0.img"

Attached Files


  • 0

#48
sumpfbeere

sumpfbeere

    Newbie

  • Members
  • Pip
  • 1 posts
Is there another way to do this than with the fastboot binary? I can't connect my phone to a computer. Tried both Windows and Linux on 3 different machines :unsure:.

  • 0

#49
Ganhiru

Ganhiru

    Regular

  • Members
  • PipPip
  • 126 posts
  • Gender:Male
  • Location:NL
  • Devices:Piramid,HD2,i8000, i900, X500+
I can confirm that this fixes the USB soft brick issue I experienced ass wel. ( HTC Legend )
After that I followed the r4-legend-root Step 1 and skipped step two by placing Clockworkmod as update.zip on the SD. Recovery Vol up + power. And I was back in the game. { I lost that other game while typing this }

It took me some searching. Ty for the fix.

  • 0

#50
anteelope

anteelope

    Newbie

  • Members
  • Pip
  • 1 posts
Hi All !

This is my htc legend fastboot oem boot result. Seems everthying ok, but usb still not working. The phone was rooted. I tried the su commands many times in terminal mode on the phone. I have never got error message, but nothing changed. I was reading more forums and i couldn't find any solution for my problems. What are you thinking? What is the problem?

C:\Documents and Settings\Rendszergazda\Asztal\HTC HERO\android-sdk-windows\tool
s>fastboot oem boot
...
(bootloader) setup_tag addr=0x60000100 cmdline add=0x9D07B198
(bootloader) TAG:Ramdisk OK
(bootloader) TAG:smi ok, size = 0
(bootloader) TAG:hwid 0x0
(bootloader) TAG:skuid 0x22F00
(bootloader) TAG:hero panel = 0x0
(bootloader) TAG:engineerid = 0x0
(bootloader) MCP dual-die
(bootloader) MCP dual-die
(bootloader) TAG:mono-die = 0x0
(bootloader) Device CID is not super CID
(bootloader) CID is HTC__032
(bootloader) setting->cid::HTC__032
(bootloader) serial number: HT03ZNX01346
(bootloader) commandline from head: no_console_suspend=1 console=null
(bootloader) command line length =446
(bootloader) active commandline: board_legend.disable_uart3=0 board_legen
(bootloader) d.usb_h2w_sw=0 board_legend.disable_sdcard=0 diag.enabled=0
(bootloader) board_legend.debug_uart=0 smisize=0 userdata_sel=0 androidbo
(bootloader) ot.emmc=false androidboot.baseband=7.05.35.26L androidboot.
(bootloader) cid=HTC__032 androidboot.carrier=HTC-EastEurope androidboot.
(bootloader) mid=PB7610000 androidboot.keycaps=qwerty androidboot.mode=no
(bootloader) rmal androidboot.serialno=HT03ZNX01346 androidboot.bootloade
(bootloader) r=1.01.0000 no_console_suspend=1 console=null
(bootloader) aARM_Partion[0].name=misc
(bootloader) aARM_Partion[1].name=recovery
(bootloader) aARM_Partion[2].name=boot
(bootloader) aARM_Partion[3].name=system
(bootloader) aARM_Partion[4].name=cache
(bootloader) aARM_Partion[5].name=userdata
(bootloader) partition number=6
(bootloader) Valid partition num=6
FAILED (status read failed (Too many links))
finished. total time: 1.188s

  • 0

#51
dickohead

dickohead

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:HTC Desire
I just got this working on my HTC Desire with the Desire HD image (leedroid). I wanted to reiterate the steps, as I feel that the instructions were a little out of order (I got a tad confused at first):

Prework:

  • Your phone must be rooted to try the following, it seems you can't write to mtd0 without root.
  • Your SD card has to work. For this, do "fastboot oem enableqxdm 0" at a command prompt while in fastboot mode (google search 'fastboot' if you need instructions on using this).
Steps:
***Step 1***

Find out your CID. Go into fastboot mode, and type "fastboot oem boot" at the command line.
The log will say something like the following:

#INFOTAG:Ramdisk OK
#INFOTAG:smi ok, size = 0
#INFOTAG:hwid 0x0
#INFOTAG:skuid 0x21F04
#INFOTAG:hero panel = 0x0
#INFOTAG:engineerid = 0x0
#INFOMCP dual-die
#INFOMCP dual-die
#INFOTAG:mono-die = 0x0
#INFODevice CID is not super CID
#INFOCID is HTC__E11
In this specific case, the CID is HTC__E11.


*** Step 2 ***


Generate a custom mtd0.img at http://ks25738.kimsufi.com/misc/
- Using the CID from above; and
- Your ROM number: From System --> About Phone --> Software Information --> Build Number (e.g. 2.50.405.2)


*** Step 3 ***


Get flash_image from here or from here: mirror provided by SgtDavePwnage.

Move both the flash_image file and the mtd0.img file to the /data/ folder by typing the following in a terminal emulator on your phone:

cat /sdcard/flash_image > /data/flash_image
cat /sdcard/mtd0.img > /data/mtd0.img

Now flash the modified image file using:
/data/flash_image misc /data/mtd0.img


*** Step 4 ***


Enjoy.



  • 0

#52
MoeyyAS

MoeyyAS

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:HTC Legend
-cry- T_T... u saved my life, THANK YOU!

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users