Jump to content


Photo

SD Card removed, but it's there!

- - - - -

  • Please log in to reply
10 replies to this topic

#1
JoQ

JoQ

    Newbie

  • Members
  • Pip
  • 2 posts
  • Devices:HTC Legend
Hi I just bought my Legend, it was used and already rooted.
I installed MoDaCo R2 via Recovery-menu, it went well, but after that it says my SD-card is removed.
Can't format it in setting either.

So I tried going into recovery-mode again, but it doesn't work. I can't get into recovery-mode. Does this have to do with the SD-card "not being there"?

Please help me!! I only have one SD-card so I cant try with another.
I really wish I havn't bricked anything!

EDIT: Trying to go to recovery gives me "error: device not found"

Damnit, what can I do!

Edited by JoQ, 02 July 2010 - 07:59 PM.

  • 0

#2
gutter

gutter

    Newbie

  • Members
  • Pip
  • 3 posts
Read this thread:

http://android.modac...-fixed/page/20/

and my post. should fix the problem.

  • 0

#3
Deffe

Deffe

    Newbie

  • Members
  • Pip
  • 2 posts
I have a similar problem:

Hi, today i take my legend and i did a nandroid restore. After that my htc legend didn't read the sd card...

i can go in recovery mode but when i have black screen with phone and red mark and i put legend with cable in usb the phone restarted and, in this way i can't make anyting.
So now pc syc is impossible also like flash roms. So i can't reflash rom or flash an original one for the htc support..

How can i do for solve the problems? please help me i'm little noob..

There is a step by step guide for make my phone able to read the sd card, please?
__________________

  • 0

#4
kubensis

kubensis

    Newbie

  • Members
  • Pip
  • 15 posts

Read this thread:

http://android.modac...-fixed/page/20/

and my post. should fix the problem.


hey Gutter i always get "permission denied" when entering the line;

cat /sdcard/flash_image > /data/flash_image or cat /sdcard/mtd0.img > /data/mtd0.img

do you have any idea why?

  • 0

#5
kubensis

kubensis

    Newbie

  • Members
  • Pip
  • 15 posts
Just a quick something to add, in Astro File Manager when the card is not visible Astro also cannot access it and it has "d--" next to "sdcard". When the card is visible Astro has "drw" next to "sdcard" i would imagine this is the difference between write protected and re-writable, just hope this is useful to someone aiming to fix this problem (like me!). Also the card seems to drift inbetween being seen and not being seen intermittently.

  • 0

#6
smartsreenath

smartsreenath

    Newbie

  • Members
  • Pip
  • 8 posts

Just a quick something to add, in Astro File Manager when the card is not visible Astro also cannot access it and it has "d--" next to "sdcard". When the card is visible Astro has "drw" next to "sdcard" i would imagine this is the difference between write protected and re-writable, just hope this is useful to someone aiming to fix this problem (like me!). Also the card seems to drift inbetween being seen and not being seen intermittently.

:) ya you are right but what is the use ?.i am using modaco rom ,after reset for me showing no sd card......some one help me......paul are u there ........please help us.................

Edited by smartsreenath, 06 August 2010 - 01:47 PM.

  • 0

#7
kubensis

kubensis

    Newbie

  • Members
  • Pip
  • 15 posts
I think its only the Modaco rom that causes this issue?

Doesnt seem like there any immediate answer i'm afraid, dont think we'll be able to recieve the 2.2 update either :)

  • 0

#8
smartsreenath

smartsreenath

    Newbie

  • Members
  • Pip
  • 8 posts

I think its only the Modaco rom that causes this issue?

Doesnt seem like there any immediate answer i'm afraid, dont think we'll be able to recieve the 2.2 update either :)

then what is the problem????? neeeed help

  • 0

#9
Berek

Berek

    Newbie

  • Members
  • Pip
  • 27 posts

then what is the problem????? neeeed help

I'm afraid I don't have an answer, but please stop using the silly large coloured fonts. It's not necessary and if anything will put people off helping you.

  • 0

#10
smartsreenath

smartsreenath

    Newbie

  • Members
  • Pip
  • 8 posts

I'm afraid I don't have an answer, but please stop using the silly large coloured fonts. It's not necessary and if anything will put people off helping you.

i am sorry..... :) actually i was desperate with issue of my mobile........i am sorry to everyone....

  • 0

#11
smartsreenath

smartsreenath

    Newbie

  • Members
  • Pip
  • 8 posts

i am sorry..... :) actually i was desperate with issue of my mobile........i am sorry to everyone....

mine is working see the post.....http://forum.xda-dev...ad.php?t=748813 :D :D

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users