Jump to content


Photo

LiveView frozen after firmware update


  • Please log in to reply
1 reply to this topic

#1
Sasha Pave

Sasha Pave

    Newbie

  • Members
  • Pip
  • 1 posts
  • Devices:Sony LiveView
Hi all,

I updated the firmware on my 2-day old LiveView and now it's broken. It was working as expected before the firmware update (able to pair, connect, apps functional) but now when booted it shows the splash screen then immediately goes into a "blank" screen with only a null clock like display in the upper-left and a battery charge indicator in the upper-right. Pic attached.

Posted Image


I can power-cycle it by holding down the left button, same behavior. Holding down the power button 5 sec. to enter pairing mode doesn't do anything. It'll enter DFU mode properly, so I've tried re-installing the firmware about 10x now with the same result.

While on the "blank screen" it does not show up in bluetooth devices on my phone (Droid with OS 2.2).

So, now it's a brick unless I can find a fix. Maybe try to revert firmware to the previous version?

Any help is appreciated!

-Sasha

  • 0

#2
msiviter

msiviter

    Regular

  • Members
  • PipPip
  • 66 posts
  • Gender:Male
  • Location:Epsom
Did you apply the firmware update using Phone Companion 2.1.
That's the way I did it, I ticked the option for Xperia X10 then clicked repair broken phone.

If you can get to the DFU I think you'll rescue it somehow, good luck!

Matt

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users