Jump to content

LiveView frozen after firmware update

Guest Sasha Pave

Recommended Posts

Guest Sasha Pave

Hi all,

I updated the firmware on my 2-day old LiveView and now it's broken. It was working as expected before the firmware update (able to pair, connect, apps functional) but now when booted it shows the splash screen then immediately goes into a "blank" screen with only a null clock like display in the upper-left and a battery charge indicator in the upper-right. Pic attached.


I can power-cycle it by holding down the left button, same behavior. Holding down the power button 5 sec. to enter pairing mode doesn't do anything. It'll enter DFU mode properly, so I've tried re-installing the firmware about 10x now with the same result.

While on the "blank screen" it does not show up in bluetooth devices on my phone (Droid with OS 2.2).

So, now it's a brick unless I can find a fix. Maybe try to revert firmware to the previous version?

Any help is appreciated!


Link to comment
Share on other sites

Guest msiviter

Did you apply the firmware update using Phone Companion 2.1.

That's the way I did it, I ticked the option for Xperia X10 then clicked repair broken phone.

If you can get to the DFU I think you'll rescue it somehow, good luck!


Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.