Jump to content


Photo

[ROM] CM 10.1 + Daily Driver Tweaks


  • Please log in to reply
32 replies to this topic

#1
ShadeStorm98

ShadeStorm98

    Newbie

  • Members
  • Pip
  • 36 posts
Aight guys. Past couple days i've been messing around with CM10.1 (htcmania version since i couldn't flash josalaito's). Below is the instructions to get a CM installation that's wicked sick :P

1. First off, im guessing yall have got a custom recovery installed, your gonna have to use CWM, this one

2. Flash CM10.1 like a brutha. you can use rom manager for that, or just hold volume + and the power button

3. Get the sisco kernel for CM10.1 and flash it

4. put some Chinese baseband on it for hanging up calls to enemies ;) flash it (like all the rest so far)

At this point, you have CM10.1 and it's pretty sick already, but we'r missing some battery-ness and some lovely video codecs. lets get some of that ey?

5. install battery saver off the Google Play Store. I like that one, it's simple and i'm simple, we're good together :) but ramp it up to level 2 of battery saving

6. MX Player will sort out most of your video needs. it'll ask you to install this aswell.

Right, that's it. Couple of extra things you can do to make your phone extra happy :P :

I) get a defaults app, this does the job well. You'll need to scroll to the bottom and change Video and Video Streaming MX Player.

ii) move MX Player to the system folder. if your lazy like me and you do this a lot, you can download an app to do it for you like this one. this step isn't 100% necessary but i think it lets Facebook use MX Player instead of the stock video player.

DONE!

Credits... i dont know if i need to do this but why not.
Thanks to: HERRERO7, Eloimuns, asis_92, and all those guys that made the apps. And all the fine people of modaco and htcmania cause i'm a massive noob but you guys explain stuff well.

Hope it works well for you guys

  • 0

#2
Phrank

Phrank

    Regular

  • Members
  • PipPip
  • 56 posts
Is GPS not working in this ROM?

  • 0

#3
ShadeStorm98

ShadeStorm98

    Newbie

  • Members
  • Pip
  • 36 posts
Just checked and yeah it's working perfectly for me :)

  • 0

#4
Phrank

Phrank

    Regular

  • Members
  • PipPip
  • 56 posts
Hmm. Weird. Wasn't working for me. I've just reverted to stock and reinstalled TWRP, I might give it another go later. I need to put the phone down some time today... ;-)

  • 0

#5
legotub

legotub

    Newbie

  • Members
  • Pip
  • 16 posts
  • Gender:Male
  • Devices:Huawei Ascend G510
Tried this out, seemed very similar to the other cyanogen I was on, only difference was boot animation. My signal didn't seem to work, even after flashing the baseband which was a bit wierd. I think I just want to go back to stock though, so Phrank, can I ask you how you reverted to stock? Did you use a backup from TWRP?

  • 0

#6
Phrank

Phrank

    Regular

  • Members
  • PipPip
  • 56 posts

Tried this out, seemed very similar to the other cyanogen I was on, only difference was boot animation. My signal didn't seem to work, even after flashing the baseband which was a bit wierd. I think I just want to go back to stock though, so Phrank, can I ask you how you reverted to stock? Did you use a backup from TWRP?


I posted in the MIUI thread and replied to your PM, and I'm pleased you're all sorted :)

  • 0

#7
KenBW2

KenBW2

    Diehard

  • Members
  • PipPipPipPip
  • 334 posts
  • Gender:Male
  • Devices:Huawei Y300 & G510, ZTE Blade
How are we for Bluetooth support?

  • 0

Huawei Y 300 Stock 4.1 + Root Tweaks > FusionX > CM10 > CM10.1 > CM10.2 > CM11 | Clockwork Recovery
Huawei Y 300 Stock 4.1 > CM 10.1 Sisco 1.0 kernel > TouchMeZ v1.4.1 > b190 Firmware Update > CM10.1 | TWRP Recovery
Huawei G510 Stock 4.1 > TouchMe v7 + AOSP Mod
Z.T.E. Blade TFT Stock 2.1 > CM7 > [GEN1>GEN2] > Ginger Stir Fry 9 > Blue Ginger V2 > [GEN2 > GEN3] > CM9 Alpha 5 > Simple Stir Fry Lite b27 > CM9 ColdFusionX 28/02/12 > KonstaT's CM10 > KonstaT's CM10.1 | Clockwork 5.0.2.0
Z.T.E. Blade OLED Stock 2.1 > JJ RLS5 > CM7 RC1 > Ippe H's Honeycomb A5 > Finnish Fillyjonk RLS6 > CM7 RC1 > Stock 2.1 | Clockwork 2.5.1.8 > 3.0.0.5
ZTE Blade TFT Stock 2.1 > MCR r3 | Clockwork 2.5.1.3 (
Replaced)
T-Mobile Pulse (Lots) > FLB2 > CM7 > CM6.1, Clockwork Recovery


#8
joenefloresca

joenefloresca

    Newbie

  • Members
  • Pip
  • 32 posts
Tried it and still, Sim Card doesn't work?

  • 0

#9
ShadeStorm98

ShadeStorm98

    Newbie

  • Members
  • Pip
  • 36 posts
@KenBW2 Bluetooth works perfectly, like everything else on this setup (apart from the youtube app) EDIT: bluetooth doesnt work, but how often does one use bluetooth nowadays?

@joenefloresca if your sim still isn't working then there are a few ways you can get back to total stock. from my understanding you have to get the original update.zip and put it in a dload folder on your zip. But your probably have to get a complete guide if your lost with that. Phrank said it pretty well :

EDIT: Deleted my original comment about not having the stock ROM.

Download the G510 stock 4.1.1 ROM from here : http://www.ulozto.ne...r001c02b170-rar

From the RAR file, extract the folder called 1_SDCARD

Change the name of this folder to dload and copy it to the root directory of your SD card (not inside any other folders, that is)

Switch off your phone, pull the battery for 5 seconds.

Hold the VOLUME UP AND VOLUME DOWN button and push the POWER button. Hold them for a few seconds, and the Huawei upgrader will kick in. It takes about 5 minutes to reflash the stock ROM completely, make sure you have enough charge.

When you're done, reboot as normal and you're back to "out of the box" state, i.e. unrooted. Just follow the other guides here to root and install TWRP or CM recovery and then flash your favourite custom ROM as normal.

All sorted ;-)


Edited by ShadeStorm98, 23 June 2013 - 09:07 AM.

  • 0

#10
totydm

totydm

    Newbie

  • Members
  • Pip
  • 41 posts
  • Devices:y300

Aight guys. Past couple days i've been messing around with CM10.1 (htcmania version since i couldn't flash josalaito's). Below is the instructions to get a CM installation that's wicked sick :P

1. First off, im guessing yall have got a custom recovery installed, your gonna have to use CWM, this one

2. Flash CM10.1 like a brutha. you can use rom manager for that, or just hold volume + and the power button

3. Get the sisco kernel for CM10.1 and flash it

4. put some Chinese baseband on it for hanging up calls to enemies ;) flash it (like all the rest so far)

At this point, you have CM10.1 and it's pretty sick already, but we'r missing some battery-ness and some lovely video codecs. lets get some of that ey?

5. install battery saver off the Google Play Store. I like that one, it's simple and i'm simple, we're good together :) but ramp it up to level 2 of battery saving

6. MX Player will sort out most of your video needs. it'll ask you to install this aswell.

Right, that's it. Couple of extra things you can do to make your phone extra happy :P :

I) get a defaults app, this does the job well. You'll need to scroll to the bottom and change Video and Video Streaming MX Player.

ii) move MX Player to the system folder. if your lazy like me and you do this a lot, you can download an app to do it for you like this one. this step isn't 100% necessary but i think it lets Facebook use MX Player instead of the stock video player.

DONE!

Credits... i dont know if i need to do this but why not.
Thanks to: HERRERO7, Eloimuns, asis_92, and all those guys that made the apps. And all the fine people of modaco and htcmania cause i'm a massive noob but you guys explain stuff well.

Hope it works well for you guys


Hi, thanks for the tutorial....i've only a question, yesterday i've flashed my recovery with the recovery.img you have posted, using fastboot (via linux e via windows) but the recovery won't start....i've an Y300 not a G510...is it a compatibility problem? Have u flashed your recovery via fastboot?

  • 0

#11
ShadeStorm98

ShadeStorm98

    Newbie

  • Members
  • Pip
  • 36 posts
Yeah i flashed via fastboot, im not 100% sure recoveries for y300 and g510 are compatible, although i dont have a y300 to test.

  • 0

#12
totydm

totydm

    Newbie

  • Members
  • Pip
  • 41 posts
  • Devices:y300

Yeah i flashed via fastboot, im not 100% sure recoveries for y300 and g510 are compatible, although i dont have a y300 to test.


Ok...another question if i can....I've read that after flashing the CM, the TWRp touch not work...in a situation like this, have I a possibilities to flash another rom? Sure not from the device...but via adb??? Anyone have ever pushed a rom in this device with adb?? and....a downgrade like this CM10.1->stock 4.1.1 is possible? is easy like to push a normal/same-version rom ?

Thanks in advance

  • 0

#13
ZolaIII

ZolaIII

    Addict

  • Members
  • PipPipPipPipPip
  • 888 posts
  • Devices:Huawei Y300-100

Ok...another question if i can....I've read that after flashing the CM, the TWRp touch not work...in a situation like this, have I a possibilities to flash another rom? Sure not from the device...but via adb??? Anyone have ever pushed a rom in this device with adb?? and....a downgrade like this CM10.1->stock 4.1.1 is possible? is easy like to push a normal/same-version rom ?

Thanks in advance

Read the http://www.modaco.co...40#entry2135438

  • 0

#14
joenefloresca

joenefloresca

    Newbie

  • Members
  • Pip
  • 32 posts
@ShadeStorm98
Yeah, I managed to get back to my stock rom :) But is there any way to get my sim card working when I flashed Cyanogen Mod? I followed your tutorial but no luck.

  • 0

#15
KenBW2

KenBW2

    Diehard

  • Members
  • PipPipPipPip
  • 334 posts
  • Gender:Male
  • Devices:Huawei Y300 & G510, ZTE Blade

@KenBW2 bluetooth doesnt work, but how often does one use bluetooth nowadays?


Car stereo, all the damn time

  • 0

Huawei Y 300 Stock 4.1 + Root Tweaks > FusionX > CM10 > CM10.1 > CM10.2 > CM11 | Clockwork Recovery
Huawei Y 300 Stock 4.1 > CM 10.1 Sisco 1.0 kernel > TouchMeZ v1.4.1 > b190 Firmware Update > CM10.1 | TWRP Recovery
Huawei G510 Stock 4.1 > TouchMe v7 + AOSP Mod
Z.T.E. Blade TFT Stock 2.1 > CM7 > [GEN1>GEN2] > Ginger Stir Fry 9 > Blue Ginger V2 > [GEN2 > GEN3] > CM9 Alpha 5 > Simple Stir Fry Lite b27 > CM9 ColdFusionX 28/02/12 > KonstaT's CM10 > KonstaT's CM10.1 | Clockwork 5.0.2.0
Z.T.E. Blade OLED Stock 2.1 > JJ RLS5 > CM7 RC1 > Ippe H's Honeycomb A5 > Finnish Fillyjonk RLS6 > CM7 RC1 > Stock 2.1 | Clockwork 2.5.1.8 > 3.0.0.5
ZTE Blade TFT Stock 2.1 > MCR r3 | Clockwork 2.5.1.3 (
Replaced)
T-Mobile Pulse (Lots) > FLB2 > CM7 > CM6.1, Clockwork Recovery


#16
ShadeStorm98

ShadeStorm98

    Newbie

  • Members
  • Pip
  • 36 posts
@KenBW2 yep, i see your point :P

@joenfloresca if you've got the stock rom, then you go to this cm and flash the baseband-lewa.zip then your sim should work, it worked for me.

@totydm TWRP doesnt work with CyanogenMod, but i put a link to a CWM that works very well with our g510's

  • 0

#17
Phrank

Phrank

    Regular

  • Members
  • PipPip
  • 56 posts
Guys, this is a version of TWRP which *does* work on the G510 with CyanogenMod installed. I zipped the recovery.img into the installer from somewhere else. Put your phone into Fastboot mode, run Install-Windows.bat and you're done. I installed this myself on my phone after the other version of TWRP stopped responding to screen presses after flashing CM.

One thing, this version saves backups in a different folder (LEWA/backups if I remember right and not TWRP/backups) but you can move your existing TWRP backups across manually and they do restore.

File on my dropbox : https://dl.dropboxus...P-LeWa-G510.zip

  • 0

#18
joenefloresca

joenefloresca

    Newbie

  • Members
  • Pip
  • 32 posts
@ShadeStorm98

Dude, It's now working. Thanks :) It worked without flashing lewa baseband. Bluetooth doesn't work, is that the only bug remaining?

Edited by joenefloresca, 24 June 2013 - 06:51 AM.

  • 0

#19
KenBW2

KenBW2

    Diehard

  • Members
  • PipPipPipPip
  • 334 posts
  • Gender:Male
  • Devices:Huawei Y300 & G510, ZTE Blade

@ShadeStorm98

Dude, It's now working. Thanks :) It worked without flashing lewa baseband. Bluetooth doesn't work, is that the only bug remaining?


I was thinking this, it seems like we have a damn near perfect CM10.1, with just Bluetooth remaining

  • 0

Huawei Y 300 Stock 4.1 + Root Tweaks > FusionX > CM10 > CM10.1 > CM10.2 > CM11 | Clockwork Recovery
Huawei Y 300 Stock 4.1 > CM 10.1 Sisco 1.0 kernel > TouchMeZ v1.4.1 > b190 Firmware Update > CM10.1 | TWRP Recovery
Huawei G510 Stock 4.1 > TouchMe v7 + AOSP Mod
Z.T.E. Blade TFT Stock 2.1 > CM7 > [GEN1>GEN2] > Ginger Stir Fry 9 > Blue Ginger V2 > [GEN2 > GEN3] > CM9 Alpha 5 > Simple Stir Fry Lite b27 > CM9 ColdFusionX 28/02/12 > KonstaT's CM10 > KonstaT's CM10.1 | Clockwork 5.0.2.0
Z.T.E. Blade OLED Stock 2.1 > JJ RLS5 > CM7 RC1 > Ippe H's Honeycomb A5 > Finnish Fillyjonk RLS6 > CM7 RC1 > Stock 2.1 | Clockwork 2.5.1.8 > 3.0.0.5
ZTE Blade TFT Stock 2.1 > MCR r3 | Clockwork 2.5.1.3 (
Replaced)
T-Mobile Pulse (Lots) > FLB2 > CM7 > CM6.1, Clockwork Recovery


#20
joenefloresca

joenefloresca

    Newbie

  • Members
  • Pip
  • 32 posts
@KenBW2

yeah. my sim card is now working without even flashing lewa baseband and sisco kernel. I guess, bluetooh is the only one remains and also, I want to ask
why is google accounts not installed? I'd try to add my gmail account but only email exchange and corporate account is available?

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users