Jump to content


Photo

[T] button removal

- - - - -

  • Please log in to reply
27 replies to this topic

#21
greybot

greybot

    Newbie

  • Members
  • Pip
  • 13 posts
  • Devices:Tesco Hudl

Brilliant guide flurry. Almost got my hudl back to where it was after the upgrade now :)


  • 0

#22
flurry

flurry

    Enthusiast

  • Members
  • PipPipPip
  • 183 posts

I can't take credit for the actual steps, I've simply elaborated a bit on Paul O'Brien's original post here


  • 0

#23
jonoathome

jonoathome

    Newbie

  • Members
  • Pip
  • 12 posts
  • Gender:Male
  • Devices:Hudl, Nexus 7, i9305, TF300T
  • Twitter:@jonoathome

I can't take credit for the actual steps, I've simply elaborated a bit on Paul O'Brien's original post here

 

Hi flurry , using your apk after updating the hudl..  it appears the latest gravitybox is causing the same problem you describe in portrait. are you having the same issues ?


Edited by jonoathome, 21 July 2014 - 11:14 PM.

  • 0

www.sixcrazyminutes.com


#24
flurry

flurry

    Enthusiast

  • Members
  • PipPipPip
  • 183 posts

Hi flurry , using your apk after updating the hudl..  it appears the latest gravitybox is causing the same problem you describe in portrait. are you having the same issues ?

 

I can't say I'm seeing any problems, I'm using GravityBox 3.2.1 (stable) and have the cursor control keys enabled. When selecting a text box the arrows appear but the back/home/recents buttons don't move left slightly like they used to.

 

Until recently the custom key in the navigation bar tweaks section of GravityBox used to move the keys slightly too, but no longer does.

 

Let's rule out a few things:

 

1.) are you running the latest stable version of GravityBox?

2.) are you running the Modaco xposed module to remove the T button? This may mess with my modified SystemUI

3.) is it just the cursor arrows causing the buttons to move?

4.) do they move left or right?

5.) does disabling cursor arrow keys fix it?

6.) does disabling GravityBox fix it?

7.) are the buttons centered when not entering text?

8.) are the immersive dots centered on the buttons (open an image in the gallery, zoom so it's bigger than the screen and wait a few seconds and the buttons should fade to little dots)

9.) are you running any other tweaks on the navbar?

 

If you could answer the above it should help me narrow down what's going on :)


Edited by flurry, 22 July 2014 - 06:48 AM.

  • 0

#25
Frederick_99

Frederick_99

    Newbie

  • Members
  • Pip
  • 12 posts
  • Devices:hudl
Many thanks for the guide, worked a treat for me to :)

  • 0

#26
jonoathome

jonoathome

    Newbie

  • Members
  • Pip
  • 12 posts
  • Gender:Male
  • Devices:Hudl, Nexus 7, i9305, TF300T
  • Twitter:@jonoathome

I can't say I'm seeing any problems, I'm using GravityBox 3.2.1 (stable) and have the cursor control keys enabled. When selecting a text box the arrows appear but the back/home/recents buttons don't move left slightly like they used to.

Until recently the custom key in the navigation bar tweaks section of GravityBox used to move the keys slightly too, but no longer does.

Let's rule out a few things:

1.) are you running the latest stable version of GravityBox?
2.) are you running the Modaco xposed module to remove the T button? This may mess with my modified SystemUI
3.) is it just the cursor arrows causing the buttons to move?
4.) do they move left or right?
5.) does disabling cursor arrow keys fix it?
6.) does disabling GravityBox fix it?
7.) are the buttons centered when not entering text?
8.) are the immersive dots centered on the buttons (open an image in the gallery, zoom so it's bigger than the screen and wait a few seconds and the buttons should fade to little dots)
9.) are you running any other tweaks on the navbar?

If you could answer the above it should help me narrow down what's going on :)

I figured out the issue..
If the nav bar is set to always on the bottom in Gravity Box in generates the issue I previously mentioned

Fix is to not to enable that option

  • 0

www.sixcrazyminutes.com


#27
flurry

flurry

    Enthusiast

  • Members
  • PipPipPip
  • 183 posts

I figured out the issue..
If the nav bar is set to always on the bottom in Gravity Box in generates the issue I previously mentioned

Fix is to not to enable that option

 

aah, interesting! I'll have a try enabling that option tonight and see if I get the same response. As the hudl always keeps the nav bar on the bottom by default it shouldn't matter that the option isn't enabled, but it'd be nice to know why it does it


  • 0

#28
flurry

flurry

    Enthusiast

  • Members
  • PipPipPip
  • 183 posts

I figured out the issue..
If the nav bar is set to always on the bottom in Gravity Box in generates the issue I previously mentioned

Fix is to not to enable that option


Having tried enabling the option in GravityBox and rebooting I see what you mean! Its fine in landscape but the portrait layout has the T button back and nothing is lined up other than, oddly enough, the immersive dots.

I'd hazard a guess that GravityBox is forcing the SystemUI.apk to load a layout other than the usual one - thus loading one I've not modified. If I get more time I'll have a look into how to prevent it doing it

 

EDIT: hmm, maybe it's nothing to do with the hudl at all, some of the posts on this page here sound like others have experienced problems with the 'always on bottom' option on other devices


Edited by flurry, 06 August 2014 - 06:51 PM.

  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users