Jump to content


Photo

Restoring Extra Screens to Defaults

- - - - -

  • Please log in to reply
67 replies to this topic

#21
FrankyG

FrankyG

    Addict

  • Members
  • PipPipPipPipPip
  • 607 posts
Damn this transparent screen...just happened to me :x

Any of you guys been able to fix this? Midnight?

  • 0
FrankyG

#22
JoelRae

JoelRae

    Diehard

  • Members
  • PipPipPipPip
  • 401 posts
  • Location:London UK
  • Devices:SPV C500
Well at least I wasn't making it up :wink:

  • 0

#23
FrankyG

FrankyG

    Addict

  • Members
  • PipPipPipPipPip
  • 607 posts
I just removed the 'home screen reset' from 'remove programs' menu on the phone, re-booted.

Then installed the LonghornSPVProExtras.cab to overwrite the default ones. I'm happy with these at the moment, I just can't be bothered trying to apply the 'reset to default' cab again...as I ain't to hopeful of it working!

I've attached the LonghornSPVProExtras.cab in case you want it, without searching :)

Attached Files


  • 0
FrankyG

#24
smittyofdhs

smittyofdhs

    Regular

  • Members
  • PipPip
  • 97 posts
  • Location:So Cal, USA
thank god, midnight made this so when it was uninstalled it reverted all the settings back. I don't like the screens that AWS used on the MPx200. I have another thread going asking for the original images so I could change them back. So I tried this and it totally screwed up all the info and alert screens. Like I said, thank god (or midnight) that this was reversible.

  • 0
PDA Lineage: Handspring Visor Deluxe > Handspring Edge > Ipaq 3850 > Siemens/AT&T SX56 PPCPE > Moto MPx200 Smartphone > Audiovox 4100 PPCPE > Audiovox SMT5600 > Cingular SX66 PPCPE > RIM Blackberry 7520 > RIM Blackberry 7100i > Verizon XV6700 > Samsung BlackJack

#25
JoelRae

JoelRae

    Diehard

  • Members
  • PipPipPipPip
  • 401 posts
  • Location:London UK
  • Devices:SPV C500
Cheers FrankyG, will try the fix asap :)

Posted from my SmartPhone!

  • 0

#26
midnight

midnight

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 3,651 posts
  • Gender:Male
  • Location:Lancashire
  • Interests:2d gfx<br />c#/xna development
  • Devices:HTC Mozart, Sony Ericsson X10
sorry i havent looked at this yet (bloody game development hehe) but i will have a look this weekend sometime, i've no idea why it goes transparent, but i'll solve it one way or another, even if it means having new default images for the error screens :)

  • 0

#27
StarfireCT

StarfireCT

    Newbie

  • Members
  • Pip
  • 24 posts
I saw the transparent screens on the Motorola phone, but I figured it was a MPx200 thingy, but I think it was the same thing you've been seeing:

It's caused but the registry tweak that changes the image: the background colour (BKUnselected) gets set to a blank value but if it's set to COLOR_alertWINDOW, the warning popups stay opaque. Also, I'm pretty sure that as Colour Themes change, the background of the error message will change as well, seeing as the COLOR_alertWINDOW value is a theme-able property.

I put together a a version for the MPx200 because I figured that the original tweak worked OK on the SPV. It also doesn't change the image for the start menu wallpaper and contacts wall paper, but that was by design.

  • 0

#28
midnight

midnight

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 3,651 posts
  • Gender:Male
  • Location:Lancashire
  • Interests:2d gfx<br />c#/xna development
  • Devices:HTC Mozart, Sony Ericsson X10
my cab already sets it to COLOR_alertWINDOW, always has, but the problem looks like its as simple as a missing comma, it worked on the first version of this cab, but something went wrong for the second version, anyways, just cabbed another version if someone wishes to try it

  • 0

#29
StarfireCT

StarfireCT

    Newbie

  • Members
  • Pip
  • 24 posts

my cab already sets it to COLOR_alertWINDOW, always has, but the problem looks like its as simple as a missing comma, it worked on the first version of this cab, but something went wrong for the second version, anyways, just cabbed another version if someone wishes to try it


Actually, if this is the same CAB that I got like a night or two ago, it didn't have that setting. What I did was extract the _setup.xml file from the CAB file on a PC and looked to see what was changing. The BKUnselected value that I saw in there told the registry to set it to "".

The way I built my CAB was by using a /postxml switch with the same basic XML that I found in that _setup.xml file - I didn't set the registry settings in the .INF file because I found that to be more cumbersome.

Of course, the other problem might have nothing to do with this or I might have gotten an older version - I'm just letting you know what made it into the CAB file that I originally downloaded... if it helps, I can send ya the CAB or _setup.xml that I got...

Cheers!

  • 0

#30
midnight

midnight

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 3,651 posts
  • Gender:Male
  • Location:Lancashire
  • Interests:2d gfx<br />c#/xna development
  • Devices:HTC Mozart, Sony Ericsson X10
its cos when it built the cab from the inf there was a missing comma like i said, so cabwiz removed that setting (and set it as blank in the compiled cab cos thats all it could do), makes no difference either way, its fixed now i hope

  • 0

#31
StarfireCT

StarfireCT

    Newbie

  • Members
  • Pip
  • 24 posts
Ah cool - tis all good. Thanks for coming up with and maintaining the CAB: it saves a lot of tapping with the registry editor :)

  • 0

#32
JoelRae

JoelRae

    Diehard

  • Members
  • PipPipPipPip
  • 401 posts
  • Location:London UK
  • Devices:SPV C500
Yep, worked like a charm. Thanks again Mid :)/

  • 0

#33
mon_nom_est_arnaud

mon_nom_est_arnaud

    Newbie

  • Members
  • Pip
  • 45 posts
Help please !
I've installed this CAB and rebooted my SPV (ROM Orange FR 1.3.6.5) twice. Extra screens (Info, Exclamation...) are now as normal, but the Programs menu background is still white without any gradient !

  • 0

#34
tanny

tanny

    Newbie

  • Members
  • Pip
  • 27 posts

Help please !
I've installed this CAB and rebooted my SPV (ROM Orange FR 1.3.6.5) twice. Extra screens (Info, Exclamation...) are now as normal, but the Programs menu background is still white without any gradient !



Remove the BKBitmapFile from HLMSoftwareMicrosoftShellRai:MSStart

midnight - can you make the 'reset' remove the BKBitmapFile (as for MSStart and MSCONTACTS) instead of assigning "" as the value? many thanks.

  • 0

#35
midnight

midnight

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 3,651 posts
  • Gender:Male
  • Location:Lancashire
  • Interests:2d gfx<br />c#/xna development
  • Devices:HTC Mozart, Sony Ericsson X10
You cant actually remove reg keys using a cab as far as i'm aware, only change them so they are blank

however, i do have an idea, which i'll work on, which should hopefully fix the problem

  • 0

#36
midnight

midnight

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 3,651 posts
  • Gender:Male
  • Location:Lancashire
  • Interests:2d gfx<br />c#/xna development
  • Devices:HTC Mozart, Sony Ericsson X10
and the answer is, no, cant be done as far as i can tell

dont forget, you should always use 'Remove Programs' on any homescreen that uses extra screens before installing another that does the same, it solves this problem before it even occurs and so no need to run this homescreen reset cab.

  • 0

#37
Disco Stu

Disco Stu

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 8,184 posts
  • Location:Coventry, UK
  • Interests:techno, Leeds United
  • Devices:HTC Touch Dual / SPV E650
Just for the sake of formailty..ahem..can you confirm this works for WM2003 ?

  • 0

#38
midnight

midnight

    Hardcore

  • Members
  • PipPipPipPipPipPip
  • 3,651 posts
  • Gender:Male
  • Location:Lancashire
  • Interests:2d gfx<br />c#/xna development
  • Devices:HTC Mozart, Sony Ericsson X10
i cant see why not, the reg keys are all the same :lol:

  • 0

#39
ultimasnake

ultimasnake

    Addict

  • Members
  • PipPipPipPipPip
  • 758 posts
  • Location:Amsterdam Holland
  • Interests:Programming<br />Gaming<br />Woman :P
  • Devices:Imate JAM/Orange E200
it works alright :lol: midnight has done a great job on it :D

  • 0
Current Project :
Smart commander
Great new application to control your pc

Smart Browser the (first) PIE alternative
Click here for the official website

Try some other great free software like :
Gaydar
Homers Bar Quotes
Erotic dice

and soon more at ultimasoftware

#40
badboy4life

badboy4life

    Diehard

  • Members
  • PipPipPipPip
  • 305 posts
I just installed this on my phone(e200) and got the pink square around the icon image, looking at the original settings on my old spv i found that the 'BKBitmapTransparent' value needs to be set to '16711935' and the pink bits disappear and so your left with a background set to the COLOR_alertWINDOW and the icon without the pink bit!!!

  • 0
A man does what he can, until his destiny is revealed




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users