Jump to content
PaulOBrien

30/Jun r5 - MoDaCo Custom ROM for GSM Hero now with Online Kitchen - Android 2.1

Recommended Posts

what is the perfect partition table ?

i am still on mcr 3.2 and i like to install mcr 4. i read loads of posts but i cannot find the perfect partition table for the sd card.

i got fat32 (rest), ext3(512 mb) for app2sd ( ext2 should be better cos there is no journaling ??? is that right ? is it faster ?)

and a 32 mb swap ( question: is a swap partition still needed for mcr 4 ? do 2.1 costum roms use swap anyway ? )

with the 2.6.27-mck-teknologist-1.91 kernel from mcr 3.2, swap is not needed anymore. see (in the first post):

http://android.modaco.com/content/htc-hero...p-for-gsm-hero/

so what is recommended for mcr 4 ?

Edited by flushy4

Share this post


Link to post
Share on other sites

I'm wondering what the SIM Toolkit is and what it's used for. On my system, I only see a Roam/INTL option and two other options when I select it: INTL1 and INTL2. What is that?

Share this post


Link to post
Share on other sites

Finally, everything is OK.

We deeply apologize, but I used to point the wrong file for the update. :)

And now I'm MCR4 Build3.

I look forward to the patch and the final version.

Thank's ¨Paul for your great job :)

Share this post


Link to post
Share on other sites

I am using the clock on my home screen which has the weather on it, but the weather isn't being displayed.

I'm probably haven't done something blindingly obvious, but is there a certain setting I need to turn on for that to update or simply just display?

Share this post


Link to post
Share on other sites
I'm wondering what the SIM Toolkit is and what it's used for. On my system, I only see a Roam/INTL option and two other options when I select it: INTL1 and INTL2. What is that?

The SIM Toolkit enables you to access Operator specific functions from the SIM card. In my case I have Domestic and International as the only choices. I have to choose International from here for my phone to work outside Scandinavia.

Other operators include shortcuts to e.g. top up your prepaid account or check your remaining balance from here (often using SMS messages in the background). It differs a lot between operators

In your case it's probably to enable international roaming. Ask your operator for details.

Share this post


Link to post
Share on other sites

Thank you very much Paul.

Wiped everything (really everything: data, dalvik, ext, battery, sensor), installed from kitchen with A2SD+ and EVERYTHING is running smooth and fast.

Wonderful.

More information: I have 1 GB ext2 partition in a 16 GB Class 2 (yes, you read correctly, class 2 Card from Sandisk), and the speed is fantastic, no lags at all.

Performed then a TitaniumBackup and had all my apps and setting runnin' 30 mins. after installing your ROM.

GREAT

Share this post


Link to post
Share on other sites
I am using the clock on my home screen which has the weather on it, but the weather isn't being displayed.

I'm probably haven't done something blindingly obvious, but is there a certain setting I need to turn on for that to update or simply just display?

Mine worked out the box, have you tried opening the weather section and making sure Automatic Download is enabled. Also in the clock i think theres an option to use your location, maybe make sure thats checked?

----------------------------

Also: I have been using the chinese radio this ROM came with but tbh it sucks on T-Mobile, at least for me (home and work), so have gone back to the older radio. This gives me consistently better reception and data connection. If anyone else does it be warned it took a godly amount of time to restart after installing, I thought I broke something, easily 5 minutes on the HTC screen and maybe another 5 once it had booted to get back to normal speed, since thought it has been perfect. Havent tried another reboot but even if it did take a while I would prefer that & better signal

Network: T-Mobile UK

Share this post


Link to post
Share on other sites

i've got some problem when i connect my phone via USB...it charge my battery and say that debugUSB is connected but i can't mount sd as an hard drive or sync...

how i can solve it?? thanks

Share this post


Link to post
Share on other sites
Also: I have been using the chinese radio this ROM came with but tbh it sucks on T-Mobile, at least for me (home and work), so have gone back to the older radio. This gives me consistently better reception and data connection. If anyone else does it be warned it took a godly amount of time to restart after installing, I thought I broke something, easily 5 minutes on the HTC screen and maybe another 5 once it had booted to get back to normal speed, since thought it has been perfect. Havent tried another reboot but even if it did take a while I would prefer that & better signal

Network: T-Mobile UK

+1 here.

I'm another T-Mobile UK user and I have reverted my radio too. I'm hoping the radio that ships with the EU version later this month proves a little better. In saying that though, there really isn't anything wrong with the radio that comes with MCR 3.2!

Share this post


Link to post
Share on other sites
i've got some problem when i connect my phone via USB...it charge my battery and say that debugUSB is connected but i can't mount sd as an hard drive or sync...

how i can solve it?? thanks

When you plug in it should request what you want to do with it, there's an option for sync or storage.

Share this post


Link to post
Share on other sites
+1 here.

I'm another T-Mobile UK user and I have reverted my radio too. I'm hoping the radio that ships with the EU version later this month proves a little better. In saying that though, there really isn't anything wrong with the radio that comes with MCR 3.2!

I'm a T-Mobile UK user (with a G2 touch) and the new radio has improved my signal quite considerably (wi-Fi, Mobile and GPS lock time). Strange so many people are seeing such varied results

Share this post


Link to post
Share on other sites
When you plug in it should request what you want to do with it, there's an option for sync or storage.

i know...this option is also in settings but it doesn't show.... :)

Share this post


Link to post
Share on other sites

I am using RA-hero-v1.3.2 and tried flashing a APPS2SD version of this ROM. I wiped data/cache/dalvik-cache/SD:ext and then did a flash. I am now getting reboot loops on the "HTC Quietly" screen. A adb log cat is posted at http://pastebin.ca/1881115

Appreciate if someone could advise on what to try next.

Thanks,

D.

Share this post


Link to post
Share on other sites

I have an unusual problem with the tuch screen, it's really non responsive, don't register touches correctly more like it has it's own life. I have wiped a couple of times, dalvik and sd to. Tried apd2 and non aps2sd, formated sd-card, partitiond and non partition. It won't go away. I'm using lates realease and have not the same problem with other roms.

Would be very thankful for clues.

Share this post


Link to post
Share on other sites
I am using RA-hero-v1.3.2 and tried flashing a APPS2SD version of this ROM. I wiped data/cache/dalvik-cache/SD:ext and then did a flash. I am now getting reboot loops on the "HTC Quietly" screen. A adb log cat is posted at http://pastebin.ca/1881115

Appreciate if someone could advise on what to try next.

Thanks,

D.

Update with the current version Amon Ra v1.6.2. No problem to flash afterwards.

Try it.

Share this post


Link to post
Share on other sites
I have an unusual problem with the tuch screen, it's really non responsive, don't register touches correctly more like it has it's own life. I have wiped a couple of times, dalvik and sd to. Tried apd2 and non aps2sd, formated sd-card, partitiond and non partition. It won't go away. I'm using lates realease and have not the same problem with other roms.

Would be very thankful for clues.

This happened to me the first time I flashed a 2.1 ROM. Some areas of the screen were completely unresponsive, and other times the screen just went haywire without even touching it! I nandroided back to a MCR 3.2 and found it was a little better but now and then the screen would just be unusable.

Read through a few forums and the general consensus was that I had developed a hardware fault! However, it seems to have settled down now and I don't have any issues anymore. Not really sure what the fix was :/

Share this post


Link to post
Share on other sites
Update with the current version Amon Ra v1.6.2. No problem to flash afterwards.

Try it.

Thanks for help but no luck. Updated to 1.6.2 and then wiped everything again and reflashed. Same reboot loop.

Share this post


Link to post
Share on other sites
Thanks for help but no luck. Updated to 1.6.2 and then wiped everything again and reflashed. Same reboot loop.

Look through the logcat output it seems like plurk that is causing it to bork. I will try and bake a ROM without it and see how it goes.

Share this post


Link to post
Share on other sites
Guest

Is there a conclusive answer regarding whether it's ok to use Orange (UK) branded handsets and the new radio together?

Share this post


Link to post
Share on other sites
Look through the logcat output it seems like plurk that is causing it to bork. I will try and bake a ROM without it and see how it goes.

Taking plurk out of the ROM sorted it.

@Paul : There may be an issue with plurk in the ROM. I submitted logs above.

Share this post


Link to post
Share on other sites
The radio has made a massive difference on my T-mobile G2, very happy :)

same here in Italy on H3G

Share this post


Link to post
Share on other sites

I am very satisfied with this rom. :) Can't wait till the european version is comming out. :) I have one problem so far: Menu -> settings -> applications -> manage applications => causes FC "The application Settings (process com.android.settings) has stopped unexpectedly. Pleasy try again." Does anyone have the same problem?

Share this post


Link to post
Share on other sites

I understand that this ROM is de-ODEX'd so that themes can be applied, but isn't ODEX faster/more efficient?

My dilemna is that the original 2.1 release is ODEX'd while the newer builds are not. If I stick with the original (which works fine for me) because I prefer ODEX'd, then I will not be upgrading at all in the future when a better kernel, etc. are released.

Edited by venturerider

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.