Jump to content

Stuck on HBoot

Recommended Posts


I have a Vodafone UK Magic


HBOOT-1.33.0007 (SAPP10000)



Jul 31 2009,15:49:25

It's not been rooted or had any custom ROM's etc.

It got a bit wet in the rain last weekend and now when I turn it on it's just stuck on the HBoot screen. I can't press 'back' for FastBoot or scroll down. No keys respond. I also can't boot into Fastboot with power + menu or any other combo.

I tried retrieving the rom.nbh from some official RUU's and putting them on the SD card. The phone picked them up and asked if I wanted to update etc. I did but didn't make any difference. Tried another rom.hbh and now when it picks it up some text flies by and nothing else happens & I'm stuck again.

Any ideas?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

By using this site, you agree to our Terms of Use.