Jump to content
Sign in to follow this  
PaulOBrien

[OLED] 06/Dec r4: MoDaCo Custom ROM (MCR) downloads + Online Kitchen

Recommended Posts

"sorrowuk" You raise an interesting point regarding hardware acceleration and it's impact on responsiveness.

I noticed my keyboard being really slow so went into settings for a mess about, thought "I don't want to turn off hardware acceleration cos surely that MUST improve things" but hey-ho I turned it off and now there is ZERO lag on my keyboard inputs aka I can type really fast (with word predictions etc).

So my point is, perhaps this hardware acceleration IS doing more harm than good? I have nothing to compare to but it seems you do.

Other's thoughts?

How did you turn it off?

Share this post


Link to post
Share on other sites

Sebastian404's ROM seems to be slightly snappier and has less random skipping when it comes to music playback I've noticed (stock wasn't terrible but lacked the snappiness). But then these problems only came up with the release of R3; I never used R2 but there didn't seem to be any complaints regarding CPU spikes/high CPU usage or music skips. I tried R3 and R4 without Hardware Acceleration and still get the same problems with random skips during music playback.

Edited by Evil Disco Guy

Share this post


Link to post
Share on other sites

Same here, i never used r2 but found R3 very laggy. Since then i have gone baked a stock ROM without the orange junk and its much better.

Share this post


Link to post
Share on other sites
Same here, i never used r2 but found R3 very laggy. Since then i have gone baked a stock ROM without the orange junk and its much better.

any chance we could see your rom?

Share this post


Link to post
Share on other sites
People should try Sebastian404's de-orangeated Rom r4 here - http://android.modaco.com/content/zte-blad...-san-francisco/

I found it alot alot faster than this Modaco custom rom. Much smoother, less crashes and no random reboots.

I think people should make their own minds up. No complaints from Paul's ROMs only compliments, good job Paul

Share this post


Link to post
Share on other sites

Touchpal settings.

Touchpal Input > Hardware Prediction.

When I unticked there was no lag.

I have switched to SlideIT since though, and am eagerly awaiting BlindType!

Share this post


Link to post
Share on other sites
Touchpal settings.

Touchpal Input > Hardware Prediction.

When I unticked there was no lag.

I have switched to SlideIT since though, and am eagerly awaiting BlindType!

My phone doesn't have the "Touchpal Input > Hardware Prediction" in the Touchpal settings.

Share this post


Link to post
Share on other sites
Where in setting is "hardware acceleration"? I want to try it on & off, to see if it does make any difference.

Its an option in the Online Kitchen. You'll need to subscribe to use this feature.

You can edit build.prop and set debug.sf.hw=0 also.

Share this post


Link to post
Share on other sites

Does anyone here still have the original mcr3.tar.gz file as it appears to have been removed, and i dont want to use clockworck recovery right now would prefer mcri method as i did this twice already

Thanks

Share this post


Link to post
Share on other sites

Hi, can anyone confirm the version of A2SD in R4

Is it Darktremor Apps2SD Version 2.7.5.2

I find the current Darktremor Apps2SD Version 2.7.5.1 and R3 causes it to not mount about 80% of the time.

This means Once my phone is started - its a pain to reboot - as I have to have the time to go through the clockworkmod screen and try to remount + reboot over and over.

Looking at all the A2SD threads, other people have this too. I assume its a race condition in /etc/init.d and that it just luck that gets it right.

Can anyone who knows the internals of A2SD look into this? or has R4 fixed it?

Share this post


Link to post
Share on other sites

In Settings->About Phone->Status, on the bottom of the page I have "Up time" but no "Awake time". Is this just me or everybody? I'm still on R3.

Edited by salazared

Share this post


Link to post
Share on other sites
Hi, can anyone confirm the version of A2SD in R4

Is it Darktremor Apps2SD Version 2.7.5.2

I find the current Darktremor Apps2SD Version 2.7.5.1 and R3 causes it to not mount about 80% of the time.

This means Once my phone is started - its a pain to reboot - as I have to have the time to go through the clockworkmod screen and try to remount + reboot over and over.

Looking at all the A2SD threads, other people have this too. I assume its a race condition in /etc/init.d and that it just luck that gets it right.

Can anyone who knows the internals of A2SD look into this? or has R4 fixed it?

Dude i got exactly the same problem....tried so many time but evrytime something goes wrong......

Share this post


Link to post
Share on other sites
Its an option in the Online Kitchen. You'll need to subscribe to use this feature.

You can edit build.prop and set debug.sf.hw=0 also.

Sorry to have to ask for it spelt out...

I found build.prop in /system on my phone.

If I change this then reboot does it turn off hardware acceleration?

Thanks

Share this post


Link to post
Share on other sites
@ Paul

got an interesting problem!

just rooted and flashed the mcr rom with Apps to SD on reboot what i'm getting is a boot loop at the modaco logo, re flashed about three times before i took out the sd card , with this gone it rebooted fine.

Now this sd is the old 8gig card from my old hero with a 512 meg ext2 partition formatted using Amon Ra's recovery img (forget the number) now this is my problem how do i get to re format the card to work with the SF? cant reformat with the hero as it took a nasty fall.

Using clockwork's option to format sd-ext i get this:-

E:cant mount /dev/block/mmcblk0p2

(file exits)

Error mounting /sd-ext/!

skipping format...

done.

any help would be great as i'm really missing my storage/a2sd. at the mo stuck with the stock 2gig card and no idea how to get a new partition. can follow instructions well enough, just got very lost with installing a gparted live cd iso on my laptop! so stalled for ideas now.

cheers in advance

In the sage words of Penelope Pitstop "Heyelp Heyelp!

Share this post


Link to post
Share on other sites
In Settings->About Phone->Status, on the bottom of the page I have "Up time" but no "Awake time". Is this just me or everybody? I'm still on R3.

I haven't put a custom rom on yet and can't find awake time either so it's not the MCR doing it.

Share this post


Link to post
Share on other sites

Flashed R4 last night with A2SD and it's working great - loads of memory free now!

Thanks to Paul for the (hopefully ongoing) work on this device.

I still can't believe how good the SF is considering the price.

Share this post


Link to post
Share on other sites

Hmm subscribed for the online kitchen, but cannot see the option to turn the HW acceleration off. Where do I find it?

Its an option in the Online Kitchen. You'll need to subscribe to use this feature.

You can edit build.prop and set debug.sf.hw=0 also.

Share this post


Link to post
Share on other sites
I haven't put a custom rom on yet and can't find awake time either so it's not the MCR doing it.

Thanks turnpike.

Okay, so I take it this is Orange's/ZTE's doing? It seems odd that it isn't there, but really I just wanted to know if my phone was sleeping properly (pretty sure it wasn't) so does anybody have another way of diagnosing this?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.