Jump to content
Sign in to follow this  


Recommended Posts

I tried to flash metal ROM 1.001.02 to my liquid S100. After AMSS or so the phone showed not connected in the acer download tool. I removed the USB, tried to switch phone on.


1. The phone does not switch on(Black Screen as when switched off)

2. Does not boot into recovery by the button combo...Power, volume, camera

3.No use trying malez recovery or superboot from computer end...It does not recognize device..Though, I have all the acer drivers installed.

4.Acer download tool does not recognize the phone anymore and says not connected everytime I try to reflash the earlier working Bin.

5.I have tried all the basic steps of removing battery, usb etc.

6. When I connect the phone to charger, still the screen remains black(as when switched off)...No sign of any activity..


[email protected]

Edited by amolb

Share this post

Link to post
Share on other sites

Hello, have a look on that :



This one in French (FR Liquid Reference forum :()... http://www.acer-android.fr/flasher-desimlo...-mode-t544.html

Google translator if needed...

hope it will work fine for you...


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


Important Information

By using this site, you agree to our Terms of Use.