Jump to content

UNIQUELY-BRICKED LIQUID A1


Guest amolb
 Share

Recommended Posts

Guest amolb

I tried to flash metal ROM 1.001.02 to my liquid S100. After AMSS or so the phone showed not connected in the acer download tool. I removed the USB, tried to switch phone on.

BUT

1. The phone does not switch on(Black Screen as when switched off)

2. Does not boot into recovery by the button combo...Power, volume, camera

3.No use trying malez recovery or superboot from computer end...It does not recognize device..Though, I have all the acer drivers installed.

4.Acer download tool does not recognize the phone anymore and says not connected everytime I try to reflash the earlier working Bin.

5.I have tried all the basic steps of removing battery, usb etc.

6. When I connect the phone to charger, still the screen remains black(as when switched off)...No sign of any activity..

WHAT TO DO GUYS...PLEASE HELP..

[email protected]

Edited by amolb
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.