Jump to content
jambezuk

Android System - Huge background data usage

Recommended Posts

i just found out that it is screencapture.apk ...

what the hell ... :unsure: :)

20110517205747.png

Edited by 75markus

Share this post


Link to post
Share on other sites

I suspect the statistics are wrong. The totals don't add up.

I've just disabled all outgoing traffic on my router, and i'm not seeing anywhere near enough blocked requests in the firewall logs to support that volume of traffic.

1KB /s is about 500 blocked requests a second. I've seen ~ 20 requests to google, amazon, cachefly and akamai technologies. All reputable.

John

Share this post


Link to post
Share on other sites

following this with great interest. somebody at xda once suggested the 0 process could be processes with root privileges.. not sure if that makes sense. network location could be a better guess.

if you google for it you'll find more people have the same issue on different handsets but I don't tgink anybody cleared up what it really is..

Share this post


Link to post
Share on other sites
I suspect the statistics are wrong. The totals don't add up.

I've just disabled all outgoing traffic on my router, and i'm not seeing anywhere near enough blocked requests in the firewall logs to support that volume of traffic.

1KB /s is about 500 blocked requests a second. I've seen ~ 20 requests to google, amazon, cachefly and akamai technologies. All reputable.

John

I'm starting to suspect the same thing but can anyone else confirm this with online billing, checking data usage against phone's readouts?

I'd sign up for online billing right now but I'm not at home and don't have my a/c number!

James

Share this post


Link to post
Share on other sites
following this with great interest. somebody at xda once suggested the 0 process could be processes with root privileges.. not sure if that makes sense. network location could be a better guess.

if you google for it you'll find more people have the same issue on different handsets but I don't tgink anybody cleared up what it really is..

In android, every app runs as a different user, so that apps cannot access each others data.

In unix, users have a user identifier. So user "app_9" could have a uid of 10008 (for example)

So you have mapping of uid -> user -> app

Spare parts displays the app usually. I guess if it can't find the app associated with the uid, it just displays the uid.

uids < 10000 are reserved for system.

you can find these in android_filesystem_config.h

The uid of 0 is always root though

John

Share this post


Link to post
Share on other sites

sorry if this is a noob question but does that mean: some process running with root privileges uses the most data on my phone, and if so, should i worry? i am new to android so i really don't know much about it.

Share this post


Link to post
Share on other sites

Any news on this? Flashed fr17 from stock (wiped of course) and i'm getting the exact same thing, as soon as i turn on 3g the up-down arrows appear and start blinking. I have the same "0" app consuming traffic.

What can i do?

Cheers!

Share this post


Link to post
Share on other sites
Any news on this? Flashed fr17 from stock (wiped of course) and i'm getting the exact same thing, as soon as i turn on 3g the up-down arrows appear and start blinking. I have the same "0" app consuming traffic.

What can i do?

Cheers!

At the moment I think the general opinion is that the data is inaccurate :P I guess hold on till it's proved either way. There are a few of us in the same boat.

Share this post


Link to post
Share on other sites
so i am on cm7 now and i still face this problem, any news?

Same boat... I suspect it's just bad data as previously concluded. Battery life is 'as expected' with CM7 certainly for myself, despite the apparently large data consumption.

Share this post


Link to post
Share on other sites

I have the same "0" process before, and accidentaly when i re-bake the FR18 without SQL tweak , the "0" process is gone...

Could anyone claify on this as well.. right now... i am checking is the Battery life better off without SQL tweak....

Edit : Sorry it is not related to SQL hack..... will test again

Edited by simon_als

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.