Jump to content
voyteckst

[STOPPED] CyanogenMod Beta2 Omnia 2 (updated: 04.05.2012)

Recommended Posts

the init.rc file on the root folder? or the init.rc in the ext4.tar.gz ? (im using windows so that last file is not an option...)

i think the market error has something to do with that i dont have wifi connection... i am connected to my router though but i cant get on internet with the browser...

there was a topic or reply somewhere here that discussed this problem... but i cant find it:(

and i also cant find the init.rc thing.. ye i can find somehting that contains "init.rc" but not one that contains the code that i have to change..

EDIT: im reinstaling android now.. i formatted my sd card again and made 2 partitions of 2 gb. the first one set as primary: FAT32 and the second one as logical: ext4,

but when i click the androidinstall.exe from the o2beta folder somewhere in the code it says: sd card moutend, sd card empty and then it says that the partitions are to small and failed to copy files to it... wut?!?

The answer to the wi-fi trouble is In the 1st post of the topic... Mr.Voyteckst is editing the post whenever the news or solutions come up =)

But i think that You will need to starr using ubuntu for this

Share this post


Link to post
Share on other sites

The answer to the wi-fi trouble is In the 1st post of the topic... Mr.Voyteckst is editing the post whenever the news or solutions come up =)

But i think that You will need to starr using ubuntu for this

yes i am considering windows - ubuntu dualboot cuz windows just sucks and it takes to long to boot etc... and all my school stuff works on ubuntu.. but i dont have time to set it now.. meby in the holidays:)

the wifi problems and things dont bother me atm.. the only thing is:

when i try to reinstall froyo it says that my sd is not found or something... xD why it worked for for the first time and not now? i set the same partitions etc!

but i think the only way to edit the init.rc is in ubuntu right?

Share this post


Link to post
Share on other sites

yes i am considering windows - ubuntu dualboot cuz windows just sucks and it takes to long to boot etc... and all my school stuff works on ubuntu.. but i dont have time to set it now.. meby in the holidays:)

the wifi problems and things dont bother me atm.. the only thing is:

when i try to reinstall froyo it says that my sd is not found or something... xD why it worked for for the first time and not now? i set the same partitions etc!

but i think the only way to edit the init.rc is in ubuntu right?

My windows mobile boots a ton quicker then my android boots. I use an custom rom. Boot takes around 40 seconds.

Share this post


Link to post
Share on other sites

i think i solved the wifi problem.. <br>but what rests now is: I can't import contacts from my SIM card.. (this didnt work anymore when i reinstalled froyo)<br>so my main concern are my contacts.. otherwise its just useless<img src="http://www.modaco.com/public/style_emoticons/default/tongue.gif">

<div><br></div><div><br></div><div>EDIT: finally.. dunno how i did it but contact are in:D the market works also so im happi again<img src="http://www.modaco.com/public/style_emoticons/default/laugh.gif" alt=":lol:" class="bbc_emoticon"></div>

Edited by shockwavenl

Share this post


Link to post
Share on other sites

the init.rc file on the root folder? or the init.rc in the ext4.tar.gz ? (im using windows so that last file is not an option...)

i think the market error has something to do with that i dont have wifi connection... i am connected to my router though but i cant get on internet with the browser...

there was a topic or reply somewhere here that discussed this problem... but i cant find it:(

and i also cant find the init.rc thing.. ye i can find somehting that contains "init.rc" but not one that contains the code that i have to change..

EDIT: im reinstaling android now.. i formatted my sd card again and made 2 partitions of 2 gb. the first one set as primary: FAT32 and the second one as logical: ext4,

but when i click the androidinstall.exe from the o2beta folder somewhere in the code it says: sd card moutend, sd card empty and then it says that the partitions are to small and failed to copy files to it... wut?!?

Autoinstaller will create partition for you. All you need to do is format the sd card as FAT32 (i do primary), then run androidinstall.exe from my storage (which will reduce the size and add a 1GB ext4 partition. Android should work fine and it should mount the FAT32 SD card (If it shows SD card mounted but does not show up on pc connection, then reboot)

If you want to mount My Storage as /mnt/sdcard and SD card as mnt/sdcard_REAL then read this comment from vakaloka (modify your init.rc in root folder - remember to remove hash).

1º As you will probably want to mount your sd in other folder, change this line in init.rc:export EXTERNAL_STORAGE /mnt/sdcard

With this one:

export EXTERNAL_STORAGE /mnt/sdcard_REAL

2ºChange this line in the same file(init.rc)

mount vfat /dev/block/mmcblk1p5 /storage

With this other:

mount vfat /dev/block/mmcblk1p5 /mnt/sdcard

3º Probably that will do the trick.Save and restart. The internal storage will be mounted to sdcard, and will be recogniced as if it were a sdcard by media players. The original sdcard will be mounted to sdcard_REAL. If you can't get it working, modify the 5 in red with the number of the FAT32 partition.

Edited by AoSra1n

Share this post


Link to post
Share on other sites
Could someone goto LauncherPro>Settings>BackupSettings and tell me if notice any error?

Here's the error: "An error ocurred while trying to create the Backup. Please make sure the SD card is available."

Devs, take a look, here's what i did:

/mnt/sdcard was working fine but launcher pro was looking at /sdcard to save the settings, and this folder was empty:

- Development Tools > Terminal

$ su

$ ls /sdcard

(no results, was empty)

So i tried run this command that is in init.rc

$ symlink /mnt/sdcard /sdcard

(but Android does not recognizes symlink command, so here's what i did:

$ rm -r /sdcard

(it was a empty folder and i had to delete so i could create a new shortcut)

$ ln -s /mnt/sdcard /sdcard

(this SOLVED the problem, now LauncherPro can find the LauncherPro folder in /sdcard to save the settings)

.

This line in init rc should work, but maybe LauncherPro doesn't use this:

export EXTERNAL_STORAGE /mnt/sdcard

Like i said, /mnt/sdcard was working fine but LauncherPro was looking at /sdcard that WAS EMPTY.

Seems that this line isn't working:

symlink /mnt/sdcard /sdcard

.

I'm just sharing what happened and how i solved it,

cheers.

Share this post


Link to post
Share on other sites

I have managed to install it automatic on my sd card. The important thing is that de sdcard must be format ass FAT32 PRIMARY, so you can see your sd card.

Everything works great, EXCEPT one thing and very important, after a copple off hours i can't make a phonecall or sms.

But the rest is ok. Iff taht bug is fix we have a very good and daily use android, that runs very fast.

Thanks and hope that the bug will be fix.

Good Job to the dev's

Share this post


Link to post
Share on other sites

Autoinstaller will create partition for you. All you need to do is format the sd card as FAT32 (i do primary), then run androidinstall.exe from my storage (which will reduce the size and add a 1GB ext4 partition. Android should work fine and it should mount the FAT32 SD card (If it shows SD card mounted but does not show up on pc connection, then reboot)

If you want to mount My Storage as /mnt/sdcard and SD card as mnt/sdcard_REAL then read this comment from vakaloka (modify your init.rc in root folder - remember to remove hash).

1º As you will probably want to mount your sd in other folder, change this line in init.rc:export EXTERNAL_STORAGE /mnt/sdcard

With this one:

export EXTERNAL_STORAGE /mnt/sdcard_REAL

2ºChange this line in the same file(init.rc)

mount vfat /dev/block/mmcblk1p5 /storage

With this other:

mount vfat /dev/block/mmcblk1p5 /mnt/sdcard

3º Probably that will do the trick.Save and restart. The internal storage will be mounted to sdcard, and will be recogniced as if it were a sdcard by media players. The original sdcard will be mounted to sdcard_REAL. If you can't get it working, modify the 5 in red with the number of the FAT32 partition.

all is working now. I formatted my whole 4gb sd card to fat32 and installed android and worked right away.

Your solution (or whateva it is) in editing the init.rc, will this solve the: sd card not mounted (or sd card not found) in the camera app?

if this isnt.. its useless to do this because it already workstongue.gif

another thing:

Its common that everyone has the "wifi sleep" bug, (i have it too...) but is there a way to fix this? (maybe editing something else in the init.rc?)

EDIT: i opened the init.rc using notepad but all the lines u have given me... i cant find them:( is this the wrong init.rc? (i got it from the ext4.tar.gz file..)

EDIT1: oh i that was the wrong one.. i found it now.. but how do i put this in the root map of android using windows? is that even possible? (i now use a copy of the init.rc in the root folder)

Edited by shockwavenl

Share this post


Link to post
Share on other sites

hi, guys...

thanks Dev for all the hard work. just wondering about the phone signal. when im on winmo, signal bar is max. but when i switch to android, signal goes to 1 bar to none. what can i do to fix that.

Share this post


Link to post
Share on other sites

all is working now. I formatted my whole 4gb sd card to fat32 and installed android and worked right away.

Your solution (or whateva it is) in editing the init.rc, will this solve the: sd card not mounted (or sd card not found) in the camera app?

if this isnt.. its useless to do this because it already workstongue.gif

another thing:

Its common that everyone has the "wifi sleep" bug, (i have it too...) but is there a way to fix this? (maybe editing something else in the init.rc?)

EDIT: i opened the init.rc using notepad but all the lines u have given me... i cant find them:( is this the wrong init.rc? (i got it from the ext4.tar.gz file..)

EDIT1: oh i that was the wrong one.. i found it now.. but how do i put this in the root map of android using windows? is that even possible? (i now use a copy of the init.rc in the root folder)

No solution to wifi sleep bug as yet.

You do not need to edit the init.rc file unless you want to change what is mounted (e.g. you want to mount My Storage instead of SD Card) - i havent edited it myself. IF you do want to edit it..it is located in root folder of android. Easy way is to edit it with android itself using an app called Root Explorer. Otherwise you can use ADB to push your new init.rc to android.

Simplest way for inexperienced users is to install QtADB which is a graphic user interface for adb. This allows you to install apk's from computer, interact with all your system files (copy to and from computer), get phone info, screenshot, logcat, ...etc

Instruction to install QtADB (for Windows choose Windows installers when downloading:

1. If you do not have Java Runtime Environment, install 32-bit JRE (AND 64-bit JRE if 64-bit operating system) from Java site. http://www.oracle.co...oad-440425.html

2. Install 32-bit JDK (AND 64-bit JDK if 64-bit operating system) from http://www.oracle.co...oad-440405.html

3. Install SDK Manager from http://developer.and.../sdk/index.html

4. Start SDK Manager and update Android SDK platform-tools Revision 5 and Google USB Driver Package, Revision 4

5. Connect your device with USB debugging enabled (Settings-->Application-->Development)

6. Start command prompt (cmd) and change to plaform-tools folder where you installed SDK Manager (cd C:\....\platform-tools). Then type adb devices and should get your device popping up. = success!

7. Download QtADB from http://qtadb.wordpress.com/download/ and extract QtADB and place somewhere (e.g. program files)

8. Download 'binaries for windows' from the same site http://qtadb.wordpress.com/download/ and extract somewhere (e.g. inside qtADB folder)

9. Open qtADB and it should ask to link with aapt file. Direct to 'windows binaries' folder and click okay.

10. Success, you can now install apk files from computer and access phone (plus much more!) - If you install an app called adbwireless from market, you can connect wirelessly to your device using QtADB.

Note : Your phone has to have USB debugging enabled.

Edited by AoSra1n

Share this post


Link to post
Share on other sites

Devs, take a look, here's what i did:

/mnt/sdcard was working fine but launcher pro was looking at /sdcard to save the settings, and this folder was empty:

- Development Tools > Terminal

$ su

$ ls /sdcard

(no results, was empty)

So i tried run this command that is in init.rc

$ symlink /mnt/sdcard /sdcard

(but Android does not recognizes symlink command, so here's what i did:

$ rm -r /sdcard

(it was a empty folder and i had to delete so i could create a new shortcut)

$ ln -s /mnt/sdcard /sdcard

(this SOLVED the problem, now LauncherPro can find the LauncherPro folder in /sdcard to save the settings)

.

This line in init rc should work, but maybe LauncherPro doesn't use this:

export EXTERNAL_STORAGE /mnt/sdcard

Like i said, /mnt/sdcard was working fine but LauncherPro was looking at /sdcard that WAS EMPTY.

Seems that this line isn't working:

symlink /mnt/sdcard /sdcard

.

I'm just sharing what happened and how i solved it,

cheers.

I never had this issue. LP backup works, SD card is shown properly with terminal command. Only issue ive faced with SD card is inability to move apps to it. I did autoinstall on blank Primary FAT32 SD card.

Edited by AoSra1n

Share this post


Link to post
Share on other sites

Hi guys,

I'm having trouble with Froyo manual installation on My Storage. It always freezes on the pink screen (if I'll use the other zImage the cursor will just freeze after few seconds).

Here's step by step of what am I doing: (I'm using 8GB Omnia 2)

1. Delete partitions of My Storage.

2. Create new partitions: 1GB primary ext4 and ~7 GB primary fat32.

3. Mount the ext4.tar.gz onto the ext4 partition.

4. Copy haret.exe, startup.txt and zImage to the root directory of My Storage.

5. Not sure what to change in startup.txt- I changed mmcblk0p2 to mmcblk1px, where x=1-7

6.Unplug my Omnia, launch haret.exe from My Storage

7. With default zImage I'm getting the pink screen and I waited like 15 mins and nothing happened. With the second zImage I can see the command line, but there's only cursor blinking for few secons and then it freezes.

Any idea what am I doing wrong?

Thanks

Share this post


Link to post
Share on other sites

Hi guys,

I'm having trouble with Froyo manual installation on My Storage. It always freezes on the pink screen (if I'll use the other zImage the cursor will just freeze after few seconds).

Here's step by step of what am I doing: (I'm using 8GB Omnia 2)

1. Delete partitions of My Storage.

2. Create new partitions: 1GB primary ext4 and ~7 GB primary fat32.

3. Mount the ext4.tar.gz onto the ext4 partition.

4. Copy haret.exe, startup.txt and zImage to the root directory of My Storage.

5. Not sure what to change in startup.txt- I changed mmcblk0p2 to mmcblk1px, where x=1-7

6.Unplug my Omnia, launch haret.exe from My Storage

7. With default zImage I'm getting the pink screen and I waited like 15 mins and nothing happened. With the second zImage I can see the command line, but there's only cursor blinking for few secons and then it freezes.

Any idea what am I doing wrong?

Thanks

Try creating logical partitions in My Storage and make sure startup.txt is SAME as the following. (But try differing mmcblk1px values if x=5 doesnt work)

Set kernel zImage

Set ramsize 180*1024*1024

Set mtype 1626

Set ramaddr 0x50000000

Set kernelcrc 1

Set CMDLINE "rootdelay=2 root=/dev/mmcblk1p5 init=/init console=ttySAC2,115200"

setbitp 0x7F008808 5 1

pfw 0x7f005800 4 0x3

pfw 0x7f005804 4 0x805

pfw 0x7f005808 4 0x7

pfw 0x7f00580c 4 0x0

pfw 0x7f005828 4 0x11

pfw 0x7f00582c 4 0x80

boot

Edited by AoSra1n

Share this post


Link to post
Share on other sites

Thanks, I changed the partitions to logical, but mmcblk1p5 didn't work. Is there a way to know what number to put in there or I'll just have to guess?

In Gparted, my extended partition is called sdd1, logical fat32 is sdd5 and logical ext4 is sdd6.

Oh, and just to make sure- the correct command to mount the ext4 files to the partition is: sudo tar zxvf ext4.tar.gz -C /media/android ?

Edit: mmclbk1p6 didn't worked to :(

Edit2: I think I forgot to mention I don't have SD card- I changed to mmcblk0p6 and it works :D

Edited by ULT1M4T3

Share this post


Link to post
Share on other sites

ok, i tried with the simcard of my dad and 3g works for me:) so im getting an 3g network sim this week.

the only thing that is bothering me:

Is it possible to change the hardware keys so that they have other functions?

oh meby not the only thing..

is it common that the battery does not charge beyond 90%? i charged it all night but when i switched on the screen i saw just 90%...

and now the last thing:

how can i change the top bar? i want it to be black... i found that topic with the manual but when i put the o2bupdate.tar.gz in the my storage, nothings changedmad.gif

Share this post


Link to post
Share on other sites

@UL1M4T3. Great, Its good that you solved it.

@shockwave.nl

To change hardware keys you have to edit /system/usr/keylayout/s3c-keypad.kl. The key number corresponds to key name. Haven't done it myself, but i believe the end call key is tricky to change because it is special. Please dont ask questions about key mapping, there are plenty of other threads on internet describing it. Google it.

I have battery issue as well. Not a huge issue. I can charge to 92-96%. But you can try turning device off and charging till full. Then turning on and go to android.

Obviously 02bupdate.tar.gz wont work. That is for a different beta. You have to do it manually (if have skills to create your own theme) as I dont know anyone who has created a dark theme for this beta (or any that work with this one).

Edited by AoSra1n

Share this post


Link to post
Share on other sites

ok meby the skin is a concern for later..

but how can i solve the problem of the camara that cant find the sd card? (and why it just dont save photo's on the my storage xD?)

EDIT:

btw i found the keymapping thing.. it isnt the file u said but it is this: system\usr\keylayout\qwerty.kl file.

and can i change this using the root explorer? or is it better to use the adb? (if i get that working..)

Edited by shockwavenl

Share this post


Link to post
Share on other sites

ok meby the skin is a concern for later..

but how can i solve the problem of the camara that cant find the sd card? (and why it just dont save photo's on the my storage xD?)

1º Make one PRIMARY partition in SD CARD whit FAT32 4Gb bigest don't work

2" Make other FAT32 Logical in MYSTORAGE all space

3º Putt automatic instalation in MYSTORAGE and t'hats all

This work for my 2 days formating installing and made me crazy but finally works!

  • Upvote 1

Share this post


Link to post
Share on other sites

@Hadesword,

thats what i did when installing android.. i made primary fat32 partition of 4 gb..

i did nothing to the mystorage but it was already fat32 format (according to windows)

and then i put the automatic installer on the mystorage and ran the installer.

I read in other topic that installing on my storage is for better performance.. maybe i should reinstall android then..

how do u do this?

seriously im getting sick and tired of this lol. but i want android on my phone so i keep goingbiggrin.gif

EDIT: i think i know how i install this then...

but how do i make a ext4 partition on my storage in windows? it looks like i cant do that...

and i think i have to use the manual installer then? and change the startup.txt?

Edited by shockwavenl

Share this post


Link to post
Share on other sites

ok meby the skin is a concern for later..

but how can i solve the problem of the camara that cant find the sd card? (and why it just dont save photo's on the my storage xD?)

EDIT:

btw i found the keymapping thing.. it isnt the file u said but it is this: system\usr\keylayout\qwerty.kl file.

and can i change this using the root explorer? or is it better to use the adb? (if i get that working..)

I agree with Hadesword method of installation if you want to install onto SD card.

use anything that can edit system files. But according to the dev its s3c-keypad.kl...link to his post here --> Voyteckst's Post

Share this post


Link to post
Share on other sites

yes i now know how to edit that keyboard file.

im willing to install android again so that EVERYTHING! (even the camera..) works.

but what happens with windows when i format the mystorage? it keeps working right? (without the programs)

and how do i do that? because minitool partion wizard does not see the mystorage. Do i have to do this in ubuntu live cd?

EDIT: i got my phone in mass storage mode now and i can format it.. but how do i have to do this?

just make primary ext4 of 1/2 gb and the rest as logical fat32?

then just make the storage card as logical fat32 and then camera can see it?

with the install i just do the same?(copy the files to my storage fat32 partition and run the androidinstall.exe?)

please respond asap so i can use my phone again (when using windows it just sucksbiggrin.gif)

EDIT2: btw, what is the "other" partition on the omnia 2? its 512mb precisely.. thats the windows partition right? so i must NOT format that?

EDIT3:

i found in the manual install of froyo (in the readme) this:

4. In startup.txt change this entry: root=/dev/mmcblk0p2 to Your android partition.

Note: mmcblk0 is now SD card, mmcblk1 is My Storage.

is the mmcblk1 correct? or is mmcblk0p2 correct? or do i have to use mmcblk0p5 (according to first post)?

the startup.txt on the mystorage is now mmcblk0p6 (hidden partion) btw.

Edited by shockwavenl

Share this post


Link to post
Share on other sites

ok guys....

For those people who needs automatic installer to my storage. this is running on ext2. i dont know how to change it to other ext. i used ritchietos bundle. thanks

instruction:

how to install

First make 2 primary partitions (not extended or logical) on my storage not sd.

partition 1 name it ''sdcard'' use fat32 (1024mb)

partition 2 name it ''system'' use ext2 (1024mb)

partition 3 name it "wmstorage" use fat32 (whatever is left.)

then extract all the files from (froyobundle) to the root of ''sdcard''

MAKE SURE YOU CHANGE THE STARTUP.TXT from mmcblk0p2 TO mmcblk1p2

Safely remove drive and first run haret from the npkinstall folder.

If your phone is rebooted run haret from the root of my storage

And enjoy.

http://www.megaupload.com/?d=IPYHB42E

if you have any problems whit android (run the npkinstall again it will auto format your ext2 partition)

Share this post


Link to post
Share on other sites

Was concerned about all the problems that people have with the new Froyo beta 2, but decided to take the plunge today....

Congrats to the Dev's on making the froyo much much faster, especially the download speed through the Android Market and the sync'ing of Google accounts (it took forever syncing contacts, calendar, etc. previously).

Everything seems to be working so far (wifi, 3G, etc.), and just doing a battery test now.

Thanks again for all the hardwork that the Dev's have put in!

Share this post


Link to post
Share on other sites

Hey, i have one problem, that sometimes it connection get lost and ask for pincode. Does anybody has the same problem and is there an app or solution for it?

Thanks and regards

Share this post


Link to post
Share on other sites

omg... why is everyone saying 1000 things? in every someone says something whole different when installing froyo on the mystorage...

so what is the good one? i think the one of radie works.. but why ext2 partition? when ext4 is faster?

and why everyone has different thoughts about the startup.txt? the one says mmcblk0p5 and when i look in other topic it is mmcblk1 or even mmcblk0p7mad.gif

EDIT:

my god.. its getting stranger and stranger.

now, what i did:

i have (according to minitool partion wizard) one partition of 1 gig as ext4 (named SDCARD)

and the rest is FAT32 partion. but somehow in the file manager of windows it says that there is only one partition and the mystorage grew to 8.3 gig and the "hidden" partition is shrinked to 200mb (or something..) i didnt do that??

and now windows does not see the mystorage anymore (yes i used: mount as mass storage device)

so how do i solve this?

EDIT2: LOL i restarted my device and now even the file explorer does not see the mystorage anymore XD what do i do? please help ASAP!sad.gif

EDIT3: i got it right somehow now... i made ext4 partition of 1 gig and a fat32 ptition of 6.3 gig . i only need to put the files on the ext4 partition but i cant mount it in windows (geei) so im downloading ubuntu 10.04lts and try it in live cd:)

Edited by shockwavenl

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.