Jump to content
tilal6991

[ICS] [CM9] [4.0.4] ColdFusionX for the ZTE Skate [ROM] [UPDATED - 28/06]

Recommended Posts

small suggestion,

put the linky to your github issues page on the first/second post.

as anyone who hasn't seen your link a few pages back will not know to write there

apart from that, great job. i haven't got any of the issues mentioned there on mine

Share this post


Link to post
Share on other sites

Couple of things.

1. Any issues from now on should be reported at github.com/ICSFusionX/android_device_zte_skate/issues

2. All issues have to have a logcat to go with them if you want me to fix the issue. No logcat = no fix.

i know you know about this so not gonna post it on github... Just curious roughly how long do you reckon till you can fix camera preview ??

cheers

Share this post


Link to post
Share on other sites

i know you know about this so not gonna post it on github... Just curious roughly how long do you reckon till you can fix camera preview ??

cheers

No idea.

Share this post


Link to post
Share on other sites

Couple of things.

1. Any issues from now on should be reported at github.com/ICSFusionX/android_device_zte_skate/issues

2. All issues have to have a logcat to go with them if you want me to fix the issue. No logcat = no fix.

Hi,

I've just did a logcat command on command prompt in my command window under Windows XP, and I see hundreds of lines of logcat reports and I don't have a clue what is needed for my specific problems... So do I just paste the whole thing from beginning to where I last stopped it or do I need to sieve through it to get a hold of the right logcat information / reports???...

1. My problems are I'm getting is my status bar notification power widgets aren't working perfectly, sometimes the mobiledata notification power widget doesn't to on / off colour position, it seems that I have to select different power widget to force the mobiledata power widget to show it's intended switch colour (although it looks as though it's still working functionally just the power widget colour doesn't change every time)...

2. Another is with the GPS, when the GPS is switched on and the "searching for GPS" notification appears (probably after launching MAPS), it seems that is doesn't want to disappear when I turn off GPS, some times I can get rid of it when I launch MAPS again turn off GPS, wait for notification to go, then exit MAPS, most of the times it just stays, which then I have to reboot with the GPS function turned off...

3. I also sometimes get the WiFi signal dropout and also have to turn off, wait a few seconds, then turn it back on... I had this problem on ICE Armour but much much much worse as it did it every time I leave the phone left on idle for X periods of time and only can get it back on when I go into the WiFi settings to turn it off / on... Also, another problem where the WiFi just can not be turned as the "error" message gets reported in the settings options and so have to reboot again...

So far as I haven't had bad battery drain when I leave the device idle with the screen off, it seems deep sleep is working for me (haven't got cpu spy installed)... This morning, I had my device on 100% and after coming home from a short trip to the hair dressers and Sainsburys the battery indicator was still at 100%, can only report that with use of the device the battery drain start to kick in, but that's how it is with my device, I get good / low battery drain / savings when in idle / deep sleep mode, and high / bad battery drain when I start using the Skate ( from light to heavy use )... I did notice sometimes the battery does drain a bit when leaving it on idle / deep sleep...However, I believe that is how it is, there is always battery drain when you have a battery plugged into any device (I stopped playing on my XBOX 360 for a few weeks and after I tried switching it one via my gamepad I found the battery was dead, hence battery drain)!...

Having a great time with this ROM build Tilal!!!... It's been running smoothly 90% of time and the other 10% is most probably when I switch the screen back on after a deep sleep, I'm just assuming the clocking up of CPU frequency is pretty stuttery after turning on the screen from a deep sleep mode... Well, I can't wait for the next ROM update build!!!... :D

I said this once before I will say again!... YOU'RE THE MAN OF SKATE PORTS, keep up the great work you provide for this community, without your contribution, this device would have died and left in the past of failed devices!...

:P

Share this post


Link to post
Share on other sites

2. Another is with the GPS, when the GPS is switched on and the "searching for GPS" notification appears (probably after launching MAPS), it seems that is doesn't want to disappear when I turn off GPS, some times I can get rid of it when I launch MAPS again turn off GPS, wait for notification to go, then exit MAPS, most of the times it just stays, which then I have to reboot with the GPS function turned off...

+ 1

Is there a way to turn it off, because it is not off, it searches for my location indoors all the time

Share this post


Link to post
Share on other sites

Hi,

I've just did a logcat command on command prompt in my command window under Windows XP, and I see hundreds of lines of logcat reports and I don't have a clue what is needed for my specific problems... So do I just paste the whole thing from beginning to where I last stopped it or do I need to sieve through it to get a hold of the right logcat information / reports???...

1. My problems are I'm getting is my status bar notification power widgets aren't working perfectly, sometimes the mobiledata notification power widget doesn't to on / off colour position, it seems that I have to select different power widget to force the mobiledata power widget to show it's intended switch colour (although it looks as though it's still working functionally just the power widget colour doesn't change every time)...

2. Another is with the GPS, when the GPS is switched on and the "searching for GPS" notification appears (probably after launching MAPS), it seems that is doesn't want to disappear when I turn off GPS, some times I can get rid of it when I launch MAPS again turn off GPS, wait for notification to go, then exit MAPS, most of the times it just stays, which then I have to reboot with the GPS function turned off...

3. I also sometimes get the WiFi signal dropout and also have to turn off, wait a few seconds, then turn it back on... I had this problem on ICE Armour but much much much worse as it did it every time I leave the phone left on idle for X periods of time and only can get it back on when I go into the WiFi settings to turn it off / on... Also, another problem where the WiFi just can not be turned as the "error" message gets reported in the settings options and so have to reboot again...

So far as I haven't had bad battery drain when I leave the device idle with the screen off, it seems deep sleep is working for me (haven't got cpu spy installed)... This morning, I had my device on 100% and after coming home from a short trip to the hair dressers and Sainsburys the battery indicator was still at 100%, can only report that with use of the device the battery drain start to kick in, but that's how it is with my device, I get good / low battery drain / savings when in idle / deep sleep mode, and high / bad battery drain when I start using the Skate ( from light to heavy use )... I did notice sometimes the battery does drain a bit when leaving it on idle / deep sleep...However, I believe that is how it is, there is always battery drain when you have a battery plugged into any device (I stopped playing on my XBOX 360 for a few weeks and after I tried switching it one via my gamepad I found the battery was dead, hence battery drain)!...

Having a great time with this ROM build Tilal!!!... It's been running smoothly 90% of time and the other 10% is most probably when I switch the screen back on after a deep sleep, I'm just assuming the clocking up of CPU frequency is pretty stuttery after turning on the screen from a deep sleep mode... Well, I can't wait for the next ROM update build!!!... :D

I said this once before I will say again!... YOU'RE THE MAN OF SKATE PORTS, keep up the great work you provide for this community, without your contribution, this device would have died and left in the past of failed devices!...

:P

grab alogcat and pastebin for android, both free on market, setup the pastebin account, run alogcat, press menu, press share, share with pastebin, it will copy your log to pastebin, press the option to paste, it will return a link, copy stated link and your issues to github here

https://github.com/ICSFusionX/android_device_zte_skate/issues

no need to log via the computer, can do it all from your phone, don't worry which of the 4000 lines of log Tilal needs as he will work it out :)

  • Upvote 1

Share this post


Link to post
Share on other sites

Started downloading latest today, when it says flash gapps, what does it mean? Please help quickly before I install wrongly

No worries now, just need to know how to get vibrate to work. Any ideas? Other than that, a great port. Very well done tilial. Very good

Edited by utternoob

Share this post


Link to post
Share on other sites

Started downloading latest today, when it says flash gapps, what does it mean? Please help quickly before I install wrongly

Flash the zip file | gapps=google apps (maps, play store)

Share this post


Link to post
Share on other sites

grab alogcat and pastebin for android, both free on market, setup the pastebin account, run alogcat, press menu, press share, share with pastebin, it will copy your log to pastebin, press the option to paste, it will return a link, copy stated link and your issues to github here

https://github.com/I...te_skate/issues

no need to log via the computer, can do it all from your phone, don't worry which of the 4000 lines of log Tilal needs as he will work it out :)

Okay, thanks, but can't I get a copy from using adb? using my pc seems a little more easier to do the work on!... :P

Share this post


Link to post
Share on other sites

Okay, thanks, but can't I get a copy from using adb? using my pc seems a little more easier to do the work on!... :P

yes! :)

adb logcat

Edited by razzmataz1478

Share this post


Link to post
Share on other sites

Okay, thanks, but can't I get a copy from using adb? using my pc seems a little more easier to do the work on!... :P

yam, if you find it easier to do on the pc go for it, principal is the same, just need to copy n paste to pastebin still and post link from to github :)

Share this post


Link to post
Share on other sites

How do you format ??? i can do wipe data , factory reset !!! but there is no FORMAT anywhere ? is it the factory reset or wipe data or something else ?

Share this post


Link to post
Share on other sites

......

3. I also sometimes get the WiFi signal dropout and also have to turn off, wait a few seconds, then turn it back on... I had this problem on ICE Armour but much much much worse as it did it every time I leave the phone left on idle for X periods of time and only can get it back on when I go into the WiFi settings to turn it off / on... Also, another problem where the WiFi just can not be turned as the "error" message gets reported in the settings options and so have to reboot again...

......

+1

WiFI needs restart sometimes.

Share this post


Link to post
Share on other sites

Format commands are in the recovery, not in the Settings menu.

How do you format ??? i can do wipe data , factory reset !!! but there is no FORMAT anywhere ? is it the factory reset or wipe data or something else ?

Share this post


Link to post
Share on other sites

How do you format ??? i can do wipe data , factory reset !!! but there is no FORMAT anywhere ? is it the factory reset or wipe data or something else ?

Secretman, you're back! Remember Me?

Boot into recovery>mounts and storage>format system :)

Share this post


Link to post
Share on other sites

Got a vibration issue. Uploaded to pastebin http://pastebin.com/6Ybnjfj Not sure what if any line of this will help tilalor anyone else, just need to know if it is fixable or not

Edited by utternoob

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.