Jump to content
argentinos

SAMSUNG I8000 (OMNIA2) ANDROID CM6NEW ROM V1

Recommended Posts

For for the sd card still no luck after another day spend on this issue :( , I used sdformattor tool hoping it will help, but NO.

I've tried to do exactly the same spacing for the partition2 linux of 1249, but it comes to 1240 or it was once 1249, but the mini-tool did not let me to restore into this claiming it is smaller then the original image of 1249, maybe by few bytes.

So most of the time I had partions as 6144Mb, 1256Mb, 19x Mb. After restoring the image 1256 becomes ext3 1249, but no sign of extra space, but I was deleting and creating the swap partion just  in case.

a little strange. you do select primary partitions right ? logical will not work here. you tried version 4 of this ROM and still nothing working ? you tried Twister V2 ROM (the link is in this thread too) ? the solution is in deed checkdisk. no need to do format. maybe you have bad sectors on your card, so try to repair-recover bad sectors too, not only file system of the card. do the checkdisk under windows os with the os provided tools. trust me they are the best for our sd cards. do not use 3rd party apps like minitool, etc, do not use linux checkdisk tools. not tested. if everything fails try another sd card. maybe yours is damaged. do not be in a hurry to buy. use an old one (even smaller first) or borrow one from a friend-relative to verify if ROM's problem or your card's problem

Share this post


Link to post
Share on other sites

Finally, hallelujah!

AParted ( Sd card partion) free tool for Android helped in my case.

I did remove and create fat32 partion in android with this tool.

(none of the repair actions helped, but create it from android with this tool)

So conlusion is that mini-tool does make fat32 partion, but it is not compatable with Android, looks like mini-tool(and other tools that I've tried) puts some extra enchanced info(without possibility to disable) for this partion that is not sutable for Android.

 

I have another issue now, USB storage feature does not work for me on Android. Any suggestions? USB Debugging ON/OFF does not help :(

 

a little strange. you do select primary partitions right ? logical will not work here. you tried version 4 of this ROM and still nothing working ? you tried Twister V2 ROM (the link is in this thread too) ? the solution is in deed checkdisk. no need to do format. maybe you have bad sectors on your card, so try to repair-recover bad sectors too, not only file system of the card. do the checkdisk under windows os with the os provided tools. trust me they are the best for our sd cards. do not use 3rd party apps like minitool, etc, do not use linux checkdisk tools. not tested. if everything fails try another sd card. maybe yours is damaged. do not be in a hurry to buy. use an old one (even smaller first) or borrow one from a friend-relative to verify if ROM's problem or your card's problem

Share this post


Link to post
Share on other sites

USB storage feature does not work for me on Android ver5. Any suggestions? USB Debugging ON/OFF does not help!

Thanks for help.

Share this post


Link to post
Share on other sites

of course usb storage is working. try to reboot your phone. when be on windows mobile, connect your phone on usb and then start haret/android. when you enter android usb storage will be working i think.

  • Upvote 1

Share this post


Link to post
Share on other sites

of course usb storage is working. try to reboot your phone. when be on windows mobile, connect your phone on usb and then start haret/android. when you enter android usb storage will be working i think.

 

Thank you, your method worked well, plus I did clean up some drivers before with USBDeview utility.

Great now my phone has second life! better then before.

All the best wishes to the people that spend time on this project!!!

P.S.:

Had one small issue maybe will help someone here. During installing apps from play market, I had error like Google Talk authentication failed and Server error, so I cleaned data for the  play service and  play framework, rebooted and it started to work again.

  • Upvote 1

Share this post


Link to post
Share on other sites
post-887919-0-34788700-1389378259_thumb.

try bigger formating space and what left will be seen as unused so you can make it linux swap.

about the wifi check the wifi settings. in which country do you live ? different countries or different internet providers (and their stock wifi routers) follow different regulations about wifi channels or frequencies.

check if you set your wifi to only g or b or n mode. better activate all.i am not sure which band this wifi is working. if you only have n this phone does not support it so this is an explanation why you get nothing.

 

@chetannaik1971

check post no 1 and also http://www.modaco.com/topic/363114-samsung-i8000-omnia2-android-cm6new-rom-v1/#entry2133378

just adjust the space according to new details for Version5

under windows you can not edit ext3/4 linux swap partitions at least not with minitool. so you just DELETE previous linux swap and make a new one with the desired/left space.

Thanks for replying! I have gone through all the steps and installed the Android OS. But on running Haret I get stuck at this start up screen

Edited by chetannaik1971

Share this post


Link to post
Share on other sites

just try to reinstall the haret.exe, zImage and startup. you placed them under Mystorage ?

is ext3/4 partition trully no2 partition after fat32 ? if yes try to reinstall the ROM. maybe it is broken during installation.

Share this post


Link to post
Share on other sites

just try to reinstall the haret.exe, zImage and startup. you placed them under Mystorage ?

is ext3/4 partition trully no2 partition after fat32 ? if yes try to reinstall the ROM. maybe it is broken during installation.

Yes I have checked the Ext4 (1309MB) partition is second after FAT32 (485MB) and the Swap Space is 189MB. There is a file POCKETFS in My Storage which keeps on appearing even after deleting it again n again.

 

I have tried deleting and re-pasting haret. zImage and STARTUP and also reinstalling the ROM but its the same issue - stuck at start up. I will soon upload screenshots of ImageRecover while I try reinstalling again so that you may be able to detect my mistake.

Share this post


Link to post
Share on other sites

i think your mistake is that you try to install the ROM on "my storage", not on sd card as i describe. im you choose my storage (the phone's hard drive) you should edit startup.txt. You have or do not have sd card ? where haret and zImage are located. tell me in order to help you.

for example try to change

Set CMDLINE "rootdelay=2 root=/dev/mmcblk0p2 init=/init"

with

Set CMDLINE "rootdelay=2 root=/dev/mmcblk1p2 init=/init"

Edited by argentinos

Share this post


Link to post
Share on other sites

i think your mistake is that you try to install the ROM on "my storage", not on sd card as i describe. im you choose my storage (the phone's hard drive) you should edit startup.txt. You have or do not have sd card ? where haret and zImage are located. tell me in order to help you.

for example try to change

Set CMDLINE "rootdelay=2 root=/dev/mmcblk0p2 init=/init"

with

Set CMDLINE "rootdelay=2 root=/dev/mmcblk1p2 init=/init"

Hi bro! My mistake was that I had created the 3 partitions as logical and not primary. Some 15 minutes ago I installed the Android successfully. I will now check how it works. Sorry about that and thanks a million for taking the time to reply patiently to my queries. God bless you n the world!

Share this post


Link to post
Share on other sites

about mp3 you are right. i am searching for it. solution is easy i think. tests for Version 6 almost finished. so i will include this fix too. thanks for your try and your notification in order to impove this ROM

Edited by argentinos

Share this post


Link to post
Share on other sites

to fix mp3 play problem please you and also others use Root Explorer program

then go to system/lib and delete file with name

libstagefrighthw.so

right after you erase you will be able to play again mp3. sorry for the inconvenience

for wifi problem check post no 105

 

i do not want to publish again V5 just for mp3 problem. anyone wants can fix it himself.

i just want to give all my efforts on version 6 that i am testing long time now

Share this post


Link to post
Share on other sites

Hey there!! I tried to install android in my Omnia 2 but i have a problem.....

 

9k4cgx.jpg

 

 

I did everything like Tut, the partitions to SD ( Primary partitions + new step 6 ) card, restore the image with the program (I changed the date of computer), then i copied haret, zimage and the startup to the root of my device... i used a 2GB SD card new, i dont know why i get stuck there..... Help please i want android on my omnia 2!! :(

 

Note: I did two things different in the Tut: i conected the SD card with a microSD adapter, not with the phone.... And when i finished the process with the card (partitions, restore, etc) i copied haret, zimage and startup to the SD and then i copied to the device  root with the Windows Mobile's File manager... I that case... There's any problem??

Greets~

Edited by brokench0rd

Share this post


Link to post
Share on other sites

i think i figured your problem. i believe it is mistake on step No18

i wrote

"In the root of "my storage" we paste a ) haret.exe, b ) zImage, c ) startup.txt from the folder "copy to storage card root" from the rar we downloaded and decompressed"

i wrote my storage (phone's hard disk.). instead of this i think you pasted the files in my device.

i wrote to paste them under "my device / my storage"

do it and i think you can proceed. if still have a problem tell me which version you want to install. V5 needs diferent space  compared to previous versions.

Share this post


Link to post
Share on other sites

SAMSUNG I8000 (OMNIA2) ANDROID CM6NEW ROM Version 6

SAMSUNG I8000 (OMNIA2) ANDROID CM6NEW ROM Version 6
- Changed phone support more SIM
- fixed some bugs ( in version 5 reported problems playing MP3 songs and wifi connectivity problems)
- changed phone.apk, deskclock.apk, contacts.apk, and many non google programs.
- Added kit kat lockscreen
- settings for greater energy savings and improve speed
- new phone and clock ics
- Ics on the system, the default phone and the status bar

Note : Also here all changes made ​​having in mind speed, the screen type our mobile (resistive), the platform version of course ( 2.2 ) and the look of latest distributions android (4.0 - 4.4). The optional, applications are not installed on the system , so anyone who does not need them, can uninstall them and lighten his cell phone. Anyone who needs them can keep them and make his mobile phone look like more modern. There are other similar applications in the market, but they are not free and so since it is not allowed to distribute commercial applications , anyone who wants can buy them and make his phone beautiful / faster .

Explanation photo below ( further changes from version 5)
1 = kit kat lockscreen 1
2 = kit kat lockscreen 2
3 = phone ics themed
4 = statusbar ics themed
5 = framework ics themed
6 = ics alarm

installation instructions same as here
http://www.modaco.com/topic/363114-samsung-i8000-omnia2-android-cm6new-rom-v1/page-8#entry2181866
link for download in the first post.

post-931240-0-56486800-1390738373_thumb.

post-931240-0-37319900-1390738382_thumb.

post-931240-0-27575300-1390738413_thumb.

post-931240-0-47423900-1390738421_thumb.

post-931240-0-79030500-1390738426_thumb.

post-931240-0-02684100-1390738431_thumb.

Share this post


Link to post
Share on other sites

EDIT: Finally i've finished, the problem was my F***king SDcard.... I tried with another 2gb card and is solved..... Ill test the android, if get some issues ill report it.. 

 

Best regards

Edited by brokench0rd

Share this post


Link to post
Share on other sites

Thanks argentinos  for the new release, i am eagerly waiting for the updated version. I have just installed on my i8000 today, i will review this and i will give my feedback soon, i think that will need you to improve this build further.

 

Thanks again for the good work! Keep going...!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.