Jump to content
PaulOBrien

Beta 13: MoDaCo.SWITCH HTC One support topic

Recommended Posts

Will we ever be able to enable fastboot with use for SWITCH?

Only if S-On as recovery flashes the files. If s-off it doesn't reboot properly to run the script it needs to.

Share this post


Link to post
Share on other sites
I would assume that Paul will disable stock OTA updater in the next update.

Yes he will be, I already posted that he would be.

Share this post


Link to post
Share on other sites

Only if S-On as recovery flashes the files. If s-off it doesn't reboot properly to run the script it needs to.

What are the advantages of switching without using recovery then? the boot seems would be faster with recovery

Edited by FilyPhanatic

Share this post


Link to post
Share on other sites

What are the advantages of switching without using recovery then? the boot seems would be faster with recovery

It's faster without recovery as the recovery process takes longer to flash.

So recovery + fastboot is still slower than using neither.

Share this post


Link to post
Share on other sites

Ever since installing Switch, restarting the phone to switch between the ROM's, TWRP runs a recovery script. Is this normal?

And also, the Google Play ROM, is pretty much unuseable, with constant 'Unfortunately, the process com.android.phone has stopped', 'Unfortunately, the process com.android.media has stopped.', 'Unfortunately, Messaging has stopped'. I can only just get into the menu to change back to the Sense ROM. Any suggestions?

S–off it solved my issues

Share this post


Link to post
Share on other sites

Looks like the calendar from the GPe side is showing up on the Sense side after it updates.

I found this too. If you want an app to only be available in one of the ROMS only (i.e. Google Calendar, Nova Launcher etc) you just need to move the .apk from 'data/app/' (or 'system/app/') to '/system/SWITCH/*ROM/app'

*Where ROM is 'gpe' or 'switch'

Share this post


Link to post
Share on other sites

I found this too. If you want an app to only be available in one of the ROMS only (i.e. Google Calendar, Nova Launcher etc) you just need to move the .apk from 'data/app/' (or 'system/app/') to '/system/SWITCH/*ROM/app'

*Where ROM is 'gpe' or 'switch'

And you will have to do this each time the app is updated.

  • Upvote 1

Share this post


Link to post
Share on other sites

I need some help diagnosing a possible issue

Please take a nandroid before attempting!

1) Open up "car mode" in the sense rom, then hit "Speak" - what happens? does it say "please wait" forever or does the mode actually load?

2) exit speak and car mode (regardless of outcome of end of step 1) and do a normal reboot (not a switch) - does it bootloop?

Anyone who has a working speak mode and no bootloop please confirm the following

a) How are your contacts saved? google account?

b ) Do you use Google Play Music? Or do you have any music on the device visible in the stock HTC Music app?

Please help - I am hoping this is not a larger issue, if it is we will have to look into it for a future beta.

If you did get a bootloop just reboot into recovery (hold power and volume down) and restore your nandroid - and be sure not to open speak mode again!

Edited by Lennyuk

Share this post


Link to post
Share on other sites

Sorry mate, I forgot to mention to you.

I did try the speech mode on Friday and can confirm it just sat on the... "Loading Contacts & Apps" (or whatever it says), and did not load. Fortunately though, after rebooting afterwards I didn't get a bootloop though.

I'm intrigued to see if anyone has this working OK on stock, as I can't see why it'd behave differently on SWITCH.

Share this post


Link to post
Share on other sites

I think the internet doesn't work on all apps, such as "LINE I Love Coffee", it says no network connection while in sense mode, but it works perfectly fine on GPe.

I bet there should be more apps that had this error..

Share this post


Link to post
Share on other sites

I need some help diagnosing a possible issue

Please take a nandroid before attempting!

1) Open up "car mode" in the sense rom, then hit "Speak" - what happens? does it say "please wait" forever or does the mode actually load?

2) exit speak and car mode (regardless of outcome of end of step 1) and do a normal reboot (not a switch) - does it bootloop?

Anyone who has a working speak mode and no bootloop please confirm the following

a) How are your contacts saved? google account?

b ) Do you use Google Play Music? Or do you have any music on the device visible in the stock HTC Music app?

Please help - I am hoping this is not a larger issue, if it is we will have to look into it for a future beta.

If you did get a bootloop just reboot into recovery (hold power and volume down) and restore your nandroid - and be sure not to open speak mode again!

1) it doesn't load.

2) no bootloop

a)contacts are all on google

b)not using google play music. there are some mp3 on phone. have played them using google play music on gpe side if that counts.

Share this post


Link to post
Share on other sites

Ok can you try the three finger gesture to launch speak mode.

Then see if bootloops on a reboot?

Share this post


Link to post
Share on other sites

I need some help diagnosing a possible issue

Please take a nandroid before attempting!

1) Open up "car mode" in the sense rom, then hit "Speak" - what happens? does it say "please wait" forever or does the mode actually load?

2) exit speak and car mode (regardless of outcome of end of step 1) and do a normal reboot (not a switch) - does it bootloop?

Anyone who has a working speak mode and no bootloop please confirm the following

a) How are your contacts saved? google account?

b ) Do you use Google Play Music? Or do you have any music on the device visible in the stock HTC Music app?

Please help - I am hoping this is not a larger issue, if it is we will have to look into it for a future beta.

If you did get a bootloop just reboot into recovery (hold power and volume down) and restore your nandroid - and be sure not to open speak mode again!

Um I just realized I don't even have car mode now...

Share this post


Link to post
Share on other sites

Can anyone think of a simple way for tasker to be able to identify which ROM is booted? I was thinking of a file search to see if Nova is in data/app but that's not going to be useful as a generic test, anyone got any ideas?

Share this post


Link to post
Share on other sites

Can anyone think of a simple way for tasker to be able to identify which ROM is booted? I was thinking of a file search to see if Nova is in data/app but that's not going to be useful as a generic test, anyone got any ideas?

if you want to search file, search something in /system. searching /data is gonna be the same for both side.

if you are trying to get different tasker setup for each side, you can just exclude tasker data and you will have different setup on each side without all those trouble.

Share this post


Link to post
Share on other sites
if you want to search file, search something in /system. searching /data is gonna be the same for both side.

if you are trying to get different tasker setup for each side, you can just exclude tasker data and you will have different setup on each side without all those trouble.

That's true. I guess running two instances could work, although would be a pain when setting up a profile which needs to run on both. Is data the same? That's a possibility though. Anyone else think of a way to check? Or is running two instances going to be the only option?

Share this post


Link to post
Share on other sites

I installed beta 8 with s-on support and it has been working great. I was getting annoyed by the way s-on works so I recently used revone for s-off. Now how do I eliminate the s-on support package (having to go into TWRP and installing the untrusted zip)? I don't want to have to reinstall everything.

Share this post


Link to post
Share on other sites

I installed beta 8 with s-on support and it has been working great. I was getting annoyed by the way s-on works so I recently used revone for s-off. Now how do I eliminate the s-on support package (having to go into TWRP and installing the untrusted zip)? I don't want to have to reinstall everything.

Delete

/data/SWITCH/son

or

/system/SWITCH/son

whichever it is, I have never used son so I forget where it is placed - but it is that simple.

Share this post


Link to post
Share on other sites

Delete

/data/SWITCH/son

or

/system/SWITCH/son

whichever it is, I have never used son so I forget where it is placed - but it is that simple.

It was in data. I deleted it, but now it just reboots and doesn't switch. Any suggestions?

Share this post


Link to post
Share on other sites

It was in data. I deleted it, but now it just reboots and doesn't switch. Any suggestions?

have you made sure fastboot is off in menu > settings > power?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.