Jump to content
Sign in to follow this  

Bluetooth Audio Fix

Recommended Posts

OK, I had this issue on CM on the G300. This was the solution I worked out, and I just checked the Y300, and it's the same:

The A2DP sampling rates are wrong. Edit \system\etc\audio_policy.conf (use root browser, back it up first, change permissions first!)

Near the bottom, you'll find an A2DP section, and it has "sampling rates 48000" - you need to add 44100, so change it to "sampling rates 44100|48000", save and reboot.

Having said that, A2DP streaming already worked fine on my intemp Bluetooth speaker, but if you`re having issues...

Edited by TangerineTractor
  • Upvote 1

Share this post

Link to post
Share on other sites

You can probably find the answer in /system/etc/Bluetooth/

You can check the device code 00:CO:DE;ID:00:00 & then see is it prohibited - black listed - or problematic (iop_device_list.con)

The most of this type of problems stated with ICS & iOS is not better standing with this to.

As I did find the auto pairing with auto M.M.S is prohibited...

Share this post

Link to post
Share on other sites

The rate definitely affects streaming... but it might be different depending on stereo/mono etc... I'm not an expert. This is the exact same issue as I had on my Sony car head unit with my g300 after a rom change.

Make sure you have write access to the file so it definitely gets saved, and make sure you get the superstore right by copying it from somewhere else in the file, or replace the 48000 with. 44100 instead.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


Important Information

By using this site, you agree to our Terms of Use.