Jump to content
KonstaT

[DEV][ROM][2.7.] CyanogenMod 11 (Android 4.4.4)

Recommended Posts

I'm seeing an odd behavior and don't know what to blame.

With this version (14.1) whenever I complete a call (incoming or outgoing) the dialer closes but not on launcher home screen but on the last application I was running even if that was closed before.

 

For example I'm on play store or some game or any other application (camera etc).  I exit the application (using exit if exist or home button).  Now I see my launcher home screen.

I press the dialer button, place the call and hung up.  Instead of launcher the previous application comes up.  It actually executes the app if that was closed.

 

I did not had this in 18.12

I'm using nova launcher and dialer one.  With the stock dialer this does not happen because the stock dialer does not offer the option to exit when the call is completed.

Maybe it's because your dialer app automatically forces android to "go back" to the last used application.

Is your question related to our device / this ROM / Cyanogenmod ?

Share this post


Link to post
Share on other sites

 

This is my port of CyanogenMod 11 for ZTE Blade III. It is unofficial and unsupported by the CyanogenMod team. It's for advanced users only.
 
 
cm-11-20140114-UNOFFICIAL-KonstaKANG-atlas40.zip
md5:af0f4352cf761d14aa3798038f0a738a
 
gapps-kk-core-20131217.zip (Core gapps package with only essential Google services.)
md5:b32bd021a0d74ed10fd97feec13122bb
 
Working:
  • RIL (mobile network & data)
  • Wifi
  • Bluetooth
  • GPS
  • Audio (playback/input/routing/headphones/etc)
  • Camera (photos, camcorder & panorama)
  • Hardware acceleration and OpenGL rendering
  • Hardware video decoding & encoding
  • 'Project Butter'
  • SD card
  • USB-storage (on external sdcard) & adb
  • USB-tethering
  • Wifi-tethering
  • Touchscreen/multi-touch
  • Sensors
  • LEDs
  • FM radio
Not working:
  • ???
Sources:
Thanks:
  • CyanogenMod team & everyone who's been working on CM11

Thanks a lot guys!! It is working perfectly on ZTE BLADE III !! Here is my video review ! http://www.youtube.com/watch?v=hoPUcKKmZKM

Share this post


Link to post
Share on other sites

This time I hope I'm providing useful part of logcat :D Finally managed to do it because I always need to access the internet as soon as possible by toggling airplane mode on and off (rather than turning the phone on and off) - then it's not possible to capture the problem with logcat (the problem does not occur).

 

Also, something I noticed: it was working well after first boot (14.1.2014). This is bothering me since 4.3 :(

The other problem I had (failing to connect to 3g network) seems to have been fixed in 14.1.2014 build

 

http://pastebin.com/eu6WQkKz

 

Some googling (other devices): https://gist.github.com/psyke83/8351912

Edited by plantroon

Share this post


Link to post
Share on other sites

 

Well, this has happened now once to me too. It happened after a soft reboot (system services die and you'll be dropped to bootanimation as everything is reloaded). You can't expect system to function properly after that and you should do a proper reboot.
 
Now someone would need to catch the cause for the soft reboot on log but I can't see how this would be a device specfic issue.

 

Installed your ROM on my friends Blade 3.I told him to send me last_kmsg.txt.

Would last_kmsg.txt help anything?

Cheers!

Share this post


Link to post
Share on other sites

hey guys how to stop or remove app called cLock in use details of that app its says that this app uses 86% of batery and use details GPS why is that?

That's clock and weather widget. It uses your location to get currrent weather

Share this post


Link to post
Share on other sites

hey guys how to stop or remove app called cLock in use details of that app its says that this app uses 86% of batery and use details GPS  why is that?

It`s simple just go to Settings>Apps>All find cLock and Disable.It`s true that this app uses to much battery

Share this post


Link to post
Share on other sites

That's clock and weather widget. It uses your location to get currrent weather

If someone doesnt like that CM thing then download TitaniumBackup and uninstall it.

Problem solved!

Question for KonstaT:

 

Fix for SW reboots coming soon?

Is that CM cLock thing vital for system?

Share this post


Link to post
Share on other sites

hi

when i full charge battery 100% and reboot battery appears after boot 85 %...

is that normal???

thanks

Go on... admit it... it's a dumb question.

"is that normal?" Its a dumb problem! Try rebooting with the charger in next time, and it won't rape all those resources on reboot. Your battery wont remember so well between boots how much it has. Cheat it.

 

Edited after cup of tea and a lie-down:

A battery powered laptop is going to produce the same results without the charger in I guess. I have to say though - 15% is quite a bit to lose. Battery a bit old?

Edited by MJonMoDaCo

Share this post


Link to post
Share on other sites

Great  ROM, my Blade seems to be more responsive, no lag, everything works fine! But, I had a reset issue last night , unexpected reboot, and after that it said, unfortunately android media device has stopped working. I had to reboot, and this issue has gone. After some google-ing I stummbled on a reason for that, it is a syncing issue, just download and install gmail app, and sync it with your google account..

 
 

Share this post


Link to post
Share on other sites

we are getting a system error. i cant logcat it atm as phone is with my daughter but here is a screenshot

 

this phone has just had a newly activated phone put in it

 

post-1018919-0-93985600-1390297114_thumb

Share this post


Link to post
Share on other sites

ok, my previous problem with daughters phone could be because her mother didn't activate the SIM card for her

Share this post


Link to post
Share on other sites

@KonstaT
Seems i found cause of that SW reboot and media error.
When i removed apps that req root like BetterBatteryStats phone is fine and doesnt do any SW reboot or media error.

I looked at the last_kmsg.txt and seems when SU gives permission for root access it actually gives some HW level permission and when BBS trys to check for wakelocks it triggers a bug that does SW reboot and media error.

Share this post


Link to post
Share on other sites

Thanks for making this rom. Soon as i got my ZTE Blade 3 i installed it and is now alot faster than before. Just one problem

 

I live in the UK and my phone is Locked to Virgin Mobile Network but when i look on my phone it says T-Mobile and sometimes Orange (EE).

 

I tether my phone to my laptop all the time what with me having unlimited data but recently when i go on to certain websites i get the T-Mobile Content Block page. I have had my content lock removed from Virgin mobile so why am i getting this.

 

Is there a way to fix this so my phone says Virgin and not T-Mobile/Orange (EE)

 

I dont want to use another rom as this is the best one yet. If anyone else has had the problem let me know and if there is another rom that fixes this please get in touch.

 

Thank you

Share this post


Link to post
Share on other sites

 

This is my port of CyanogenMod 11 for ZTE Blade III. It is unofficial and unsupported by the CyanogenMod team. It's for advanced users only.
 
 
cm-11-20140114-UNOFFICIAL-KonstaKANG-atlas40.zip
md5:af0f4352cf761d14aa3798038f0a738a
 
gapps-kk-core-20131217.zip (Core gapps package with only essential Google services.)
md5:b32bd021a0d74ed10fd97feec13122bb
 
Working:
  • RIL (mobile network & data)
  • Wifi
  • Bluetooth
  • GPS
  • Audio (playback/input/routing/headphones/etc)
  • Camera (photos, camcorder & panorama)
  • Hardware acceleration and OpenGL rendering
  • Hardware video decoding & encoding
  • 'Project Butter'
  • SD card
  • USB-storage (on external sdcard) & adb
  • USB-tethering
  • Wifi-tethering
  • Touchscreen/multi-touch
  • Sensors
  • LEDs
  • FM radio
Not working:
  • ???
Sources:
Thanks:
  • CyanogenMod team & everyone who's been working on CM11

 

How to download a zipp files?? Thanks

Share this post


Link to post
Share on other sites

if you really need help with this perhaps you shouldn't use this rom.

+1

But by the sounds of things, he's probably yet to root the phone and unlock the bootloader. This could be painful for somebody...

Share this post


Link to post
Share on other sites

^^ and then nek minute I've bricked my phone guys

So Mr. Nek Minnit found his way into Aussie vernacular slang, huh? Well, unlike our Rock bands and our top acting talent, you can't have him! Besides, he has to stay in colder climates, hence living in Dunedin.

For those who need an example, here's our former Prime minister and current 3IC at the UN:

Aunty Helen

>.<

Memoriiies...

@zuzunovic

Tried this?

You won't get anywhere without it. You'll get practice at downloading zip files (adb and fastboot), unzipping them, relocating them, and then using them!

ever seen this before:

C:>

You'll either say "yes" or quiver in fear... even though you shouldn't be afraid of it. Its your (heh) friend. If you don't think so, then you're best to stick with what you have... Or you could always just:

iPhone for life Just kidding.

Edited by MJonMoDaCo

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.