Jump to content

[DEV][ROM][2.7.] CyanogenMod 11 (Android 4.4.4)

Guest KonstaT

Recommended Posts

Guest KonstaT
This is my port of CyanogenMod 11 for ZTE Blade III. It is unofficial and unsupported by the CyanogenMod team. It's for advanced users only.
Screenshot_2013-12-17-16-11-33.png Screenshot_2013-12-17-16-12-21.png Screenshot_2013-12-17-16-13-01.png Screenshot_2013-12-17-16-13-39.png
You will need updated recovery image (CWM, TWRP) to install this build!!!
gapps-kk-core-20140608.zip (core gapps package with only essential Google services)
  • RIL (mobile network & data)
  • Wifi
  • Bluetooth
  • GPS
  • Audio (playback/input/routing/headphones/etc)
  • Camera (photos, camcorder & panorama)
  • Hardware acceleration and OpenGL rendering
  • Hardware video decoding & encoding
  • 'Project Butter'
  • SD card
  • USB-storage (on external sdcard) & adb
  • USB-tethering
  • Wifi-tethering
  • Touchscreen/multi-touch
  • Sensors
  • LEDs
  • FM radio
Not working:
  • ???
  • CyanogenMod team & everyone who's been working on CM11
Like my work?
Edited by KonstaT
Link to comment
Share on other sites

Guest KonstaT
Merged commits not mentioned in the changelog.
2.7. changelog:
  • Android 4.4.4
  • Heads up notifications (merged)
  • Searchable settings (merged)
7.6. changelog:
  • Android 4.4.3
  • dynamically set correct baseband version
  • patched CVE-2014-3153
  • patched latest OpenSSL vulnerabilities (merged)
21.5. changelog:
  • worked around broken WMA hardware decoding by using FFmpeg instead
  • patched CVE-2014-0196
  • Add UUID (re-)scan support for vold-mounted volume (1,2)
  • browser fixes (merged)
    • tittle bar autohide
    • fix 'most visited' homepage
  • new theme chooser (merged)
8.5. changelog:
  • new CAF based lights HAL
  • enable FFmpeg codecs (merged)
20.3. changelog:
  • fixed fm audio routing to speakerphone
  • got rid off legacy mmparser by using libExtendedExtractor instead
  • might have done something to VoIP :P
  • fixed wifi data indicator arrows (merged)
  • dialer lookup (merged)
10.3. changelog:
  • updated to new fm volume api and switched to CM's qcom fm solution (routing fm audio to speakerphone currently broken)
  • possible fix for cause of soft reboots (1)
4.3. changelog:
  • sync with upstream
14.1. changelog:
  • enabled zRAM and KSM by default
  • re-enabled JIT cache
  • enable qcom bionic optimizations
  • add option to display navigation (Settings -> Interface -> Show navigation bar)
  • add option for custom navigation bar height (Settings -> Interface -> Button height)
  • fixed transparency on incall screen
  • Keep InCallUI in memory (1,2,3)
  • add option to force high-end graphics such as transparent status/navigation bar (1,2)
  • Add option to always show battery status on lockscreen (1,2)
  • Allow changing screen-off animation (1,2)
18.12. changelog:
  • initial release


Previous builds:



Previous gapps: (Android 4.4.2)

gapps-kk-core-20131217.zip (core gapps package with only essential Google services)

Edited by KonstaT
Link to comment
Share on other sites

Guest KonstaT

How to install:

  1. boot into ClockWorkMod
  2. backup and restore -> backup (makes a nandroid backup of your previous ROM)
  3. mounts and storage -> format /system
  4. wipe data and factory reset
  5. install cm-11-xxxxxxxx-KonstaKANG-atlas40.zip
  6. install gapps-kk-xxxxxxxx-signed.zip
  7. reboot now



Q: I can't find developer options and performance settings, why?
A: Settings -> About phone -> Click 'Build number' several times

Q: I don't have reboot options in power menu, why?
A: Settings -> Developer options -> Advanced reboot

Q: When I'm connected with an USB cable to my computer, I can't see my internal sdcard as a storage, why?
A: I've made an executive decision not to include a mount point for internal sdcard. This is because recent Android versions don't allow setting emulated sdcard as secondary storage. Setting rather small emulated sdcard as a primary storage caused issues with games/apps that want to download large amounts of data to the sdcard.

Q: There's no transparent status/navigation bar, why?
A: It has been disabled on low memory devices. You can enable it by removing/commenting/changing to false 'ro.config.low_ram=true' in /system/build.prop. There's also an option that will only force high-end graphics (Setting -> Performance -> Force high-end graphics).

Q: 'OK Google' voice command doesn't work, why? There's no Google Now page on the homescreen, why?
A: These are features of proprietary Google Experience Launcher. You'll have to find and install GE Launcher first. 'OK Google' voice command is also disable on low memory devices (see above).


How to build:

1. Follow instructions on initializing a build environment up to a point of downloading the source code.
2. Initialize CyanogenMod 11 repo.

repo init -u git://github.com/CyanogenMod/android.git -b cm-11.0

3. Add local manifest that downloads ZTE Blade III device config, props and kernel source from my github and few CM replacement projects from legaCyMod github.

curl --create-dirs -L -o .repo/local_manifests/local_manifest.xml -O -L https://raw.github.com/legaCyMod/android_local_manifest/cm-11.0/local_manifest.xml
curl -L -o .repo/local_manifests/manifest_zte_atlas40.xml -O -L https://raw.github.com/legaCyMod/android_local_manifest/cm-11.0/manifest_zte_atlas40.xml

4. Sync source code.

repo sync

5. Update Terminal Emulator (you only need to this again when Terminal has been updated).

cd path-to/cm11/vendor/cm/

6. Apply patches. There's few patches needed for classic webview (1,2,3,4,5). Copy patches into respective project directories, change into directories and apply patches.

git am -3 patchname.patch

7. Compile.

cd path-to/cm11/
. build/envsetup.sh
brunch atlas40

Use 'repo sync' to pull merged changes from upstream. Use 'make clobber' to clean the build environment. Repeat step 7 to make a new build.

Edited by KonstaT
Link to comment
Share on other sites

Guest przemvelbenny

Good to see you alive KonstaT! :)

This forum nearly died without you! Just downloading whatever you upload. Thanks for your work and your time waste do it.

Edited by przemvelbenny
Link to comment
Share on other sites

Guest ZteLegend

Tested it right now. Perfect. No other word necceseary. I tought I might need Nova,but it's speed is amazing. Fast, great performance. Lovely. Just lovely.

Link to comment
Share on other sites

Thanks , man...

Did anyone tried this ROM?



didnt see that Zte legend already tested,....


So everything is ok?

t Thanks KonstaT, and thannks Ztelegend for testing it..

Edited by peksan
Link to comment
Share on other sites

Guest ilievski.ace

Thanks man you are the best ... I will now definitely change my blade lll pro. For zte blade lll. .. thanks again and don't forget you are ower God....

Link to comment
Share on other sites

Guest ZteLegend

Thanks , man...

Did anyone tried this ROM?



didnt see that Zte legend already tested,....


So everything is ok?

t Thanks KonstaT, and thannks Ztelegend for testing it.I 

I liked 4.2.2 but it was lagging a bit. BUT KIT KAT....it's a combination of beauty,speed and awesomness.

Link to comment
Share on other sites

Guest plantroon

I only wiped /system and everything works so far :) Wifi got broken on my previous ROM somehow and now it works fine :) This is definitely the best Android ROM for Blade 3 right now :D

Link to comment
Share on other sites

Didn't test it but it probably works.

thanks man

 I used it all the time, so if it doesnt work, i will stick with 4.1.2...

But dont get me wrong Konstat, THANK YOU VERY much man

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.