Jump to content
chil360

[ROM][4.4.4][ALL] SlimKat 9.1 UNOFFICIAL [29/12/2015]

Recommended Posts

@chil360 http://www.ulozto.net/xAjrS8Td/y530-u00-v100r001c150b170-rar

Did you try them?

What date are they?

Is device scoring more than our?

I think it's kernel mem interface dependable & that they are for 4.3-4.4!

The Adreno driver's are just binary blobs so you can try out are they working simply copying them.

If you want to try pm me to talk a little bit about it!

do you think that will be possible to port adreno 203 drivers from this rom?

Share this post


Link to post
Share on other sites

I unpacked the update.app, i tried to copy all the files from Y530 EGL folder in the cm10.2 Y300 EGL folder (i tried a 4.3 rom because y530 has android 4.3) but after flash, the screen goes off, seems that the phone power off but simply the display power off, so i think need to be optimized (?), if you or others want to help me, but i dont know how to rewrite egl

Edited by fonz93

Share this post


Link to post
Share on other sites

I think we need the source code of Y530 to port gpu drivers to cm10.2 :)

Huawei does not release source code of the rom, they release the source code only for the kernel 

Share this post


Link to post
Share on other sites

Huawei does not release source code of the rom, they release the source code only for the kernel 

Yes,we need kernel source code of Y530 for porting drivers to cm10.2 for y300/g510. I think :D (sorry for bad english) 

Share this post


Link to post
Share on other sites

There is no such a thing like a source code for Adreno, the drivers are closed proprietary source & are only distributed as compiled binary blobs!

The driver is only one the same for all Adreno GPUs (there are additional libs for 300+ bat its all distributed together). Logically there are version numbers bat we can only track them by file build date info. Much like on PC!

If you can find a device with Adreno 203 (a200) that scores more in benchmarks (with ROM ID) then that is wort looking into!

Don't forget that 3D performance is also CPU dependable!

Edited by ZolaIII

Share this post


Link to post
Share on other sites

I unpacked the update.app, i tried to copy all the files from Y530 EGL folder in the cm10.2 Y300 EGL folder (i tried a 4.3 rom because y530 has android 4.3) but after flash, the screen goes off, seems that the phone power off but simply the display power off, so i think need to be optimized (?), if you or others want to help me, but i dont know how to rewrite egl

I am downloading this now and will try it later.

 

I think there are more files to replace than just the lib/egl libraries. Try also replacing lib/libOpenVG.so lib/libgsl.so lib/libsc-a2xx.so and maybe the etc/firmware files.

  • Upvote 1

Share this post


Link to post
Share on other sites

I am downloading this now and will try it later.

 

I think there are more files to replace than just the lib/egl libraries. Try also replacing lib/libOpenVG.so lib/libgsl.so lib/libsc-a2xx.so and maybe the etc/firmware files.

Ok, ill'try tomorrow because now i have to go, thanks for help

Share this post


Link to post
Share on other sites

Had a tough time installing the new release.

After installing and rebooting, it wouldn't get past the error message "system ui has stopped."

I reflashed, with full wipes, this worked but was very laggy.

Facebook, tapatalk and yahoo mail wouldn't run.

I've done all wipes and reflashed a third time, again its very laggy but all apps are working.

Several random reboots when the phone on charge.

Don't know what's causing this but I'm confident its not slimkat as I've flashed other ROMs over the weekend and had same issue.

I've change from twrp and cwm and back again and tried different 4.4 gapps

I'm lost right now as to what's going on but keep you posted.

Share this post


Link to post
Share on other sites

Had a tough time installing the new release.

After installing and rebooting, it wouldn't get past the error message "system ui has stopped."

I reflashed, with full wipes, this worked but was very laggy.

Facebook, tapatalk and yahoo mail wouldn't run.

I've done all wipes and reflashed a third time, again its very laggy but all apps are working.

Several random reboots when the phone on charge.

Don't know what's causing this but I'm confident its not slimkat as I've flashed other ROMs over the weekend and had same issue.

I've change from twrp and cwm and back again and tried different 4.4 gapps

I'm lost right now as to what's going on but keep you posted.

Try to install firmware if you can find original UK one!

Then play again with ROMs...

Hopefully this will help...

Share this post


Link to post
Share on other sites

Try to install firmware if you can find original UK one!

Then play again with ROMs...

Hopefully this will help...

I'll give that a go.

Thanks!

Share this post


Link to post
Share on other sites

 

 

They are definitely more up to date but I can't get them to work. It may well be possible to run with these blobs but I don't know how. I got this far... logcat.

  • Upvote 1

Share this post


Link to post
Share on other sites

I just looked up the rest & yes its probably that he traces them back to bionic move - copy lib libc that is bat its not about it I think!

Just for sake of experiment rip of libc & libm & copy them then try again!

If the result is the same then just copy back GPU driver & live bionic libs & try if it will boot.

I think that this Amsterdam server is getting high! ¡ :)

Share this post


Link to post
Share on other sites

They are definitely more up to date but I can't get them to work. It may well be possible to run with these blobs but I don't know how. I got this far... logcat.

Looks to me like these drivers are not 100% compatible with our kernel: there is an error allocating graphic memory via a kernel IOCTL early on in the EGL startup. If the Y530 has kernel source we could port the necessary bits I guess..

PS well done on this port, 'tis a lovely rom :)

Share this post


Link to post
Share on other sites

Can any say, which DPI number in SlimCat 2.3 or 2.4 was? In 2.8 it's to big for me.

220 is the best, try it

Share this post


Link to post
Share on other sites

for zolaIII and chil360

I have some issue with Performance Control:

everything is ok (it has supersu permissions) if I don't restart the device, my setup is working as I want.

But when devicerestarts,  all my settings are gone, it return to default value (min cpu 320, ondemand, row, readahead 128kb ...) even if I choose that my setting are ready at startup.

I think supersu is not working properly as other user (tangerine) said in the past.

 

TangerineTractor issue:

http://www.modaco.com/topic/368306-rom442all-slimkat-28-rc3-unofficial-10022014/?p=2190943

Edited by Romagnolo1973

Share this post


Link to post
Share on other sites

for zolaIII and chil360

I have some issue with Performance Control:

everything is ok (it has supersu permissions) if I don't restart the device, my setup is working as I want.

But when devicerestarts, all my settings are gone, it return to default value (min cpu 320, ondemand, row, readahead 128kb ...) even if I choose that my setting are ready at startup.

I think supersu is not working properly as other user (tangerine) said in the past.

There is a problem with SU it's a rev 15 (last one is 17) & its not full compatible with 4.4... I actually didn't have problems with it. Problem is we can't update it as built in interface for it (in setting) don't work with new binary & it blocks all other apps (similar ones that come with binaries). On the other hand check the update of Performance Control app (in app - app settings) last version is 2.1.11. Edited by ZolaIII

Share this post


Link to post
Share on other sites

There is a problem with SU it's a rev 15 (last one is 17) & its not full compatible with 4.4... I actually didn't have problems with it. Problem is we can't update it as built in interface for it (in setting) don't work with new binary & it blocks all other apps (similar ones that come with binaries). On the other hand check the update of Performance Control app (in app - app settings) last version is 2.1.11.

I have tried last PerforanceControl but same issue and yes I don't like the way Slim Rom choose to manage SU put it so deep inside the rom, because if there is a security problem, users need an update as soon as possible and in this case they can't. We nee'd waiting slim directly update it and as we can see is not fast.. I don't like this solution at all.

Could be this can help to put SU in the system?

https://github.com/SlimRoms/Superuser

I don't know because I', not a programmer, I'm only a simple user

Edited by Romagnolo1973

Share this post


Link to post
Share on other sites

I have tried last PerforanceControl but same issue and yes I don't like the way Slim Rom choose to manage SU put it so deep inside the rom, because if there is a security problem, users need an update as soon as possible and in this case they can't. We nee'd waiting slim directly update it and as we can see is not fast.. I don't like this solution at all.

Could be this can help to put SU in the system?

https://github.com/SlimRoms/Superuser

I don't know because I', not a programmer, I'm only a simple user

Nop!

You have a Slim+ (by David_vaz) where su is stripped down from system & settings so you can use (flash) any su by jour choice. So try it out! You don't have to wipe data (apps).

Share this post


Link to post
Share on other sites

Nop!

You have a Slim+ (by David_vaz) where su is stripped down from system & settings so you can use (flash) any su by jour choice. So try it out! You don't have to wipe data (apps).

I have installed SuperSU with is binary via twrp so is working, but the problem is that SuperUser is still active and is dominant over SuperSU so the system is not 100% rooted, I want uninstall SuperUser but is deep system app and I can't delete it. PowerControl and other apps needing rooted access (greenify, romtollbox) does not work properly because of this poor SuperUser put inside the slimrom.

Share this post


Link to post
Share on other sites

I have installed SuperSU with is binary via twrp so is working, but the problem is that SuperUser is still active and is dominant over SuperSU so the system is not 100% rooted, I want uninstall SuperUser but is deep system app and I can't delete it. PowerControl and other apps needing rooted access (greenify, romtollbox) does not work properly because of this poor SuperUser put inside the slimrom.

No you didn't get anything with that!

It's still using old binary & system integrated control! :)

I told you to if you want to try a another Slim Kat based ROM (Slim+).

As its same Android version (based on Slim RC2 currently) it's in of to just install it over & jour apps will remain the same.

Share this post


Link to post
Share on other sites

ahh understood.

Well I solve the issue with a workaround:

disble superuser from is setting moving from adb&apps to disabled, purge all application has SU access from is windows (without this second step it does not work)

restart and now with SuperSU been the only root manager now all is working better.

Performance Control now apply all my personal settings just 1 minute after a boot when SuperSU can make is job and others apps as roomtoolmanager and greenify works better with more options available.

 

So I can continue use SlimKat that I love so much  :)

Well was a hard work but finaly is working, IMHO make SU app a simple application and not inside system is far far better, letting user update it without issue and choose is own SU app, expecially when superuser is so buggy for KK.

Thanks zola for your help

Edited by Romagnolo1973

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.