Jump to content
Guest

[KERNEL] [Y300/G510] Stock Huawei

Recommended Posts

Guest

Exactly. I've only re-packed the boot.img and updated the ramdisk. No changes have been done to the zImage itself. However the stable build got KSM enabled at least.

 

EDIT: "UKSM" cannot be considered as stable at the moment after those issue reports with the latest nightly build.

Edited by Guest

Share this post


Link to post
Share on other sites

In mine carbonrom 4.2.2 if i add this in build.proprio

persist.synopsis.zram=1

persist.synopsis.zram_size=128

persist.synopsis.ksm=1

persist.synopsis.frandom=1

The zram doesn't start

Bit ksm and frandom work correctly

Screenshot_2014_08_20_02_06_33.jpg

In /data/property i havent the persistente synopsis zram

Edited by luca020400

Share this post


Link to post
Share on other sites

Hi guys. One question. I installed the kernel, everything went fine.

But, what to do now?

What can I do to make the phone more smooth and that it runs i better performance? :D

Share this post


Link to post
Share on other sites

Get trickster mods from play store

Ok, will do.

After kernel install battery life is kind off poor, is this normal?

Share this post


Link to post
Share on other sites

Here: post-1040382-14086143114431_thumb.jpg

The battery % goes out fast, I think it got from 88% to 79% in like half an hour.

Share this post


Link to post
Share on other sites

I used my ROM for 2 days for testing purpose ( i usually use AOSP MOD) and i had not any problem of zRAM, you may need to use another script or it just has the wrong permissions

i discovered that changing lcd density to 233 causes that problem. it wasnt zram :S i dont know why happens maybe the huawei lockscreen dosent support somehow that change

Share this post


Link to post
Share on other sites

i discovered that changing lcd density to 233 causes that problem. it wasnt zram :S i dont know why happens maybe the huawei lockscreen dosent support somehow that change

 

It shouldn't have nothing to do with the LCD density

Share this post


Link to post
Share on other sites
Guest

so why reverting it to 240 fixes the problem?

 

Are you referring to the "deep sleep wake up issue"?

Share this post


Link to post
Share on other sites

Why do you put -p0 option on swapon command in zram script ??

The -p$ option is available only in the busybox paid version applets ..

 

 

I uploaded a zram script that is fully working http://luca020400.altervista.org/addon/Zram-enabler.zip

Edited by luca020400

Share this post


Link to post
Share on other sites

my phone kept the scree on for long time, actually he doesnt seen to turn off manually o.o noticed it right now

Share this post


Link to post
Share on other sites

my phone kept the scree on for long time, actually he doesnt seen to turn off manually o.o noticed it right now

 

Good to know that I'm not alone with this problem. I thought it was app related or something but it's probably not. The screen timeout is just being ignored and the screen stays on forever which is pretty bad if the screen turns on by accident in the pocket for example. I've never had problems with AOSP Mod before so I think this problem is probably related to the kernel.

Share this post


Link to post
Share on other sites
Guest

Becoming even weird. For some the phone doesn't wake up from sleep. For other's the screen doesn't turn off huh.png.

 

Could you please always post the date of the kernel build you are running?

Edited by Guest

Share this post


Link to post
Share on other sites

Ok seems to be only an issue with the UKSM build though it happened when KSM was disabled. Now with the latest stable it seems to work correctly again. Sorry for the fake alarm :D

Share this post


Link to post
Share on other sites

Latest is 17 Aug :huh:

Thats a nightly i think , anyway i will install that version

Share this post


Link to post
Share on other sites

No, he is referring to zRAM

no no not zram. when is set to 233 then i play music if the screen is on everything is ok but when i lock it the phone reboots, setting it back to 240 the problem disappear. before i was thinking it was zram that cause that but not. hope you understand me now :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.