Jump to content
Sign in to follow this  

[HELP] Coolpad 8730L Network settings

Recommended Posts

Hello there,

I think I have a little problem with my settings with my Chinese smartphone, he is compatible with almost all existing frequencies BUT there is a concern, I do not understand why my phone only displays almost the entire time that it is connected in 2G and 4G but I liked these quite annoying because 4G is not available everywhere in my country (Belgium, my operator is Mobile vikings - Base). I'm sure I set my phone to work with 2G/3G/4G 3 modes.

I do not understand why because my phone do CDMA and WCDMA my operator it is WCDMA.
So I try to look with Uncle Mobile Tools but I have no way to make the phone work with GSM / WCDMA / LTE the only option I have with the 3 mode does not include the WCDMA but CDMA.

Here are some screen to a better understanding of my problem.

My settings in setting app:


Photo : 1.png

My settings in mobile uncle is "unknow" :

Photo : 2.png


Photo: 3.png

My phone works on these band :
GSM band : 2/3/8
WCDMA BAND : 1/2/5
TD-SCDMA: 34/39
FDD-LTE : 7/3
TDD-LTE : 38/39/40

I really need help to have LTE/WCDMA/GSM in same time to have 3g fonctional when there is not 4g


Thanks you very much !!!!




Edited by Moijordan

Share this post

Link to post
Share on other sites

143 views and no answer this is really sad how people don't help other and are just here to dowload and read tuto without thanks ....

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.